Feb 2024 Cumulative Quality update fails to install (KB5034763) error 0x800f0831

Copper Contributor

The most recent quality update will not install.....I've tried running DSIM scan, restore, etc and it will not install.  Please WINDOWS, fix the update patch.  My laptop bogs down every time it tries to download and install this update. 


Anyone else have a similar issue or resolution that actually works?

5 Replies
Are you able to install other updates?
Have you tried Windows Update troubleshooter?

You may ask your question on:

@Reza_Ameri yes, several attempts to no avail.  Also ran the DISM scan health, clean ups, restore, commands through the CMD prompt and that didn't reset either.  Microsoft just needs to fix the issue and relaunch the quality updates



What build of Windows do you have installed?

Do you have a third-party antivirus?

February 13, 2024—KB5034763 (OS Builds 19044.4046 and 19045.4046) - Microsoft Support

Missing some early update:

Error 0x800f0831 when installing an update - Configuration Manager | Microsoft Learn

  I found this answer to seem helpful: Windows 10 update issue due to error 0x800f0831 - Microsoft Community


Hi there johnnyk_1985,

It finally got resolved!!!!!

But it succeeded after I disabled secure boot. So I toggled it the other way around. Anyway after at least 20 upgrade attempts in the last 4 months, with assistance from all over the place the only thing that really helped me out was to disable secure boot in the bios. All earlier attempts stranded in the famous second boot error and reverted back.

You are right, it's sometimes not an option to clean install a system. In this case I'm pretty sure I couldn't get the system in the same shape anymore after a reinstall. There were too many undocumented configurations and tweaks I did over the years. The system did fine, except it didn't accept upgrades anymore, until today.

I'm so glad I have this stupid issue behind me! Thanks again johnnyk_1985."

Make sure report this issue using the Feedback Hub app too.

@Reza_Ameri That was the first thing I did, then went into DISM scan health/restore, etc through the CMD prompt.

Still no resolution