Can't update to win 2004

Copper Contributor

I tried everything:

- I waited for normal Win update to tell me I can update to Win 2004

- clean boot

- disabled all devices other than boot drive, monitor and mouse

- downloaded the win update assistant and a local ISO

- tried sfc and DISM commands suggested in other posts


But, at the end of the upgrade after a reboot it goes through a recovery and takes me back to Win 1909.  

I ran SetupDiag but it said nothing matched a known error signature. 

Any other possibilities to try? 





2 Replies



Hey Charlie,


Just a shot in the dark here.

This exact thing happened to me 3-4 times over the years.


Short answer:


check for BIOS/Firmware updates from the laptop manufacturer and check for updated drivers from first the laptop manufacturer and if none available then the components in your laptop (IE- go to NVIDIA/AMD/Intel support sites, whichever your device is for graphics drivers and also for audio and communication device drivers. In rare cases you may need controller drivers especially on older machines.


My desktop, MSI Infinite X,  needed to be wiped (all my data/programs are backed up weekly just for this reason) completely and a new Windows 10 2004 install was done because it absolutely would not upgrade to version 2004 for me. The new install went without a hitch running from a USB stick.


Long drawn out detailed story about what I said above. For example.


Once it was because I had secure boot set and the BIOS was not letting the drive be altered in any way shape or form. That was about 6 years ago. I had to first disable secure boot, then re-enable it once more after the windows 10 install was completed. - probably not your issue, but worth looking into.


The other times ALL involved either outdated BIOS/Firmware OR outdated drivers.


For example, my wife's five year old MSI Apache Pro GE72 Leopard laptop would not install without the bios being updated. Luckily Windows TOLD us the laptop needed to be updated first. SO I looked into it and did the bios UPDATE and THEN upgraded the laptop to Windows10 2004 with no troubles after the BIOS update.


MY laptop however, is 6 years old and is an MSI GE60 Apache Pro.


I did the windows update and it failed with an error code. Forget what it was but I could find no trace of that error code anywhere on the internet.


I decided to use the Windows Upgrade Assistant tool. The Windows update assistant tool did everything including reboot and install right up to 99% completed, I was 1% away from logging in, sigh, then it hung fer a bit, then it said something went wrong and rebooted. When I logged back in I had the original Windows 1909 that I had before I tried to do the update. I am pig headed so I tried that, performing various troubleshooting tasks in between each failure for about 5-6 attempts or so. I was at it for a few hours before deciding it was ridiculous and I had better look into something else.


I went to the MSI support site to see if there where updates for my laptop, not expecting to find anything newer than 2016. However, there were indeed 3 updates available for my laptop. 1 BIOS update, 1 Firmware update and 1 touch pad firmware update. BIOS from, 2018, the other 2 from 2020 I believe.....


Since my EC (whatever that is) and my touch-pad were both working fine I figured BIOS update it is and I honestly felt that was all I would need. I tried the update using the Windows update assistant tool once more and once more if failed at 99% doing the reboot into my old windows version.


So, I  updated my EC firmware, tried the update, reboot into old windows version at 99% complete. Finally, I tried with no anticipation of it working the touch pad firmware update. By this time I had resigned myself to running Windows 1909 until security updates stopped and then who knows? I mean the laptop is still working great for what I use it for-why spend another $500-$1000 right?


After the touch-pad firmware update the laptop update itself to Windows 2004. What I mean by that is, as soon as the firmware update was done a reboot was required. During that reboot Windows Setup opened and completed my 99% install to %100 percent.


Weirdest thing I ever seen happen and it was, seemingly, because of a touch-pad firmware/driver conflict.





Thank you for the detailed reply.  I really appreciate it.  I seem to have the same symptoms, but alas the MSI cure didn't help.  My desktop computer is only 6 months old and there was nothing on the MSI site for it.  I think all my drivers are up to date.  And yet, it fails just like yours did 99% through the upgrade.  But, I don't get any error codes.  


I will keep digging...