User Profile
Kensapphire
Copper Contributor
Joined May 31, 2023
User Widgets
Recent Discussions
How to generate hash (SHA256) of file from Sharepoint or Onedrive using Microsoft Defender for Cloud
In an organization's Microsoft Defender for Cloud Apps, is it possible to generate file hash of a certain file located in Microsoft SharePoint Online or Onedrive by using Advanced Hunting? The sample query I found is pasted below, however, I don't know how to incorporate generation of file hash (SHA256). CloudAppEvents | where ActionType == "FileUploaded" and Application == "Microsoft SharePoint Online" | where ObjectType == "File" and ObjectName endswith ".xlsx" | project Timestamp, ActionType, Application, ObjectName, AccountObjectId, AccountDisplayName, IPAddress, CountryCode | take 5011KViews0likes1Comment
Recent Blog Articles
No content to show