Develop Ineo+ 258 - Size/Media Error when using Universal Print

New Contributor



We have setup Universal Print connector on Server 2016 and added our Develop printer. Whenever we print directly from the Server it works fine but printing via Universal Print always generates a Size/Media error on the machine. 


Tried both with and without Document conversion but no difference. 


The driver is Generic 36C-9SeriesPCL and is actually a Konica one I think since Develops are rebadged Konica Minolta machines. 


Print Model: Develop Ineo+ 258
Driver: Generic 36C-9SeriesPCL
Universal Print Connector: 1.14.7564.21701

Connector OS: Microsoft Windows Server 2016 Standard | 10.0.14393
Client OS: Windows 10 Pro 1909 | 18363.1198


Any advise appreciated as not sure what else to try atm. 

10 Replies
best response confirmed by GCSJordan (New Contributor)



What media size is present in the printer?  A4 or letter?


I have similar issues with Canon printers, they have A4 & A3 paper.  On the server with print connector the media sizes are detected by the printer driver, so they are set correctly to A4/A3.  


When registering the printer the media size in UP is set to letter, I have to change it to A4.  Then when printer is mapped, on the client it is still set to letter, I have to change it to A4/A3 per drawer.


Then I can print correctly.. I do not have this issue with HP universal driver or Lexmark universal driver. Even though they still are set to letter on both UP and the client, A4 prints correctly on the printer..


I think I'm experiencing the same thing. A4 but it was defaulting to Letter.

I changed it in UP and then locally on the machine as well and then it works. I tried removing on the local client and re-adding after changing in the UP portal but still the same until I manually set it under Printer Preferences -> Advanced.



Yeah it's annoying, I hope this gets fixed before UP leaves preview.. We're already using it as if it was in production..


I've been trying to open a ticket with MS for this but with our new partner it has become difficult to open a ticket..

Thank-you for your feedback on this issue.


Regarding the difference between A4 vs Letter, Windows OS has built-in logic to default the paper size based on the logged in user's regional settings.  For example, if the user's regional setting is one of the North American countries, then it'll set "Letter" as the default paper size.  Setting the country to one outside of North America would set "A4" as the default paper size.


As yourselves noted, users can manually override this in the printer properties.

Unfortunately, changing the setting in the Universal Print online portal doesn't affect the Windows client OS behavior.




Hi Jimmy

Thanks for input.

Unfortunately I don't think what you describe is working correctly which might be the issue. I'm in the UK and my region is set to United Kingdom. It still defaults to Letter for this.

@GCSJordan Thanks for the additional clarification.  I'll reach out to the product team and post an update when I hear more.

Hi Jimmy, thank you for explaining.

I'm in Belgium and my printers are defaulting to letter as well. I'm currently opening a ticket with Microsoft support for this.

@Jimmy_Wu Just wondering if this has now been fixed?
A User tried this today and much to my surprise worked first time :)



I know the root cause was thought to have something to do with the local pdf printer, returning letter every time.. but I haven't had time to test it myself.. 

We have now captured a number of known issues regarding Windows and Universal Print at Known Issues - Universal Print | Microsoft Docs.  One of the identified known issue is when the "Print to PDF" is set as the default printer, then when selecting any other printer will cause "Letter" to be the select paper size.  This may help to explain the experience some of you are seeing.


To workaround this problem, please manually set the default printer to something other than "Print to PDF".