Unable to download app package with specific user

New Contributor



I have set up a Microsoft 365 developer sandbox subscription with an instant sandbox to develop a Teams app with a bot and I am using the Developer Portal website.

Until yesterday I was able to download the app package and preview the app in teams while using the provided global admin account; which I will refer to as Ken.


As of today those actions fail as seen:

app package download failure.pngpreview in teams failure.png


I added a normal sample user; which I will refer to as Lynne; as owner of the app and when I log in as her to the Develop Portal, I am able to download the app package and preview in teams.

To rule out a problem with the global admin rights, I made Lynne global admin and made the original global admin Ken into a normal user and tried everything again, but Ken still has the failures and for Lynne it still works, also after making Ken global admin again.

It seems that it is not global admin related, but that overnight the Ken account has somehow become "corrupted"?


Any idea how I can resolve this?

9 Replies
I am also facing the same issue.
We are not able to download the app package.
We are looking into this, we will update you.

@Meghana-MSFT  Thanks for you response.

for your more information one of the API is returning 403 while landing on app overview screen.



and while perform "Submit App Update" or "Download App Package" the  following api's response are 500.





I can confirm that I see the same api responses.
We created an app in the Developer portal and added personal tab to it using Admin account. We were able to successfully download the manifest. Could you please confirm if this is what you are also doing?
My app also has a bot linked to it, but it does indeed have a personal tab since the bot is personal scoped.
As of today, I am again able to download the app package with the Ken admin account.
I didn't change anything since last Friday, so I don't know what fixed it.
best response confirmed by KenDB (New Contributor)

Thank you for confirming. Engineering team has investigated and mitigated the issue on Friday 6/17.
403 on appDefinitionItem is expected on non-msft tenant, that is by design for now.

If the response is helpful, please click "**Mark as Best Response**" and like it. You can share your feedback via Microsoft Teams Developer Feedback link. Click here to escalate.

Yes i am doing the same process.