Microsoft Tech Community Live:  Microsoft Teams Edition
November 09, 2021, 08:00 AM - 12:00 PM (PST)

Teams Image sent by chatbot no open after update

%3CLINGO-SUB%20id%3D%22lingo-sub-2842577%22%20slang%3D%22es-ES%22%3ETeams%20Image%20sent%20by%20chatbot%20no%20open%20after%20update%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2842577%22%20slang%3D%22es-ES%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1092873%22%20target%3D%22_blank%22%3E%40HunaidHanfee-MSFT%3C%2FA%3E%20%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%20Hello%2C%20we%20had%20the%20same%20problem%2C%20but%20as%20of%20today%20without%20making%20any%20changes%20with%20the%20teams%20version%201.4.00.2879%20of%207%2F10%2F2021%20the%20images%20began%20to%20be%20sent%20correctly%2C%20but%20when%20clicking%20on%20them%20they%20do%20not%20open%2C%20on%20the%20web%20and%20mobile%20app%20open%20correctly%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Eteams%20desktop%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22rosrene_2-1634140587219.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F317089iB62883DB3F10219D%2Fimage-size%2Fmedium%3Fv%3Dv2%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22rosrene_2-1634140587219.png%22%20alt%3D%22rosrene_2-1634140587219.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ETeams%20Web%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22rosrene_3-1634140587083.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F317090iC4748B625C269DD4%2Fimage-size%2Fmedium%3Fv%3Dv2%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22rosrene_3-1634140587083.png%22%20alt%3D%22rosrene_3-1634140587083.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20do%20not%20have%20a%20previous%20version%20available%20to%20test%2C%20but%20this%20worked%20and%20it%20stopped%20working%20a%20few%20days%20ago%20together%20with%20the%20shipment%20without%20any%20change%20on%20our%20part%2C%20any%20ideas%3C%2FP%3E%3CP%3EThank%20You%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2842577%22%20slang%3D%22es-ES%22%3E%3CLINGO-LABEL%3Echat%20bot%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ETeams%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2845153%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20Image%20sent%20by%20chatbot%20no%20open%20after%20update%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2845153%22%20slang%3D%22en-US%22%3EThanks%20for%20sharing.%20I%20am%20looking%20into%20this%2C%20I%20will%20get%20back%20to%20you%20soon.%3C%2FLINGO-BODY%3E
Occasional Contributor

@HunaidHanfee-MSFT Hello, we had the same problem, but as of today without making any changes with the teams version 1.4.00.2879 of 7/10/2021 the images began to be sent correctly, but when clicking on them they do not open, on the web and mobile app open correctly

 

teams desktop

rosrene_2-1634140587219.png

 

Teams Web

 

rosrene_3-1634140587083.png

 

I do not have a previous version available to test, but this worked and it stopped working a few days ago together with the shipment without any change on our part, any ideas

Thank You

3 Replies
Thanks for sharing. I am looking into this, I will get back to you soon.
The image is sent as inline attachment?

@HunaidHanfee-MSFT Yes, we send it as an inline attachment and we have also tested with the public url in both cases the behavior is the same

I share some images:

 

method call

rosrene_0-1634214161525.png

 

return GetReport

rosrene_1-1634214205514.png

-----------------------------------------------------------------------------------------------

Inline test (microsoft example)

 

rosrene_2-1634214256800.png

 

the bot returns the image but it cannot be opened, this verification only occurs in the desktop teams client, in the web and mobile client it opens correctly

 

rosrene_3-1634214379717.png

Microsoft sample document Send media attachments with the Bot Framework SDK - Bot Service | Microsoft Docs

 

Thank you