How to resolve "Failed to submit this app" error?

Occasional Contributor

Hi Team,

Just from Today, while submitting teams custom app via Developer Portal, error "Failed to submit this app." started to occur.

 

yuu113_0-1649387976641.png

 

I have tried with below condition but this error always occurs. Error also occurs on the app which we can submit update till yesterday. What is happening and how can we resolve it? (from this error message, we couldn't guess anything about the reason..)

 

Checked:

・Publish from outside Developer Portal (apps > manage apps > send app to organization) succeeded so seems Developer Portal related Issue.

yuu113_0-1649389826980.png

 

・For all apps, no validation error in "Publish to store" is found. Manifest itself seems to be fine.

・Create new custom app with minimum configuration and publish but failed with same error.

・Tried publish from both Teams client and Browser but failed with same error.

・Try same operation with different tenant but failed with same error.

 

20 Replies
@yuu113-Could you please share the manifest json ,so we can try it from our end?

@yuu113-We are able to repro the issue. we are checking with internal team and let you know.

Same issue on my side... tried everything..

@yuu113 

Same here.. i've tried everything.. couple of weeks ago everything used to work fine but starting from last week creating new apps and uploading it to my company's org seems impossible.

  • I've tried creating the app fro developer portal from scratch and publishing it to org .. have submit error knowing that i have 0 errors in manifest validation.
  • I tried adding an already downloaded up and uploading it to the org.. same error..
  • PS : I have 2 applications that i've created month ago and they still working and i have no problems adding/uninstalling it. Weird thing is, when i've tried to update one of them by just changing personal tab url the error appeared again and i couldn't submit it again.
  • There's no further details about the error which sucks!
  • Screenshot 2022-04-11 at 5.42.43 PM.png

Screenshot 2022-04-11 at 5.37.25 PM.png

I'm having the same issue since Friday.

Our internal team is working on it. we will update you once we get any updates.

Issue is resolved. Could please check with the updated version of teams.
Microsoft Teams Version 1.5.00.15719 (64-bit)-E.

@Sayali-MSFT 
I'am facing this error too, this monday (13 Jun)

Even if I try to use Developer portal from teams app (latest version, that installed with "check for updates" is Microsoft Teams Version 1.5.00.14473 (64-bit)) or via Web browser - I still got 500 error accessing
GET https://dev.teams.microsoft.com/emea/api/appdefinitions/3ce2b9f5-b950-404d-b33d-367cdad95860/manifes...

@Rick_ILM- It looks like updated teams version is not rolled out publicly .In the upcoming version you will get fixes regarding this issue.

@Sayali-MSFT Second try allow me to update client up-to  Microsoft Teams Version 1.5.00.15973 (64-bit). 
But problem still persist.

Anyway, I can't understand, why https://dev.teams.microsoft.com/apps - depend on version of installed microsoft client ?
I can get same error on PC without MS Teams installed, just with web browser.

@Rick_ILM-We will check it and let you know.
@Rick_ILM- We are check this with Web.It's working fine from our end. Could you please check it once? have you tried the same as below?
https://youtu.be/yGxISWpTe4M
@Sayali-MSFT, here simple upload/download test with teams sample app
https://emalm.com/?v=dmEVD

@Rick_ILM -Tried with same. It's working fine.
dev.png

@Sayali-MSFT I am getting the same issue as @Rick_ILM, however a developer in our org with the exact same permissions is not seeing the error. The most frustrating part of this is that the network request to /emea/api/appdefinitions/... is 500'ing without any error information.

@yuu113 

I am also having the issue while download the App package

Digitallalit1_0-1655443860667.png

Even in case of publishing to org also getting error message without details.

Digitallalit1_1-1655443938337.png

 

 

 

 

Hi, This seems like a bug. We have raised the bug with concerned team.

Thanks

@Sayali-MSFTThanks for you response.

for your more information one of the API is returning 403 while landing on app overview screen.

Digitallalit1_0-1655460650931.png

 

and while perform "Submit App Update" or "Download App Package" the  following api's response are 500.

 

Digitallalit1_1-1655460931109.png

Thanks

 

@Sayali-MSFT I am having this exact error, can you please send me the dev teams email.