Deep link from Chat to Tab does not work on Android

Copper Contributor

Our app creates a deep link to a personal tab in Conversation (chat) tab.

On android devices, clicking the deep link causes not switching tab (from Conversation to the personal tab), but an error message "Sorry, we cannot take you to this destination at this time" only.

On iOS device, the deep link works. 

I think this is an issue of Android Teams client and should be fixed, but is there any workaround?

10 Replies

@thonda We could not repro the issue with Deeplinks to personal tab on android. Which version of teams are you using? Could you please try updating your app to the latest version and see if that fixes the issue?

@Gousia_Begum I have updated the app to version 1416/, but our app cannot be used on the version.

Our app is under AppSource registration process and can be used as custom app.

It can be used on PC Teams client, but has disappeared on the personal app list, while messages from our app (bot) are displayed on Chat.

I tried re-login procedures, but the problem did not improve.

@thonda Could you please check if you are able to view developer preview on mobile?


I tried to select link with developer preview setting enabled, but the error message ("Sorry, we cannot take you to this destination at this time") was displayed.

Now our app is displayed on the personal tab on Android device, but Deep link from Chat to Tab does not work yet.

@thonda Could you please share the deeplink that you are using?



The deep link is like this:

"755e...f02f" (omitted here, but actually long ID string without "...")
is app id of our app (now custom app).
"default-data" is entity ID of a specific tab.

@thonda did you managed to resolve this issue on Android devices and can you share the solution?


We face similar issues within our Personal Tabs on Teams for Mobile for Android but everything works  on IOS devices.

@Gousia_Begum I have two separate apps that I'm developing, and both have a bot and a static tab. The 2nd app -also- has a configurable tab (in case that's relevant...). Both apps were also developed in much the same way, and both are side-loaded to the same test user. 

HOWEVER - I can consistently reproduce the following:
 - App1 works fine to deep link to it's static tab, on desktop (web) and on Android
 - App2 works fine to deep link to it's static tab, on desktop (web) and consistently fails on Android, with the same error as the original poster.

Here's the deeplink syntax for both (modified to post here). Notice that app1 (the working one) has a space in the "label" field, in case that's relevant. Both are using an Adaptive Card "OpenUrl" action.

I've also tracked the payload, using Fiddler, and both are practically identical (there's some different data in the Adaptive Cards, relevant to each app, but the "Action.Submit" is essentially identical).

So, I've got a good test scenario if anyone from the Teams team wants to look more into this? I've also saved the Fiddler traces if that helps, albeit that the apps are not in the store (yet), but can be side-loaded if desired to investigate further.

@Freddy Bang 

Our app has been published in Teams AppSource, but this issue has not been solved yet.




It appears that on the web and desktop app the address works as:


But on the android app the address works as: