App works on desktop but not on mobile

Brass Contributor

We added an app to our own organization. It works on the desktop client but not on the mobile client.
I see the app but when I open it, it just stays black.
We use the loginHint in the contentUrl.

We use the following config for the staticTabs:
"staticTabs": [
"entityId": "de.someid.startTab",
"name": "App Name",
"contentUrl": "https://server/appname/app/teams?uid={loginHint}",
"scopes": [

18 Replies
I am trying to repro this issue with the custom app. Will update you soon with the findings.

I tried this and it was working fine on mobile as well. Which mobile OS you are facing this issue on? Could you please share version of OS as well Teams?

Any updates on this issue?


It's Android 11 with MS Teams Version 1416/

Could you please check if you are getting any error with DevTools for Android -


I have activated the Developer Preview of my Teams Client on the Android device but I could not see the Teams App:



@relkniw - That's weird, can you please try signing out and login back into the Teams mobile client. Can you check if you can access Teams on browser?



 Now I see my application, but if I inspect it nothing is displayed: no Elements and no Console output.










Can you check if app is working when accessing Teams on web browser -


I tried with a Samsung S20 5G and Android 11:

- Chrome 95.0.4638.74

- Firefox 94.1.2

- Samsung Internet

- Edge


and a Apple iPhone 11 integrated Browser.


I always get the message that the browser version is not supported and to download the app.



Thanks for sharing the information.
We have tested this scenario with the HelloWorld application and faced no issue on Desktop as well as on mobile both Android and iOS. Could you please share the manifest with the actual URL that you are using(if possible). So that we can test this out at our end and check what is going wrong.
About testing on browser, I meant to check it on Desktop Browser not mobile. Can you check it once and see if it is working?

I have send you a private message with the manifest.json file.

Yes it works on Desktop Browser.

We can see it's not working on mobile even after adding the domain in valid domains. Can you please share how you are authenticating the app? When tried to access it was asking for some PIN.

Need your input to understand it accurately.


We are using adfs for the authentication.

Did you get the PIN query on the mobile or on the desktop?


On desktop only. I will confirm internally if that is the reason why it's not working.
best response confirmed by ChetanSharma-msft (Microsoft)
For AAD related issues you can reach out to





are there any news to that issue?

The answer from Prasad_Das-MSFT does not help in any way. So I don't know why ChetanSharma-msft confirmed it as best answer.

We do not use Azure AD.





@relkniw - As discussed earlier that you are using adfs for the authentication, Please reach out to AAD team (Azure Active Directory Support) or whoever owns this AD FS flow. This is not something that the Teams Platform has any expertise or insights on.

1 best response

Accepted Solutions
best response confirmed by ChetanSharma-msft (Microsoft)
For AAD related issues you can reach out to

View solution in original post