Surface Hub Reverts to Skype Mode

Occasional Contributor



We have three Surface Hubs that we have provisioned via Intune to be in Teams Mode only.  A lot of times in the morning when someone first uses a hub it has reverted back to Skype Mode and does not show the Teams icon.  To fix this we usually have to restart the hub.  I believe this is happening because our hubs go through Cisco ISE on our network here at work for authentication and they are losing their network connection overnight when they are sitting there not being used and going back to Skype until it has to be restarted and re-authenticated on the network.  Has anyone ever run into an issue like this and is there a way to resolve this on the Hub side or do you think this is more of a network/authentication issue?


Thank You,


11 Replies



The device shouldn't revert to Skype mode, even if it cannot connect to Teams on Office 365.

Regardless, there's a daily maintenance window that should reboot the device overnight.

If this is something you're experiencing with only one Hub I suggest to log a ticket with Microsoft Services so they can look at the logs.

@Damon Tyler we have the exact same issue with 3 Surface Hub 2s's. Configured via Intune, randomly revert to Skype. 



Same issue here. We have 30 Surface Hub 2s and randomly, some Surface Hubs revert back to Skype. Sometimes we can fix it by just rebooting the device, sometimes not. Our Surface Hubs are all managed in Intune, On premise AD joined, Teams preferred mode and connected to the network by Wifi WPA2 enterprise. We are running these hubs since few month and we never had this issue before around the 28th september.


I can see this in the event viewer :


Activation of application Microsoft.MicrosoftTeamsforSurfaceHub_8wekyb3d8bbwe!Teams failed with error: -2147009284 See the Microsoft-Windows-TWinUI/Operational log for additional information.


and in the TWinUI/Operational log :


Microsoft.MicrosoftTeamsforSurfaceHub_8wekyb3d8bbwe!Teams for the Windows.Launch contract failed with The deployment operation failed because the specified application needs to be registered first..


Activation for Microsoft.MicrosoftTeamsforSurfaceHub_8wekyb3d8bbwe!Teams failed. Error code: The operation completed successfully.. Activation phase: -2147009265


Best regards,




@Cyrille_D we had another one do this, and going into Apps Teams was greyed out, and clicking on it said it had to be reset (which did nothing). We just uninstalled it and reinstalled and that fixed it. This happened in the CEO's office, so to say he was unimpressed that the one thing the Hub is supposed to do well (Teams) didn't work is an understatement.

Considering how much these things cost, they should be far more reliable.

Sure, I have a ticket opened at Microsoft (premier support) since few days regarding this issue and still waiting for a feedback...
This behavior can be observed when Teams is trying to connect to Office 365 but unable to do so. You'll usually see this when the device wakes up from sleep if getting back on the network is slower than the Teams app attempt to sign in.
To work around this behavior, you can switch to Teams Mode 2, or update to the Windows 10 Team 2020 Update where this behavior doesn't exist.
Thank you for the update, we'll probably switch to mode 2 if the problem doesn't exists in this mode.

@Cyrille_D we have the issue in mode 2

Anyone have insight on a resolution for this? Just discovered this is happening on some of my SH1 devices. Going through Cisco ISE. Using Mode 1. A reboot, and they are back to using Teams. Since the office is so empty I haven't even checked if they revert by the end of the business day, or if it is happening overnight.
This should be fixed in the 20H2 update, we had no issue since the update but as you said, our offices are also empty.


Thank you so much for the reply! 

I had tried the 20H2 update about two weeks ago to pre-emptively move to Modern Auth. But I was having trouble with my accounts disconnecting after setup. So I rolled those devices back. I have no idea if they were doing this before, and maybe I'm just noticing since they are more visible to me?


I'm new to SH devices so we'll try 20H2 again soon on a test device.