SP2019 Server Quick Launch Nav missing on Modern sites after Aug CU patch install

Copper Contributor

Installed KB4484472 yesterday on SP2019 Server.  Users today started to complain that the Quick Launch navigation on Modern sites is no longer visible.  Is anyone else experiencing the same issue and have you been able to resolve the issue?  It appears that Chrome and IE browsers are only affected.  Using Edge browser seems to display the navigation.

This is the expected look:



This is the current look:



Thanks in advance for any insight into this matter.

40 Replies
I believe I have read somewhere there was a problem with the CU released in September

@David Graham Hi, we're also experiencing this issue.  Does anyone know if this gets resolved in the Sep update ?

I have same issue after installing KB4486676. Anyone have solution?



I have the same issue with our SharePoint 2019 environment after installing kb4486676 October CU.

Anyone else found a solution? Our workaround is to change the default navigation from Home.aspx to Documents.aspx

This affected the whole farm (thousands of sites)

I found others with similar issues



but no solution

Missing left navigation in 3 consecutive patches.  You would think MS devs and testers would have noticed this by now.  Real slack units.


Can anyone confirm if the Nov patch fixes this ?

@nick_trinidad After opening a case with MS, they recommended instsalling the following KB



From <https://support.microsoft.com/en-us/help/4486675/october-13-2020-update-for-sharepoint-server-2019-l...>

It resolved the issue



This did not work or us.


It seems to be related to the edit/publish options in the grey bar that goes above our news content. Every single site page with edit/publish is affected. The javascript is a mess of errors when you view the code on the page. 


Other documents, or system pages show the modern menu just fine but this is not how sharepoint is typically viewed by most people in an organization.  We're about 2 seconds away from just switching to dokuwiki or something else. This has been weeks.



We installed the November CU. Still same problem. The Nav is available on Google Chrome and the old IE11.

Please Microsoft  fix this problem!

Same here after installation of Dec CU. Microsoft please fix, thanks!

December update applied.  No fix still.

Installing KB4486675 did the trick for me!

.. and remember PSConfig :)

I just installed a new SharePoint 2019 Farm with the Dec 2020 CU using the AutoSPInstaller.com powershell installer and I am seeing the same thing.

The powershell installer choked and I had to setup the Default Site from the SharePoint Central Administration site.  Any site I create has the same issue.

Installing KB4486675 did not fix it.

Oddly enough, the MySites web application work fine.



@David Graham We have also been affected by this issue for months! I finally got fed up and did some sleuthing in the code. It seems that the sp-pages-assembly.js file got replaced by a newer version which is creating most of these issues. 


I will preface this by saying, always make backups before you try unverified solutions such as this one. I did such by copying the files I would be replacing in a backup directory, in the case that I need to revert back later. 


In this directory:

C:\Program Files\Common Files\microsoft shared\Web Server Extensions\16\TEMPLATE\LAYOUTS\Next\spclient


There are some layout folders. One labeled 'default' and one as 'en-us'.  'en-us' in the URL pointed me to that folder as holding the offending file. In the console, it kept saying 'cannot read property 'call' of undefined' stemming from this file:



So I replaced the sp-pages-assembly.js file in the 'en-us' folder with the older file in the 'defaults' folder. (After backing it up)


After this, the navigation came back. There are some things that still don't look right as labels aren't being updated from machine labels for example. but the navigation is back and we can edit modern pages again. 


You may also need to open a CMD as Admin and run IIS reset as well as doing a hard reload on the site to get the updates to appear as caching can keep you from seeing the changes until then. 


It seems that the navigation missing could be stemming from an issue with the publishing bar on modern sites as the navigation would appear again if I was in a list, that uses the modern layout but has a list bar instead of a publishing bar. 


It's not perfect, but it's at least usable again.

Tried replacing the requested JS file but no luck , wondering if there is proper fix from Microsoft , its being couple of months now .




@MSaeed7 - Hello everyone, we are facing the same issue too. I installed the latest Dec 2020 KB hoping that would resolve the issue but it didn't. I haven't installed the Oct 2020 KB at all.. Can I install the Oct 2020 KB now? or will this impact the farm ?any help is greatly appreciated.

@dmonnala We had the same problem with the December CU already installed. The solution was probably to apply the October and November patches, which also works when December is installed. It is important that you install the multilingual update for your language and not only the core.


So you have to install KB 4486715 instead of KB 4486714.


I just applied the january security patch KB4493161. had the same issue until I cleared my browser cache.

Today I tried installing the January 2021 CU on all my SharePoint 2019 Servers and the problem still exits.

It will not let me install the October or November 2020 CU updates.  I'll guess it's because these are Cumulative Updates and you should not need to install anything but the latest update.

@rukueu  Thank you for your response. So the Jan 2020 CU worked for you after clearing the cache? that's great to hear. Did your others users confirmed the same too?