SharePoint 2019 On Premise not sending Alerts

%3CLINGO-SUB%20id%3D%22lingo-sub-2683932%22%20slang%3D%22en-US%22%3ESharePoint%202019%20On%20Premise%20not%20sending%20Alerts%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2683932%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20a%20SharePoint%202019%20On%20Premise%20single%20server%20farm%20(our%20dev%2Ftest%20environment)%20that%20is%20sending%20emails%20if%20they%20are%20generated%20by%20workflows%20but%20the%20out%20of%20the%20box%20alerts%20are%20not%20working.%26nbsp%3B%20I%20can%20see%20the%20alert%20created%20and%20added%20to%20the%26nbsp%3BImmedSubscriptions%20table%20but%20they%20are%20just%20not%20sending.%26nbsp%3B%20It%20happens%20to%20all%20users%20and%20all%20site%20collections%20in%20the%20farm.%26nbsp%3B%20I%20have%20doing%20everything%20in%20these%20articles%20but%20still%20cannot%20get%20them%20to%20work.%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fsocial.technet.microsoft.com%2Fwiki%2Fcontents%2Farticles%2F13771.sharepoint-troubleshooting-alert-email-does-not-go-out.aspx%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3ESharePoint%20Troubleshooting%3A%20Alert%20Email%20Does%20Not%20Go%20Out%20-%20TechNet%20Articles%20-%20United%20States%20(English)%20-%20TechNet%20Wiki%20(microsoft.com)%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fwww.sharepointdiary.com%2F2012%2F02%2Fsharepoint-alerts-not-working-troubleshooting-checklist.html%23%3A~%3Atext%3DSharePoint%2520Alert%2520Notifications%2520Not%2520Working%2520-%2520Checklist%2520for%2CSharePoint%2520to%2520Send%2520Mails%253F%2520...%2520More%2520items...%2520%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3ESharePoint%20Alert%20Notifications%20Not%20Working%20-%20Checklist%20for%20Troubleshooting%20-%20SharePoint%20Diary%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fsharepoint%2Ftroubleshoot%2Fsites%2Fno-alert-notifications%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3EUsers%20don't%20receive%20SharePoint%20Online%20alert%20notifications%20-%20SharePoint%20%7C%20Microsoft%20Docs%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAnyone%20have%20any%20other%20suggestions%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2683932%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ESharePoint%20Server%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2684243%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%202019%20On%20Premise%20not%20sending%20Alerts%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2684243%22%20slang%3D%22en-US%22%3EI%20have%20also%20verified%20that%20the%20Immediate%20Alerts%20Timer%20Job%20is%20running%20however%20it%20is%20taking%20zero%20time%20to%20run.%20I%20have%20also%20verified%20that%20this%20same%20issue%20occurs%20in%20our%20new%20Production%20environment.%3C%2FLINGO-BODY%3E
Occasional Contributor

I have a SharePoint 2019 On Premise single server farm (our dev/test environment) that is sending emails if they are generated by workflows but the out of the box alerts are not working.  I can see the alert created and added to the ImmedSubscriptions table but they are just not sending.  It happens to all users and all site collections in the farm.  I have doing everything in these articles but still cannot get them to work.  

 

SharePoint Troubleshooting: Alert Email Does Not Go Out - TechNet Articles - United States (English)...

 

SharePoint Alert Notifications Not Working - Checklist for Troubleshooting - SharePoint Diary

 

Users don't receive SharePoint Online alert notifications - SharePoint | Microsoft Docs

 

Anyone have any other suggestions?

3 Replies
I have also verified that the Immediate Alerts Timer Job is running however it is taking zero time to run. I have also verified that this same issue occurs in our new Production environment.
We finally figured this one out. SharePoint 2019 Outgoing Email settings has a new feature to use TLS Security or not. When we turned this off our alerts started flowing.
Obrigado David por reportar sua dor e soluciona-lá. Até o momento meus alertas voltaram a funcionar! Abraço.

Thank you David for reporting your pain and solving it. So far my alerts are working again! Hug.