content type hub url - SPO admin but "waiting for access permission"

Brass Contributor

Hi there I became a SPO admin in my organization three days ago, and whenever try to access our URL I get a "you need permission to access this site" and, under, a "waiting for approval" since 12 days.


In SPO Admin Center I checked the active sites' list to find some "contentTypeHub" therein but there's not, neither is in the deleted sites' list as well.


This has impacted me as I set a site as a hub and created some content types but am not able to publish them: whenever I go to a content type I've created (where its columns are defined) and click in the link "Manage content type publishing", comes a 403 Forbidden page.


Where such kind of "approval requests" can be found and verified to allow the access? TIA


Btw I've also checked in our classic SPO admin center and both options about custom scripts are turned on. And since I cannot access the contentTypeHub site, I cannot provide a screenshot of the permission on that site neither its access access permission requests (IF that site still exists, since is not in the active sites' list as I've mentioned)



10 Replies

Hi @mescwbif,


Can you publish content types on Content type gallery on SharePoint admin center?



@Matti Paukkonen nope, it doesn't show any in the list and if a click the + to create it gets stuck in the "waiting" circle as in the ig I've attached here

@mescwbif Hello,

Please try the filter option when you look through sites on SharePoint Admin Center.
Classic sites are not shown by default, you will need to activate that filter.

Yours sincerely,
Aref Halmstrand

@ArefHalmstrand thanks I had already tried that to see if the contentTypeHub site would show up in classic sites' list in SPO classic admin center... and no, it's not listed there, as much as isn't in modern admin center site' lists, even in the deleted sites' list - picure attached.


seems that it's just evaporated


moreover, today so to make a test I tried to manually create a site called contentTypeHub and after I confirm the default address (same as site name) SPO gets stuck forever in the "verifying":



@mescwbif Try solving it with PowerShell,

Add-SPOUser -Site https://<tenant> -LoginName <youradminaccount> -Group "<owners>" 

NOTE! AFAIK the site is based on classic sites so it can be wise to check the permissions group that exists by default on a classic site. Probably something like: "contenttypehub owner".

Yours sincerely,
Aref Halmstrand



Update: any PS get or set stuff I try on contenttypehub site collection returns "server exception", "not supported", for instance:

Set-SPOsite -DenyAddAndCustomizePages 0
Set-SPOsite : The requested operation is not supported for site:
In line:1 character:1
+ Set-SPOsite -De ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : NotSpecified: (:) [Set-SPOSite], ServerException
+ FullyQualifiedErrorId : Microsoft.SharePoint.Client.ServerException,Microsoft.Online.SharePoint.PowerShell.SetSite


regarding add-spouser, I make no idea what the group name would be since it would carry in the contenttypehub site collection title and I don't know how such title would be (I tried to google it to no avail)


I work across multiple organisations and tenancies. I've had this crop-up in a few tenancies recently. It looks like there's been a change in the way Microsoft interprets the assigned admin roles.


In orgs where it doesn't work the access has been assigned 'SharePoint admin' role, but is not in the CTHub site-collection admins


When I check tenancies where it is still working, I can see that the site-collections admins has both:

  1. Company Administration (special role)
  2. SharePoint Service Administrator (special role)DuncanH910_1-1612473547592.png

and checking my access rights on the ContentTypeHub I can still access shows I'm listed as site-collection admin.


I'm still investigating, but its looking suspiciously like its a symptom of the fiddling Microsoft has recently done with the admin roles :(


The 'hanging-screen with no details in the Content Type Gallery UI:


is a symptom of your access-rights being denied - this is because this UI is just skin over the old ContentType Hub site page.


If you are still experiencing the issue raise a ticket with Microsoft Support on your tenant - links via admin portal. 

@DuncanH910 thanks for your time. We've an A1 plan, hence the support is free - best effort and after creating a case and working with them the solution found was to have me added to company admins group and use only the built-in contenttypehub site collection to publish content types to other collections. No solution was found to publish types from another additional site hub, which makes null all MS online documentation regarding this possibility (it's even stated that one could create up to 2000 hub sites...). It's a pity since we were evaluating SPO as an option to manage our documents and we need a way to segregate content type creation among different teams. That said, we were forced to discarded SPO as a viable solution and go with some other solution, probably SpaceDoc. Unfortunately.

@mescwbif I'm about a year late here but I've just had the same issue and found your post.


As you are a SharePoint admin you can navigate to the following URL and give yourself access


I tried all sorts of things but this seems the easiest.


P.S I found it on this blog  seems to have been a problem since 2014! - Thanks Jasper

Brilliant! This worked perfectly.