Cannot SET AUTO_UPDATE_STATISTICS and AUTO_UPDATE_STATISTICS_ASYNC status to FALSE.

%3CLINGO-SUB%20id%3D%22lingo-sub-2964483%22%20slang%3D%22en-US%22%3ECannot%20SET%20AUTO_UPDATE_STATISTICS%20and%20AUTO_UPDATE_STATISTICS_ASYNC%20status%20to%20FALSE.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2964483%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3EHave%20been%20using%20SharePoint%202016%20with%20SQL%20Server%202016.%20For%20compliance%20issues%2C%20we%20need%20to%20set%26nbsp%3B%3C%2FP%3E%3CP%3ESET%20AUTO_UPDATE_STATISTICS%20and%20AUTO_UPDATE_STATISTICS_ASYNC%20status%20to%20False.%26nbsp%3B%3C%2FP%3E%3CP%3EWhenever%20we%20set%20to%20false%20its%20automatically%20back%20to%20True%20after%20certain%20time.%20We%20don't%20have%20any%20SQL%20Server%20Agent%20Jobs%20running.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EMy%20DBA%20suspect%20this%20could%20be%20due%20to%20some%20hardening%20settings%20at%20SharePoint.%20If%20anyone%20knows%20the%20solution%2C%20Please%20advise%20how%20to%20resolve.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2964483%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ESharePoint%202016%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Server%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
New Contributor

Hi,

Have been using SharePoint 2016 with SQL Server 2016. For compliance issues, we need to set 

SET AUTO_UPDATE_STATISTICS and AUTO_UPDATE_STATISTICS_ASYNC status to False. 

Whenever we set to false its automatically back to True after certain time. We don't have any SQL Server Agent Jobs running.

 

My DBA suspect this could be due to some hardening settings at SharePoint. If anyone knows the solution, Please advise how to resolve.

0 Replies