Sharepoint SPSE and oidc with identity server failing

New Contributor

we've configured Sharepoint SE to connect to the identityserver following https://docs.microsoft.com/en-us/sharepoint/security-for-sharepoint-server/oidc-1-0-authentication

we've performed the trust by automatic metadata endpoint

the token returned from the idp seems fine

 

we are able to logon successfully but the web application gets trapped in an infinite loop to the idp url

the token passed seems fine

 

but we have an exception in the following call

SPFederationAuthenticationModule.OnSignedIn: /sites/redacted_cert/_layouts/15/Authenticate.aspx?Source=%2Fsites%2Fredacted%5Fcert UrlPathDecode Fail. Error: System.UriFormatException: Invalid URI: The format of the URI could not be determined.
at System.Uri.CreateThis(String uri, Boolean dontEscape, UriKind uriKind)
at Microsoft.SharePoint.IdentityModel.SPFederationAuthenticationModuleV2.OnSignedIn(EventArgs eventArgs)

after these error we get a 302 and the loop continues indefinitely

Has anyone any idea of what could be the issue?

the farm build is '16.0.14931.20284'

1 Reply

Hi @Andrea Dal Farra, sorry to hear that you're having difficulty getting OIDC configured successfully with your identity provider. Unfortunately this isn't enough information for us to go on to investigate this issue.  We'd need to understand what your repro steps were, your full ULS logs, and a capture of the looping requests in Fiddler or similar web debugging tools.

 

I recommend opening a support case with Microsoft Support so they can work with you to collect this information and pass it on to the SharePoint team for investigation.