Teams integration: Hiding the O365 header in project roadmaps

Frequent Contributor

It is possible to implement a project roadmap in a Teams tab to simplify communication. Simply open the roadmap, then copy the URL from the address bar and add it as a website tab in Teams.

By adding "&dynamicsUI=true" to the URL, you can even hide the O365 header.


18 Replies

@Trutz Stephani I am trying to add to a teams channel. Is there a way to add &dynamicsUI=true to the URL to remove the O365 header?

Hi @locious 

The parameter works only for the "Roadmaps" feature, not for "Project Home".

But the parameter works also for the new Project for the Web

@Trutz Stephani the URL I provided earlier is the new project for the web. Bus i still can't get it to work. Have you been able to?

Hi @locious ,

Yes that worked for me.


The O365 bars and only hidden when embedded in Teams or a model-driven app. If you use the URL directly in the browser, the sidebars and header appear nonetheless.



@Trutz Stephani I am asking if it will work on this url:


I already am familiar with adding it to an in individual project URL such as the one you just provided.

Hi @locious ,

It seems then we both completely misunderstood each other.

The parameter doesn't work for the Project entry page, which is the URL you supplied.

Hi Trutz - I'm trying adding "dynamicsUI=true" to the URL in MS Teams and it's not working (I'm adding the project as a website app in MS Teams). Am I missing something...?

Hi @michelbehr,

Adding the parameter with a & character after the guid of the project should be all that's needed.

Be aware that you no longer need the workaround as Microsoft released 2 apps to solve the integration.

Roadmaps and Project app for Teams integration:

New apps in TeamsNew apps in Teams







Just add the apps to your teams as tabs and then select a project that you want to integrate.


@Trutz Stephani Thank you for your quick reply!

The 'project' app for MS Teams only works for Standard Channels, but I need to use in the context of a Private Channel, so I think I have to use the 'website' app instead, I can't see an alternative.

Regarding your reminder of adding '&', yes, that's how I'm doing it, but the header persists:




Hi @michelbehr,

I just tested it again with a website tab in our tenant in a private channel and a normal one and it worked without an issue.

Maybe it is something to open a ticket for. Does the embedding work when you open the project via the default Power App "Projects" when navigating to

@Trutz Stephani OK, good to know, we'll probably figure it out then - below some evidences of current behavior:


#1 Trying "&dynamicsUI=true" with dynamics website" -> error message



In browser we see the same result:


The original URL is this one:




#2 Trying to add 'project' app as new tab in Private Channel -> 'project' app is not presented



#3 Trying to add 'project' app as new tab in Standard Channel -> 'project' app is presented (OK)


Should we open a ticket or could it be something related to our own tenant configuration?



Hello @michelbehr ,

The "&dynamicsUI=true" query string is only for the project or roadmap UI URLs, not the Dynamics model driven app URLs.


@Paul Mather Thank you - yes, by bad. But in any case here is screenshot for the URL requested (still not working).


Any suggestions...? Open a ticket right...? :\

@michelbehr when you click on the "Tasks" Tab in the Dynamics app, does it show you the embedded tasks? That's what I wanted to check as your original embed URL is the same that is used by that tab.

As Paul noted, embedding the whole application doesn't work.

@Trutz Stephani On both browser and MS Teams UI, if I add the "?dynamicsUI=true" suffix I get an error message, if not I get the site _with_ the header.






@michelbehr I see in your first screenshot that the embedding for the project works in the Dynamics app. Strange, that then the URL parameter doesn't work when embedding the normal project page in your Teams as a website. I think you should open a ticket to get this solved.

@Trutz Stephani sorry, I didn't take all 4 screenshots, but actually it's the same behavior on both browser and MS Teams UI. I'll open a ticket - thanks