Mark on Track only changes Task to 99%

New Contributor



I have a task with 2 resources. 1 resource has baseline work of 10hrs and remaining work of 0hrs. The 2nd resource has baseline work of 0hrs and remaining work of 10hrs. When I "Mark on Track", the resource with remaining work goes to 100% complete and the remaining work switches to actual work of 10hrs. The resource with baseline work remains at 0% complete though resulting in the task being at 99% complete. Why does the Mark on Track option not mark both resources at 100%?


Thank you!

5 Replies
Okay help us out here. I think you are misusing the term "baseline work" and hopefully you really mean "work". Baseline values are static values stored in separate baseline fields when a baseline is set, although baseline data can be manually entered. So, when you say resource 2 has zero hours of baseline work yet remaining work of 10 hours, it doesn't make a lot of sense.

I think a screen shot (Task Usage would be good) showing the task with assigned resources, and these fields: Baseline Work, Work, Remaining Work, % Work Complete, Start, Actual Start, Finish, Duration and Peak. We also need to know your Status Date.


Good Morning,


Sorry about that. Please see screenshots below. 

*We set the baseline with one resource and then reassign the work/remaining work to another resource.


Before Mark On Track:


After Mark on Track:




best response confirmed by Clay-Project (New Contributor)
I get the same result you do and indeed it looks like a glitch (e.g. bug). Ah, but first impressions can be deceiving. Percent Complete is simply Actual Duration / Duration and examining the values of both variables, they are each 11520 minutes with Remaining duration at zero. Seems like a slam dunk for a "bug".

However, I do notice, the first resource does show an actual start, so maybe he showed up for the meeting and then was ushered out. Given that, the first resource "started" but never finished (i.e. Actual Finish shows as "NA"). That's why, despite the math, Project is showing an incomplete (i.e. 99%) for the task. Simple solution, either remove the first resource entirely, or show an actual finish. Boom! Problem (and apparent, but false, "glitch") solved.

Thank you John. We can manually mark the resource as 100% complete or add an Actual Finish as you suggested but we would certainly prefer if "Mark on Track" could do this for us? If we have 100 tasks with this scenario, that is a lot of tasks to individually adjust.

We can't remove the first resource as it has baseline work against it and we need that for history.
You're welcome and thanks for the feedback. If I answered your question, please consider marking my response as the answer.

Baseline fields are static so removing the first resource from that task will NOT change that resource's baseline work. And if that resource did not do any work on the task I would think you would want his/her baseline work for that task to be removed so it doesn't affect performance metrics (i.e. that resource is going to show an extra 3.34 hours of planned work that was never performed, not because of any fault of the resource but due to retention of an incorrect baseline).

It seems strange that you would have a large quantity of task assignments with this scenario (i.e. assign a resource and then replace them before that resource accrued any actuals). In my mind, this scenario is, or should be, a fringe type of action.