You don't have permission to create a row - SharePoint list, new item via PowerApp Form

Regular Contributor

Hi there,


We have a Communications Team SharePoint site, we created a simple list, we created a PowerApp form.

When tested by two users one could add a row to the SharePoint list, but the other go the "you don't have permission to create a row" error when using the PowerApp form.


We've tried lots of permissions changes and variations but don't have a solution. Please let me know what you think we could do to solve this.


The one thing that looks strange is seen when checking the permissions for the user who gets the error, using the List's "check permissions" button. This user has a     deny - add and customize pages   permission. 

The second user who can add an item via to the list using the PowerApp form has the same permissions when checked in the same way.



Here is the input form (super simple)


Here is the error one of the users get


We've tried

- removing and re-adding the sharepoint list to the PowerApp. Didn't fix the issue.

- using set-sposite -identity -DenyAddAndCustomizePages $false     didn't resolve the issue

- checking we found

Full and had the folllowing ticked

Add and Customize Pages  -  Add, change, or delete HTML pages or Web Part Pages, and edit the Web site using a Microsoft SharePoint Foundation-compatible editor

and Read had it unticked
Changing these didn't solve the issue.


Many thanks for your help




3 Replies

Hi @Dorje McKinnon 


In the Lists permissions, are the two users in the Members group with Edit access? If not you may want to add the affected user into the Members group and see if that helps.


The image you show of permissions appears to show a user who has full rights (Owner) so that shouldn't be an issue, unless it's of the affected user?




Hi @Damien Rosario 

thanks for the reply.


We have tried the two users , as members of the Members group. Same error for one of them as I've documented.


The screen shot is of the impacted user when they were a member of the Owners group. Which also gave the same error I documented.



best response confirmed by Dorje McKinnon (Regular Contributor)

Hi @Dorje McKinnon 


Only other thing I can think of is to check who the original creator of the app was and whether they have appropriate permissions to access the list.


In the form (referring to image 2 of your simple form) in the ... menu > Customize with PowerApps and in PowerApps click onto the View tab > Data sources.


In the left side Data sources pane, under In your app, hover your mouse over the SharePoint list and see who the connection belongs to.


It may be that the creators permissions are not quite right and may need adjusting.


Otherwise if still nothing, you can also try the experts at the dedicated PowerApps forum who are mind blowingly amazing at this stuff.


See how you go?


Good luck