PowerApps Forms stuck loading

Copper Contributor

Hello everyone,


Since yesterday we have an issue with our PowerApps Form , it wont load, it just keeps spinning and spinning without doing anything.

It does the same when trying to add a new entry to the SharePoint list , or when trying to open an existing one.

While posting this I already saw 2 other post regarding the same issue, and neither one had a resolution to the problem.

I can say for certain that the problem is not user generated as there was not modification made to the PowerApps Form or the SharePoint between the last time that it was used (and worked) 06.05.2020 and yesterday ...and now when it doesn't .


Any advice is greatly appreciated

4 Replies
best response confirmed by CosminM (Copper Contributor)

This is global issue :(

Thank you for your reply, I was looking for a official statement regarding this being the result of a service shortage , haven't found anything yet.
Anyway, I'm sure this post will help others facing the same issue.

This is probably a stretch , but do you know anything about a time frame in which this issue could be solved, or is there any official statement regarding this problem.
Again, thank you for the reply, hugely appreciated.
Any update, please? I am still experiencing this issue today (May 10, 2020).

@rcheong852 It looks to be fixed since Saturday.