Copy link to task does not work in Teams

Iron Contributor



we use planner as a tab in MS Teams channel but there does not work feature "Copy link to task". When I click on this feature, nothing will happen. When I use this feature directly in Planner website ( it works correctly. What to do with it?


Thank you,





12 Replies
Yes, this is a known issue that I have to review if It have been solved...last time I tested, it didn't

I agree - it's deeply annoying. 


However, there's been progress albeit, it's still wrong!


Today (2 January 2019) I thought, let me try copying a link to a task card, perhaps they've fixed. Imagine my excitement when it actually did copy something!


Off I went happily into the document where I wanted to place a link to this specific card. I duly clicked  the hyperlink and hey presto - disappointment. It took me only to the channel, not to the specific card.


So, progress' (if you can call it that) but nothing usable at all. MS, if you're going to 'fix' the issue, why 'fix it' wrong like this? Link to an item is not the same as link to a channel...


Please can you sort this out???

@Miroslav Novák 


So here we are in the middle of August, 2019, and this still doesn't work?

I have tested it and it works already.

@Miroslav Novák 

Unfortunately, your observation is little better than this.


I'll point it out, again.  From the Planner web page, copying the link works just fine.

From the Teams/Planner add on tap, a 'Copy Link' only copies the subject line.


To anyone who has had this experience and has some useful advice, I would be grateful if you would share it.


If the collective wisdom is 'you already have your work-around', I'll stop wasting my time.


@Richard Deighan if I understood it right from your message, you have still problem with it? Or you do not have? I agree that copying the link works fine from the It also works now from Teams, when you click on the button "copy link", it provides you copying the subject, yes, I agree but when I paste it to conversation, everybody can click on it and check the task... My issue is solved...


@Miroslav Novák 


So the clarification seems to be that from the Planner App within Teams, when getting a link to a task and then using Ctrl-c, the link is only generated if pasted into a Teams conversation.  Trying to paste into something else like email or another chat service does not work, as it just pastes the title text.  However, after pasting the link into a Teams conversation, it is possible to then copy that link and use it however desired.  Does that seem to match everyone's experience?


Not sure why the Planner App within Teams link couldn't be implemented to result in something usable directly outside of Teams.

@Miroslav Novák 

I had the same problem after I had changed standard browser to Google Chrome - when I changed back to Edge it works :)   Microsoft -< Microsoft :) 

@Juan Carlos González Martín Do you know if this behavior will be changed? If the link will be available to be past in another clients? And for the graph? There will be a field with this url?

I am having this behaviour now. A few weeks ago, all was working fine but now today I can't seem to link directly to tasks. Only the channel. Within Teams it is still working but I need to link within Sharepoint and that is no longer working now. Did you have any luck with this?
Seeing a similar issue - we generate a link to use in a power automate flow - however the link to the planner card doesn't work any longer, even directly in planner - it only opens the planner board but not the task

@AndyNolanJet2 Same here - Links to task just open Planner Board not actual task. Painful.