Wrong SMTP in Outlook for Mac

%3CLINGO-SUB%20id%3D%22lingo-sub-3042507%22%20slang%3D%22en-US%22%3EWrong%20SMTP%20in%20Outlook%20for%20Mac%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3042507%22%20slang%3D%22en-US%22%3E%3CP%3EHello%20team%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe%20recently%20migrated%20from%20Gsuite%20to%20M365%2C%20the%20users%20in%20the%20company%20have%20Apple%20devices.%3C%2FP%3E%3CP%3EWhile%20migrating%20email%2C%20the%20users%20installed%20office%20with%20the%20old%20SMTP%20%3CA%20href%3D%22mailto%3AEmail%20address%20removed%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3EEmail%20address%20removed%3C%2FA%3E%3C%2FP%3E%3CP%3EAfter%20changing%20the%20email%20traffic%20and%20updating%20the%20SMTP%20of%20users%20to%26nbsp%3B%40tenantname.com%26nbsp%3B%20we%20started%20configuring%20Outlook%20profiles.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20(cosmetic)%20issue%20now%20is%20that%20all%20profiles%20show%20the%20wrong%20smtp%20in%20the%20Outlook%20profile%2C%20recreating%20a%20profile%20did%20not%20work..%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAccount%20settings%20also%20state%20that%20the%20email%20adres%20is%26nbsp%3B%40tenantname.onmicrosoft.com%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22WhatsApp%20Image%202021-12-20%20at%2009.44.16.jpeg%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F335060i402343A072800504%2Fimage-size%2Fmedium%3Fv%3Dv2%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22WhatsApp%20Image%202021-12-20%20at%2009.44.16.jpeg%22%20alt%3D%22WhatsApp%20Image%202021-12-20%20at%2009.44.16.jpeg%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%E2%80%83%3C%2FP%3E%3CP%3EHas%20anyone%20encountered%20this%20on%20MacOS%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-3043555%22%20slang%3D%22en-US%22%3ERe%3A%20Wrong%20SMTP%20in%20Outlook%20for%20Mac%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3043555%22%20slang%3D%22en-US%22%3EIn%20the%20admin%20portal%2C%20click%20on%20the%20account%20then%20Manage%20username%20and%20email%20in%20the%20panel%20that%20opens.%20Is%20the%20primary%20address%20and%20username%20the%20same%3F%20%3CBR%20%2F%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-3043334%22%20slang%3D%22en-US%22%3ERe%3A%20Wrong%20SMTP%20in%20Outlook%20for%20Mac%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3043334%22%20slang%3D%22en-US%22%3EThe%20%22add%20account%22%20page%20shows%20the%20custom%20domain%20when%20adding%2Fcreating%20a%20new%20profile.%3CBR%20%2F%3EBut%20when%20the%20outlook%20profile%20actually%20is%20being%20used%20you%20see%20the%20Onmicrosoft.com%20in%20the%20left%20pane...%3CBR%20%2F%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-3043096%22%20slang%3D%22en-US%22%3ERe%3A%20Wrong%20SMTP%20in%20Outlook%20for%20Mac%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3043096%22%20slang%3D%22en-US%22%3Eand%20it%20still%20comes%20up%20with%20the%20onmicrosoft%20account%20if%20you%20remove%20the%20account%20and%20add%20it%20back%3F%20c%20As%20long%20as%20the%20custom%20address%20is%20set%20as%20the%20Primary%20email%20address%20and%20username%20in%20their%20user%20account%2C%20that%20is%20what%20you%20should%20see%20in%20Outlook.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-3042750%22%20slang%3D%22en-US%22%3ERe%3A%20Wrong%20SMTP%20in%20Outlook%20for%20Mac%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3042750%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F75%22%20target%3D%22_blank%22%3E%40Diane%20Poremsky%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHi%20Diane%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20for%20the%20quick%20reply%2C%20i%20added%20all%20accounts%20the%20modern%20way.%20Also%20all%20users%20have%20the%20custom%20domain%20as%20their%20logon%20adres.%20But%20still%20the%20client%20shows%26nbsp%3B%40%20tenant.onmicrosoft.com%20in%20stead%20of%20tenant.com%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIts%20just%20cosmetic%20but%20annoying%20and%20confusing%20for%20end%20users.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-3042731%22%20slang%3D%22en-US%22%3ERe%3A%20Wrong%20SMTP%20in%20Outlook%20for%20Mac%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3042731%22%20slang%3D%22en-US%22%3EDid%20you%20set%20the%20custom%20domain%20as%20their%20log%20in%20address%3F%20%3CBR%20%2F%3E%3CBR%20%2F%3EWhy%20are%20you%20using%20SMTP%20with%20Office%20365%3F%20If%20you%20add%20the%20account%20using%20auto%20account%20setup%2C%20it%20should%20add%20it%20as%20an%20exchange%20account.%20This%20is%20a%20better%20experience%20and%20syncs%20calendar%20%26amp%3B%20contacts.%3C%2FLINGO-BODY%3E
Occasional Contributor

Hello team,

 

We recently migrated from Gsuite to M365, the users in the company have Apple devices.

While migrating email, the users installed office with the old SMTP Email address removed

After changing the email traffic and updating the SMTP of users to @tenantname.com  we started configuring Outlook profiles.

 

The (cosmetic) issue now is that all profiles show the wrong smtp in the Outlook profile, recreating a profile did not work..

 

Account settings also state that the email adres is @tenantname.onmicrosoft.com

WhatsApp Image 2021-12-20 at 09.44.16.jpeg

Has anyone encountered this on MacOS?

 

 

 

8 Replies
Did you set the custom domain as their log in address?

Why are you using SMTP with Office 365? If you add the account using auto account setup, it should add it as an exchange account. This is a better experience and syncs calendar & contacts.

@Diane Poremsky 

 

Hi Diane,

 

Thanks for the quick reply, i added all accounts the modern way. Also all users have the custom domain as their logon adres. But still the client shows @ tenant.onmicrosoft.com in stead of tenant.com 

 

Its just cosmetic but annoying and confusing for end users.

 

 

and it still comes up with the onmicrosoft account if you remove the account and add it back? c As long as the custom address is set as the Primary email address and username in their user account, that is what you should see in Outlook.
The "add account" page shows the custom domain when adding/creating a new profile.
But when the outlook profile actually is being used you see the Onmicrosoft.com in the left pane...
In the admin portal, click on the account then Manage username and email in the panel that opens. Is the primary address and username the same?
Yes that is the same, as stated before this is a cosmetic client-side issue but i don't know much about MacOS. So i'm searching for a solution..
I'm pretty sure its not a mac OS issue, If making a new profile doesn't fix it, it's coming from the server. You can try using in-app support (on the Help menu in Outlook.) Or the Office 365 admin can contact support thru the admin.microsoft.com portal.
I will let an enduser recreate his profile. I am the admin.