Outlook with Gsuite not sending email

Occasional Visitor

Update: I haven't been getting email notifications for any replies, but it does seem to be working now. 


Outlook is not sending emails out from our linked Gmail. Sending and receiving works fine with Gmail directly, but sending from Outlook, the mail just sits in the outbox. Checking the Send/Receive pane and then Show Progress has this showing. 

I've reinstalled Office and Gsuite, they synced fine. Nothing has changed at all, and it's working normally outside the Insider build. My boss was the first to get the build and see the issue, and I downloaded to verify it. I'm getting the same problem.

Anyone else? Any other ideas of what to check?


Edit: It seems Google is aware of the issue. Posting for anyone else with the same issue.

11:34 AM

Our engineer team is aware of this right now, and they are also working on a fix for this. At this moment what they suggest is to remove the upgrade (1904) and go back to the (1903) since they are trying to find out if the issue is caused by our tool or Outlook it self.

19 Replies
best response confirmed by Truce (Occasional Visitor)

@Truce If you're still seeing this problem I'd be interested in taking a closer look at this failure.   Can you still reproduce it on demand?   If so, email me  asnapke AT microsoft dot com and I may be able to assist you.  If you happen to already have IMAP/SMTP logs collected go ahead and send that.


EDIT: see below, root cause has been found restart Outlook and this should be fixed.


have the exact same issue here - commenting to see what the fix is. @Truce 

same problem starting on Wednesday. Only happens when sending from Outlook with GSuite. Not a problem sending directly from gmail account.@Truce 

@Brandscaping (and anyone else with this problem) if you are seeing this consistently and are on Insiders, please go to the Help section in the ribbon and use "Contact Support" to start an In-app support case.   That will expedite data collection and help us track down why this is happening.

@Truce  I am having the same problem and I am hoping that I don't need to uninstall and reinstall Office to build 1903 as it is a pain adjusting all the settings.

Looking forward to hearing of any updates.

I upgraded to business premium and switched by email backend to MS. Problem solved. @AaronMS 


Shared my logs from email with @ipro.l? domain.

One more interesting observation.

I had issues with iCloud on the same PC. iCloud application suggested to create/submit Report with collected data. I accepted it. Shortly data were collected by application and mail message was created (in Outlook). When I chose to Sent ... it went smoothly (not in Outbox.. it was Sent and went to Sent Items).

Hope it could be helpful.


Just checked with other application. Adobe. If I open pdf and Send Emai -> MS Outlook and create a message, after I click Send, it smoothly works. Message was sent and went to Sent Items.


@Truce Have a look in your Application log and see if you have a Warning event 68 saying that it is unable to load gsync.dll.


If that is the case, then please refer to this article for a workaround:

@Arunas_St Unfortunately I don't see a case with that domain.   Did you get a case reference number?


You can also look for the App Event 68 where gsync DLL will not load and if so, follow the process in



Update to all on this thread: we've tracked down the root cause in why the GSync provider DLL was not registering properly and worked with Google to get it resolved.


Outlook should be able to correct the issue itself on restart.  If you're not seeing that occur, try making sure all Office apps are closed (or simply restart the machine).  If the issue persists past that please use Help>Contact Support to work with us and trigger additional data collection.

@AaronMSI sent log to your mail from my mail (therefore I don't have case number).


I do confirm, that it was App Event 68 where gsync DLL will not load. After I followed workaround and restarted PC, Outlook started to work as expected (send messages).


Thanks for help.





do we have ANY news about this?

Is it gonna be fixed soon? Is there a better workaround than restarting your computer?

My company is using mail merge a lot and nobody is able to work. I'm replacing the outgoing smtp server with our own but again, it's not always working properly. 

@Delijohn There was an issue fixed on 4/24 that was related to the GSync connector in Outlook, that's where restarting Outlook would help.   And once it is restarted and reconfigured this isn't something that you'd see come back and require any additional restarts.


But, if you're using an outgoing SMTP server I don't think you are using the GSync connector.  You can enable advanced logging and generate SMTP logs and very likely you'll see some sort of indicator why your messages aren't being sent.


sorry for my late reply. The problem still persists when we use the gmail smtp outgoing server. It's still showing these pop ups to sign in again and again. When we try to swap to our company's smtp server, it gets better but it's working with the 5th or 6th time. It's so annoying that it's so not trustworthy. :(

@Delijohn Again, if you're using an outgoing SMTP server this isn't the same issue as discussed in this thread.    If you see intermittent SMTP failures start with the SMTP log to see why it is occurring.   But if auth prompts are showing up, it may be more complicated since SMTP logs only show you that a login failed.   Often you'll have to go to the auth provider to find out why.

@AaronMS Again, let me try to explain it one more time.


a) in the case we use gmail, it's happening a lot. I will try the smtp log but i thought it's a known issue the syncing failures with gmail, that's why i wrote here. Out of 500 users, it's happening to 10 per week. 


b) when i try to fix their issue, after resetting outlook or doing other stuff, the pop up for authentication keeps showing up. Only when they are trying to send mails. So, in this case, i start using the SMTP of my company. But, until it starts working, i have to change the settings 3-4-5-6 times and put again and again my company's smtp and settings. Otherwise it keeps trying to use gmail's settings. It's like it's stuck. Restarting outlook or the computer doesn't help. After 4-5-6-7 times, it starts sending mails with the new settings.

@Delijohn I think I am experiencing the same issue. Have you finally figured out how to resolve this?

Outlook is unable to send email from outlook was gmail is selected as a preferred sender.  I get the message " Message failed to send "TRY AGAIN"


After 3 days of back and forth with Microsoft support chat, some support guy called Kaleem responded with this message:

Regarding the issue that you're encoutering, I would like to inform you that we are aware of this issue and have identified this behavior as a BUG. The report is already being filed with the product engineering team. I understand the severity of the issue and the requirement for the resolution. Since this needs to be tested and the fix needs to be rolled out, we would not be able to provide an ETA on the fix. You may also refer to the Microsoft blog, where all the updates to the latest features and fixes are announced. Here is the link: