Office icon missing in OneDrive app preferences

Copper Contributor

Hi! As you can see in onedrive app preferences, there's used to be an "Office" icon, which is now disappeared in my OneDrive app. How is it possible to get this settings option back? I've tried resetting onedrive, and I have the latest version as well. I want to turn file collaboration off.  Thank you!



12 Replies


If the Office icon is missing from the OneDrive app preferences, you can try the following troubleshooting steps to restore it:

  1. First, ensure that you have the latest version of OneDrive installed on your computer. You can check for updates by opening the Microsoft Store app and clicking on the three-dot menu in the top right corner, then selecting "Downloads and updates".
  2. If OneDrive is up-to-date and the Office icon is still missing, try resetting the OneDrive app. To do this, right-click on the OneDrive icon in the system tray and select "Settings". In the Settings tab, click on the "Reset OneDrive" button, and then follow the on-screen instructions.
  3. If resetting OneDrive doesn't work, try running a repair of the Microsoft Office installation. To do this, go to Control Panel > Programs and Features, find Microsoft Office in the list of installed programs, right-click on it, and select "Change". In the Microsoft Office Setup wizard, select "Repair", and then follow the on-screen instructions.
  4. If the Office icon still doesn't appear after resetting OneDrive and repairing Office, try reinstalling OneDrive. To do this, go to the OneDrive website and download the latest version of OneDrive for your operating system, then run the installer.

I hope this helps!


I know I don't know anything (Socrates)

@NikolinoDE Hello,


I also want to turn off the file collaboration option. I have a mac though. The Office option does not show up in my Onedrive app and it doesn't even have an option to Reset Onedrive.





On a Mac, the OneDrive app might have a slightly different interface compared to other platforms. If you're unable to find the "Office" option to turn off file collaboration and there's no option to reset OneDrive within the app, here's an alternative approach:

  1. Unlink and Re-Link OneDrive:
    • Click on the OneDrive icon in your Mac's menu bar.
    • Click on the three dots (...) to open the menu and select "Preferences."
    • In the Preferences window, go to the "Account" tab.
    • Click the "Unlink OneDrive" button. This will remove your OneDrive account from your Mac.
    • Once unlinked, close the OneDrive app completely.
    • Reopen the OneDrive app and follow the prompts to sign in and link your account again.
  2. Check Online Settings:
    • Sometimes, specific settings related to file collaboration might be available only through the web interface. Log in to your OneDrive account using a web browser on your Mac.
    • Navigate to the settings or preferences section. Look for options related to file collaboration or Office integration. You might find the option to turn off file collaboration here.
  3. Contact OneDrive Support:
    • If you're still unable to find the option to turn off file collaboration after trying the above steps, it's a good idea to reach out to OneDrive support for assistance. They might be able to provide you with more specific guidance or address any technical issues you're experiencing.

Please keep in mind that the user interface of apps can change over time, and features might be relocated or renamed. If the option you're looking for is not available in the app preferences, the web interface or customer support might be the best routes to explore. The text and the steps are the result of various AI's put together.


My answers are voluntary and without guarantee!


Hope this will help you.


Thank you so much, I will try these options.

Did you manage to solve this? I am facing the same problem.

Kind regards.
Unfortunately, it didn't work for me.
Option 1 didn't work.
Option 2 didn't show me different settings options online.
I haven't tried option 3.

During my research, somebody suggested to pause synching in OneDrive when I am saving my new files in OneDrive. Just going to the app in the top menu in my mac, then look for the option to pause synching for either 2/4/24 hours, I just choose 2 hours, save my files in OneDrive (it works), and then go back to "unpause" synching.

It's not ideal, but it works.

OneDrive has been a pain in every mac I own. Not sure why but I guess at some point I will contact customer support.

Hope this helps.


I'm joining in - I have the same symptoms as the colleague who opened the discussion.

I updated the operating system to the latest version of macOS Sonoma 14.0 (everything worked fine before the update).
Currently, I have detected a problem with file synchronization within the OneDrive v. 23.184.0903.0002 (standalone) (Apple Silicon) application.

What I did:

I performed the above-mentioned operations - they did not help

Additional activities
1. I turned off synchronization of everything connected to OneDrive
2. I deleted the app, downloaded the most up-to-date one and installed it again
3. I reconnected the account (I also changed the main folder several times so that it would not refer to old local files - it didn't help)
4. I added account synchronization and after a few seconds of correct operation I have the following message:


- Yes, I'm logged in to OneDrive > you can see it in the screenshot
- Message from OneDrive:


translation > You'll need to restart OneDrive to continue syncing this location

5. I still don't see the Office tab in the OneDrive settings - why?



What is the problem:
1. The folder and file structure is not being downloaded
2. And somehow the folder/file, e.g. Word, gets corrupted and cannot be opened after double-clicking

Please help, how can I solve this problem?


Regards Mariusz


@MariuszMJ the office tab in the preferences is missing in my OneDrive also after updating to MacOS 14.0. 


Syncing is working as it should after deleting OneDrive and reinstalling, however I now have to navigate to the original file source folder when completing a file>save as. Prior to the update the default save location was set to the current files folder / location

I did not manage to restore the icon, but i managed to solve the sync problems. Apparently, when you uninstall an app in MacOS, some files remain in the system. So i had to download an uninstallation manager, which helps to wipe all the files when you uninstall an app. Alternatively, you can use the advice given here:,OneDrive%20icon.... In all the folders, I deleted everything related to Word and OneDrive. Then I reinstalled the two. Bingo, all my problems were solved. Just dragging the app into trash removes the app but keeps all corrupted file on the disc.
perform the process as you wrote and I will let you know the result.

Regards Mariusz

 @Azariah and all 


Actions I took:

  1. I disconnected all OneDrive and SH synced spaces
  2. I uninstalled OneDrive using
  3. I paste each of the file paths below. At each location, look for files with ‘onedrive’ in their name. When you find them, drag them to the Trash.

    ~/Library/Application Support/







    /Users/your_name/Library/CloudStorage  > new patch - Here you will find entries/references to other projects made available under SH
  4.  I logged in to SH and all the spaces I wanted to have synchronized, I used another option: Add a shortcut to the OneDrive service (then OneDrive creates shortcuts to other spaces in one OneDrive place). If I did not use this workaround, after synchronizing the resources with SH, I immediately received the following message:

    - Message from OneDrive:

    translation > You'll need to restart OneDrive to continue syncing this location
    I still don't have the Office icon.

    I am waiting for a final solution to the indicated problem by Microsoft and Apple ;)
  5. I restarted my computer
  6. I downloaded the latest version of OneDrive 
  7. I installed the latest version of OneDrive
  8. I only synchronized one location, it was OneDrive
  9. So far, synchronization works - I'm currently testing this solution. Unfortunately this is a workaround, but nothing else has worked for me currently. Maybe someone will find this description and such a temporary workaround useful.



    @Azariah - Thank you for your help and direction :) 







Try this in terminal:

defaults delete EnableAllOcsiClients

Then restart OneDrive.


See: for more information