OneDrive for Business sync SharePoint libraries on Mac

Highlighted
Occasional Contributor

Is there any view on when the OneDrive for Business sync for Mac will support syncing SharePoint libraries?

32 Replies
Highlighted
i think it is going to be in q4 but not sure.

Kr,

Paul
Highlighted

Here

https://support.office.com/en-us/article/Get-started-syncing-SharePoint-sites-with-the-new-OneDrive-...

we can read about the new Preview to sync SharePoint sites

 

Is there any view about a PREVIEW for MAC to support syncing SharePoint libraries?

 

Highlighted
Highlighted

I have followed instructions on the page:

https://support.office.com/it-it/article/Get-started-syncing-SharePoint-sites-with-the-new-OneDrive-...

 

to install the new preview version for Mac.

That’s all OK for private OneDrive and for OneDrive for Business folders.

BUT we have problems to sync SharePoint sites

 

The link in the SharePoint site “Sync” open the Windows version of OneDrive and not the Mac version.

How can I sync the SharePoint sites?

 

See images

sp1.jpgsp2.jpgsp3.jpg

Highlighted

I have followed all steps.

 

I have also enable team site sync with the following commands in the Terminal APP: 

Defaults write com.microsoft.OneDrive TeamSiteSyncPreview -bool True

Defaults write com.microsoft.OneDriveUpdate Tier Team

Killall cfprefsd

 

  1. On the Office 365 app launcher, choose SharePoint.

  2. Click the site that you want to sync.

  3. Click Documents or navigate to the subfolder that you want to sync.

  4. Click Sync, and then choose Sync now.

 Here we have the problem, if I click on Sync now the system have to open a OneDrive Windows version and not a Mac version, so I can't add SharePoint site to it!!

 

 

How can I sync the SharePoint sites?

 

 

Highlighted

Hi Vincenzo,

 

We had the same problems, which was caused by the level of rights. Did you entered the the commands in the terminal after elevating your rights (by using su)? After this is done you should be able to sync the SharePoint libaries the same way you do on Windows (click sync in SP and OD asks for confirmation).

 

Kind regards,

Sonny

Highlighted

by using su

What does it mean?

I am administrator of the Mac!!

 

p.s. I have inserted again the commands in the terminal as root level

no works!

Highlighted

That’s all OK, now. The tenant was not updated. Now it’s working fine.

Highlighted

Does the Sync not work across different tenants on a Mac? When I click on the sync link it starts to setup a new OneDrive For Business session with a user login something along the lines of myemail_companya.com#ext#@companyb.onmicrosoft.com

Highlighted

The OneDrive for Mac works fine.

You have to download it from App Store.

The official version not permit to sync sharepoint sites, if you have to do that, you can download the preview version and follow the instrucions here:

https://support.office.com/it-it/article/Get-started-syncing-SharePoint-sites-with-the-new-OneDrive-...

You can use private OneDrive and a company OneDrive...

 

Highlighted
Wow. didn't know preview went public. Thanks a lot.
Highlighted

I'm running 17.3.6673, is there a later preview release than this?

Highlighted

17.3.6673 is the last

Highlighted

Thanks will test on my Win10 VM to see if it is realted to the mac client or tenant(s).

Highlighted

The Mac preview crashes during setup for me. Is there a way we can get support for the preview?

Highlighted

simple to do...

Click on theOneDrive White Icon

 

Send a problem

:)

 

Highlighted

I ned the preview to keep running long enough for me to do that

Highlighted
Highlighted
That's where I found the download and those are the instructions I'm following but OneDrive crashes during the initial setup process after I nominate my OneDrive folder for syncing.
I'm looking for a way to report the issue but that link doesn't provide any support contact details
Highlighted

Hi.

Today I have problems to sync SharePoint sites with the new OneDrive for Mac.

The first configuration of OneDrive and SharePoint site was OK.
Now I’d like to add a new SharePoint site and when I click on “Sync now” on the SharePoint site, the system ask me to launch the Windows version of OneDrive !!!

I have discovered that the version is changed from 17.3.6673 to 17.3.6674

new version???new version??? 

Highlighted

uhm... I have tried on another Mac with another account on the same tenant and it works fine!!!

 

Below the correct image of the correct popup for Mac version... the other is for Windows client...

 

sync.png

Highlighted
Any news on this? We are are already in the middle of Q4 2016.
Highlighted

The new preview sync SharePoint libraries. That's all OK.

I have problems only with my account on a single Mac.

Nobody help me so now I think to uninstall and reinstall the APP :)

 

 

Highlighted

uaohhh

BIG PROBLEM

Now, after unistall it, I can't install again... problem, problem, problem...

and now???

Highlighted

The Sync File from Your OneDrive screen briefly appears for me and then OneDrive crashes.

 

I've tried this with the new version of the client (17.3.6674) and it behaves in exactly the same way. The crashed thread # varies but it is always the same operation. Stack trace copied below

 

Thread 7 Crashed:: Core Loop
0 com.microsoft.MSSyncEngine 0x00000001082a0e88 AssertWorker(AssertType, wchar_t const*, unsigned int, char const*, wchar_t const*, wchar_t const*, ...) + 1335
1 com.microsoft.MSSyncEngine 0x0000000108462019 SyncServiceProxy::EndSyncScopeInitialization(ScopeState&, ResourceID const&, int (*)(DriveInfo*), SPOPermissions::SyncRestrictions const&, PermissionsInfo const&) + 3019
2 com.microsoft.MSSyncEngine 0x00000001084bb4c5 CoreLoopWorkItemQueuer::ExecuteNextWorkItem(bool) + 65
3 com.microsoft.MSSyncEngine 0x00000001084bb3d8 CoreLoopWorkItemQueuer::DoWork(bool) + 218
4 com.microsoft.MSSyncEngine 0x000000010831575e coreLoopWorker(int&, bool&) + 305
5 com.microsoft.MSSyncEngine 0x0000000108315301 coreLoop(void*) + 215
6 com.microsoft.OneDrive 0x0000000107c19895 -[coreController coreLoopThreadMain:] + 170
7 com.apple.Foundation 0x00007fffd7be330d __NSThread__start__ + 1243
8 libsystem_pthread.dylib 0x00007fffeb53aaab _pthread_body + 180
9 libsystem_pthread.dylib 0x00007fffeb53a9f7 _pthread_start + 286
10 libsystem_pthread.dylib 0x00007fffeb53a221 thread_start + 13

Highlighted

1. Close the APP.

2. Move the APP in the trash folder.

3. Clean the MAC from all OneDrive files:

Open the Finder - GO - ALT Library - Delete all the following files:

~/Library/Group Containers/UBF8T346G9.OneDriveSyncClientSuite

~/Library/Group Containers/UBF8T346G9.Office/Microsoft/AppData/Microsoft/Office/15.0/OfficeFileCache

~/Library/Group Containers/UBF8T346G9.ms/com.microsoft.onedrivebusiness-mac

~/Library/GroupContainers/ com.microsoft.skydrive-mac

~/Library/Application Support/OneDriveBusiness/Settings

~/Library/Containers/com.microsoft.OneDrive-mac

~/Library/Containers/com.microsoft.OneDrive-mac.FinderSync

4. Reinstall the Previee APP following the instructions here: 

https://support.office.com/en-us/article/Get-started-syncing-SharePoint-sites-with-the-new-OneDrive-...

 

 

Highlighted

Today, the last quarter of 2016, some news about the new version of OneDrive for Mac?

Or a new preview?

Highlighted

MS targeted end of year, so there are still some days left in the month/year..

Highlighted

Two days ago I have downloaded a new preview version:

Version 17.3.6707.1124 (Public Preview Released December 1, 2016)

I have stored the following link and not the web page:

https://go.microsoft.com/fwlink/p/?linkid=831500

I have installed it on my desktop and that's all OK.

Now I have downloaded it for my notebook ma the version downloaded is a previous version!!

News about it?