Microsoft Technical Takeoff: Windows and Microsoft Intune
Oct 24 2022 07:00 AM - Oct 27 2022 12:00 PM (PDT)

Error parsing app package

New Contributor

I have been all over the other threads about this question but nothing seems to fix my problem. No matter what I do, my .appinstaller doesn't work. I keep getting : Error in parsing the app package.

First off let me say I can access both the .appinstaller file and the .appxbundle file using the direct URLs. Also, I am able to install using .appxbundle and I have a signed certificate. I also tried doing the loopback exemption but that didnt work either. Here is the XML to my .appinstaller


<?xml version="1.0" encoding="utf-8"?>
    Version="" xmlns="">
        Uri="" />
            HoursBetweenUpdateChecks="0" />

In addition, I have added all the MIME types to my apache httpd.conf file as such :

    AddType application/appinstaller .appinstaller
    AddType application/msixbundle .msixbundle
    AddType application/appxbundle .appxbundle
    AddType application/msix .msix
    AddType application/appx .appx 

I would appreciate any help on this. Thanks!

7 Replies

Hi @BrianShekkt,


Does this fail when clicking on the .appinstaller uri on a webpage? Can you please share what your download uri looks like on the page. Also, there's a known App Installer install/caching issue which can be fixed by a restart, please try and see if a restart of your machine fixes the issue.




@Tanaka_Jimha I have already tried restarting, it didn't help. Both the .appinstaller and the .appx file are accessible on the server and I can download them via the links directly. However if I run .appinstaller it just get back a parsing error. 



Is the download page publicly available for our team to investigate? If it isn't can you please file an item in Feedback Hub (Win + F)  while reproducing the issue. Please file it under the category Apps > AppInstaller. Please also attach a copy of your .appinstaller file + package, if possible.




@Tanaka_Jimha I am also having issue which can be solved by restarting computer, but I'd like to avoid telling my customers to restart computer with every single update. Can you please provide source issue link and probably a estimate when it can be resolved?

@BrianShekkt I have been working with AppInstaller files and at a glance your syntax looks reasonable to me. I do have a couple of ideas to test for where the problem might be..


First, You can probably remove the xmlns reference for the schema.  Yeah, it *should* be there but I've found that removing it works and keeps the file from being rejected on backrev systems.


Second, I'm not working with bundles, but what you wrote looks correct (I just haven't tried that).  You might try a MainPackage with a .appx file from your bundle to determine if this is the area of the problem.


Third  is the value for HoursBetweenUpdateChecks.  Although documentation covers the 0 case, it could be the problem and maybe you should try a 1 to see if that is the cause (or eliminate the value as it is optional and defaults to 4 hours).

I just had the same error message while trying to install a downloaded package. While looking into my problem I learned a few things that mich be useful to anyone else coming here.


The problem here could be the application is not able to access the URI addresses.  Even if the individual URLs are available via a browser, the application doesn't think they are valid. In this example I can see the publisher is "myCert" and the URI addresses are http not https. From my quick reading it looks like https and file are supported. no mention of http. Someone reply if they can confirm .appinstaller supports http:


>> Trying to use http without a valid certificate that could have been the problem.



The Name, Publisher, Version, ProcessorArchitecture, and ResourceId must match the values in the AppxManifest.xml file specified in the app package Uri.


One can check the details by entering the package URI into one of the many certificate checkers like: ""


In my case my firewall was blocking the application. I use Tinywall and it needs every new application to be approved to use the internet. This resulted in "Error parsing app package" rather than some other useful message to inform me what went wrong. Not useful error message.

there is a known caching issue with the appinstaller file. see more details here if it applies to your app: