You don't have access to this org in Teams.Select another org, or contcat your admin

Occasional Contributor

This user is within my organisation and not a guest but when she tries to open Teams we get 

You don't have access to this org in Teams.Select another org, or contcat your admin


She was a member of another org in MS Teams previously using the same email address as her organisational one.


We logged onto and deleted the other org but a) teams still remembers it and b) we still can't log on to the actual organisation she is a member of



26 Replies

Send her a "deep link" to one of the teams within your own organization, should look something like this:


See what happens after she clicks on it.

Hi @Vasil Michev 


We just get the attached error 'Something went wrong'

Hi @Vasil Michev 


Also when she tries to sign in it still knows about the other org even though we removed this from her profile?

Well you do have the "tenant picker" visible on the second screenshot, so just select your "home" tenant there.

Hi - It just takes ages and then fails to sign in. It basically then says the same message but with the different organisation.

Get her to sing-in into a Private session in the browser and use the same URL.

Hi how do you do a private session sorry

Right-click on your browser's icon -> Private session/Private Window/Incognito window

Ah ok i see what you mean, ok i'll try this with the user tomorrow when they are back in.

Hi @Vasil Michev 


I have fixed this now but removing the licences and reapplying them. Thanks for your help though, it was appreciated.


Thanks Mike


Hi Michael!

I have the same error that you slow.


Can you please explain me where did you remove licenses and reapply them?

@Olekasandr_RupaHi - login to as a user with access to the admin centre

Once logged in click on the Admin icon

Once the admin centre opens up click on Users > Active Users

Find the user and on the left hand side of the user name click on More Actions (the 3 dots) and select 'Manage Product Licences'


A new tab will open on the right hand side of the screen listing all available licences. One of these will be Teams (depending on your version of office will determine what type of teams licence you have) untick this (if ticked) and retick it (it will go blue).


At the bottom of this tab click Save Changes


It says it can take 24hours for this to be applied but for me it was within the hour.


I hope this helps



@michael_baldwin et al 


All of a sudden earlier today, Teams stopped giving me access to my own organisation and asked me to contact administrator. However, I am the admin, and I cant login. I tried multiple uninstall and reinstall of desktop app but Teams still remembers details and prevents me from logging into my own organisation. Its a horrible loop I cant escape. What on earth is going on and why?



Did you manage to resolve this issue?  I have the same problem.  I can log onto Teams via the mobile app and my web browser, but the desktop up tells me "You don't have access to this org...".  I've also reinstalled numerous times. 

@RudivA I have exactly the same issue here. I'm the admin and i can't entre my org!  


I have the same issues, and I cannot get it  work an a work laptop.

It does work on mobile and on personal laptop.

Can someone help us ?



@vmagliano-analytiqum  Same issue here. I am admin but Teams won't let me log in. Desperately need a solution to this as meetings are being missed.

This is all very well but I have no admin - Azure has me listed as working for 3 organisations - two were guest access granted - but won't let me remove them - give me an "unexpected error" message 


I've managed to get in only by logging out of every instance and using an Incognito window to map out which instances open and which don't - it was linked to having multiple Microsoft logins for some reason (historical) and each one opened different doors - and then asked me if i wanted to use Work or was a horrendous mess and still is but I least i know which rabbit hole to run down to open Teams now



@RudivA This is still unresolved ! Microsoft is a broken company. Its products are too complicated for normal people to troubleshoot and who just want to get their work done. I shouldn't have to know about licensees, active directory in the same way I dont know how my car works, but I switch it on and it works. Complete joke of a company but hey they're a monopoly so they get away with it !