Teams Polls show results anonymous despite recording names

Copper Contributor

Hi all,

I've been testing the poll function within teams for an upcoming meeting. For some reason, the repondends still show up as anonymous despite having checked the box "Record names of respondents (only visible to creator)". Results show anonymous directly in the teams app but also when I access the results via> forms> etc.

Does anyone have an idea what is going wrong here?



34 Replies

Hello @SandorKrus,

If the respondents' names are still appearing as anonymous despite using the "Record names of respondents" option, there could be a few possible reasons for this not working:

  1. Permission Settings: check that you have the necessary permissions to view the names of respondents:

    To have the necessary permissions to view the names of respondents in Teams Polls, you typically need to have the following access rights:

    - Microsoft Teams: such as owner.

    - Office 365: You should have sufficient access rights in Office 365. This may include being a member of the appropriate groups or having specific permissions assigned to your user account.

    - Poll Creator: you should be the creator of the poll.  Ensure that you are logged in with the account that created the poll or have been granted access by the creator.


  2. Poll Creator View: Make sure you are viewing the poll results as the creator of the poll. Sometimes, the poll results may appear anonymous to other participants or viewers, but the creator can still see the names of respondents.

  3. User Privacy Settings: It's also worth checking the privacy settings of the respondents. If the respondents have chosen to remain anonymous or have restricted the visibility of their names, it can override the "Record names of respondents" option.

    If you think my answer helped you, you can click on Mark as best response.

    Kindest regards

    Leon Pavesic

@SandorKrus @LeonPavesic 
I am having the same issue. It was working last week and for many weeks before but today it doesn't seem to be working. Whether I tick or untick 'record names' the results still show as anonymous. 


First of all, thanks for your reply. Unfortunatly, I'm afraid your suggestion do not solve the issues as I have full teams access via my company account and I'm hosting the polls myself (and am thus the poll creator). Even when I'm in just a teams call with myself and I look for the responses via, respondents (which is in some attempts just me) are shown as anonymous. So this should cover both the poll creator view as well as my own privacy setting. So I think it must be something else, or might I have misinterpreted you?





Indeed, last week I had no issues either! And your description is exactly the same I'm running into as well.
I suddenly have the same issue: Created a survey last week and the initial results were recorded correctly but now suddenly all new answers are "anonymous", leading to duplicates in the results as well.

Hi @anne-a500@SandorKrus@Smockrun,

Can you please go to > Apps > Forms > All my forms > It should be there. > Open Answers > Viewing results and let me know if you can see the results there?

Please click Mark as Best Response & Like if my post helped you to solve your issue. This will help others to find the correct solution easily. It also closes the item. If the post was useful in other ways, please consider giving it Like.

Kindest regards

Leon Pavesic

Hi @LeonPavesic,

The form is indeed there and it also shows results. However, the results that are shown, are all saying "anonymous" in the name column despite having ticked the box "Record names of respondents (only visible to creator)". So its is not that I cannot find the results, but it is that all results are simply anonymized.



Hi @LeonPavesic,

I can also see the results. But the last result with a correct email and name is from 28.6. - any answers from yesterday and today simply show "anonymous". I also tested by sending multiple replies myself and those show up as multiple "anonymous" entries instead of being recognized as the same user.

@SandorKrus experiencing same today. Pls share incase you have resolved this issue. thank you!

@SandorKrus I'm experiencing the same.  I've been using the Polls app each week for a number of months, to get a list of names for Friday lunchtime's 5-a-side soccer game at work.  This week, its just Yes/No replies from players named 'anonymous'.  Frustrating!

@MDuffin @SandorKrus Having the same issue here today as well. I've used polls before in the same meeting cadence with no issues, but today everything is showing as "anonymous" this is very frustrating as we need to know how people are voting in our polls. 

Having this same issue as well as of this morning. I even responded to the poll to see if it would show my information and it all comes up as anonymous. Following for a hopeful resolution soon!
Same here, hoping to see a resolution to this issue. On my end Polls worked normally last Friday (June 30, 2023), but as of today (July 5, 2023) I am experiencing the same "anonymized" problem described in this thread.
I am also having the same issue, polls recorded the names for weeks until today.
I am also facing the same issue. The names are showing as anonymous despite me being the poll creator.
Hi @LeonPavesic,
I am experiencing the same issue. Any fix by now? Thanks

I am experiencing the same issue, my previous polls I can see the names, the one I made yesterday all are anonymous. 

@jozsefhajdu I am facing the same issue. Although I select "names recorded" the names are showing as Anonymous. How to fix it, is it a bug in Microsoft Teams poll ?

@Prabhaharan27 same here, selected record names, but shows anonymous at each responder. seems like it is a recent bug

1 best response

Accepted Solutions
best response confirmed by SandorKrus (Copper Contributor)

We noticed this issue about "Record names" setting not taking effect for Teams/Outlook Polls. We have fixed it. Please try it again. Thanks all.

View solution in original post