MS Teams Rooms SRSv2 - Windows 10 Media version does not match

New Contributor



I am attempting to run the CreateSrsMedia.ps1 script as an elevated administrator (using x64 powershell)

The settings I'm using:

[2] Polycom MSR

[0] Surface Pro 4


I get stuck at the following:

"Please enter the path to the root of your Windows install media:"


When I direct to the root path of my windows 1803 copy I get the below message:

"Your Windows installation media is version 10.0.17134.228. Your SRSv2 kit requires version 10.0.17134.1."


How am I able to retrieve/download a copy of 10.0.17134.1?







11 Replies
best response confirmed by ToddM_KineticIT (New Contributor)

For anyone experiencing the issue that I did,


I ended up editing the powershell script so that it ignored the windows version check = 10.0.17134.1.

I only did this as I knew I had windows 10 build 1803 and decided to take a chance and it worked out.

Hi Todd,


Can you advice where exactly did you select ignore the version? I have tried to change the XML files to look for 10.0.18362.30 but no luck.


Hi Sprinting Python,

It's been a while since I ran fixed this myself. I can't quite remember of I ended up adding a line or redacting one.

I'll have to attempt to replicate this, unfortunately this is not the best time (I'm sick and work is busier than ever!) I would recommend continue searching for the answer on the tech community forums plus raise a job with Microsoft.


@ToddM_KineticIT  Thanks mate no problem. Figured it out. Hashed out that part of the script and all good.


@sprintingPython Hi !
Did you eventually solved it ?
What is the solution ? I'm have similar error to you.

@Eitan203no I did not. Still looking for a solution.


I solved it like 30 minutes ago
I just downloaded from VLSC win10 pro and it worked smoothly !

@Eitan203I tried to use win10Pro but it says it needs win10 Ent and not PRO.


He mofificado el script como pongo a continuación.

Ha creado el usb, con la otra versión de windows, he puesto un true en lugar de un false cuando chequea las versiones, asi que salta esa comprobación.


# We only accept media with a version number matching the version required
# by the SRSv2 kit.
if ($img.Version -ne $KitOsRequired) {
Write-Host ("Your Windows installation media is version {0}. Your SRSv2 kit requires version {1}." -f $img.Version, $KitOsRequired)
#return $false
return $true



The most awesome reply which worked in no time, thanks man for your support

@jguzman73  Gracias genio!!!!!! Me estaba quedando sin pelos con este tema,