MacOS unable to share screen

Copper Contributor
  1. Click the Apple menu.
  2. Then, go to System Preferences > Click Security & Privacy > Privacy tab.
  3. Click Screen Recording.
  4. Click the lock icon to make changes.
  5. If required, enter your admin password.
  6. Finally, click the checkbox next to Microsoft Teams.
  7. notification window will ask you to restart it. Agree.

Did all this setting till problem is not resolve? Please guide

27 Replies

Hello @ManishWadhai   I don't use a Mac myself but I found this unverified article - does it help?  Please let this community know.  Or you can open a ticket at the tech support site, where authorized agents are available to troubleshoot issues until they are resolved.


Microsoft Teams Screen Sharing Not Working on Mac (FIXED) (

Helli @ThereseSolimeno  i already did all this exercise but problem not resolved.

Thank you, this worked perfectly. Using Mac OS 11.6 


Thanks. Worked fine for my Mac Mini OS Big Sur 11.5


I did all of this, but when I got to #6, there's no Microsoft Teams option to select!

@BMarkley When you get to step #6, click the + Icon, then go to applications and select Teams. It'll add it to the list, then you'll be able to turn it on. Hope this helps!



Marketing Director

@ManishWadhai   I completed all the steps.  I see Microsoft Teams listed, but I'm unable to 'select the box' next to Teams.

Please help.




Remember to "open" the settings by clicking on the lock icon and giving it your password.

This worked for me. Thank you.



All settings are okay on my daughters Macbook 2020, but when I click share button in teams, only a blank square appears and no choice is available. Can you help? 

This just worked for me. Thank you! @ManishWadhai 

Remember to "open" the settings by clicking on the lock icon and giving it your password.


Macbook Pro M1PRO with Monterey V12.1.  Solution worked perfectly.  Thanks so much.


@ManishWadhai Thank you, this resolved our issue.

there was no menu to select screen share before or after following privacy instructions monteray 12.2 thanks

@ManishWadhai BLESS you for this. Was losing my mind and this is all it took to fix,

I didn't find the Teams application in my application folder. I do have Microsoft office, but should I need it? Honestly, I'll just stick with Zoom.
I have the same issue as @BMarkley: I follow all the steps, the lock is unclicked, but no apps appear in the window to check. When I use the + to add Teams from my applications, it asks to "Open then Restart" Teams, but then never adds it to the box in System Preferences. I am not able to add any applications there.
1 best response

Accepted Solutions
best response confirmed by ManishWadhai (Copper Contributor)
Hi, I have the same problem, and I found the solution:
1. Go to System Preferences > Click Security & Privacy > Privacy tab.
2. If there is a Team Application, try to delete it first by select the "Teams Application list" and klik the minus " - " sign in the left corner of the selection box
3. When finished, click the plus " + " sign in the left corner of the selection box, browse the Application > select the Microsoft Team (work or school).app and click OPEN
4. Now retry the share screen on Teams, it should work.

Greeting from Bali

View solution in original post