Microsoft Teams Rooms May update
Published May 21 2020 08:00 AM 98K Views

The impact of COVID-19 has dramatically changed how we work today, with a monumental number of organizations working from home. While physical meeting rooms may not be a focal point for many right now, there are still organizations and industries whose essential workers continue to rely on these spaces during this time. We also recognize the vital role Microsoft Teams Rooms will play when organizations return to work. To this end, we want to share the latest update for Microsoft Teams Rooms, app version, now available on the Windows store and coming to every Microsoft Teams Room over the next few weeks.


This release contains the following features:


Modern authentication support

Microsoft Teams Room administrators can now configure Microsoft Teams Rooms to use modern authentication to connect to Microsoft Exchange, Microsoft Teams and Microsoft Skype for Business services. Although Microsoft Teams Rooms already communicate over encrypted channels (such as TLS 1.2), using modern authentication reduces the need to send passwords over the network, leveraging tokens provided by Azure Active directory. To help reduce the potential attack surface, Microsoft Exchange Online will disable basic authentication in the future, as announced in the blog “Improving Security – Together”. Modern authentication support for Microsoft Teams Rooms will help ensure business continuity for your devices connecting to Exchange Online.


In light of COVID-19, and to reduce potential impact for existing on-premises customers who may need time to plan and implement hybrid modern authentication, turning on modern authentication will be manual. To learn more about how to set up and use modern authentication, follow the guidance published in Authentication in Microsoft Teams Rooms.



Application splash screen

The new application splash screen improves the startup experience when a Microsoft Teams Room device wakes up from an idle state or the device reboots. This provides end users with a more visually appealing experience while the device loads.



Project content to one or both front of room displays

For configurations with dual front of room displays, we now provide the flexibility to project content to only one display when using an HDMI cable to present outside the context of a meeting. Meeting Room administrators can apply this setting via an XML configuration file. Learn more about using the XML configuration file in the documentation titled “Manage a Microsoft Teams Rooms console settings remotely with an XML configuration file”.


Support for dynamic emergency calling for Microsoft Teams

Microsoft Teams Rooms now supports dynamic emergency calling and provides an updated calling experience tailored to emergency policies set by Microsoft Teams administrators. During an emergency call, both the console and front of room displays will show the phone number and location associated with the Microsoft Teams Room. Using emergency policies configured by Microsoft Teams administrators, the emergency call can be routed to specific emergency numbers. Learn more about emergency calling in Manage emergency calling.



Open Source Software (OSS) notices in device settings

Room administrators can now easily access Microsoft Teams third-party software notices on the Microsoft Teams Room console. Administrators can see these notices in Settings, under the About tab. Notices can also be viewed through the Microsoft Teams desktop application.


Senior Member

@Pavel Aivazov can you give recommendations for alternative cables?

Frequent Contributor

@Pavel Aivazov  - How are faulty USB cables responsible for the GUI not launching? My systems work fine post GUI launch. However each morning I come in and they are grey screened on the system, but when using my remote software it's actually just sitting on the Windows desktop and I have to hit the Windows button, and select the only visible tile which launches the Team GUI.


Hope this isn't the case (in reference to faulty cables) because I just had 2 more Meetup systems and 2 more Rally systems to leverage MTR that are scheduled to be done in the next week or two and then potentially 3 more to bring our grand total in the office to 10 MTRs. We have to run cables under the raised flooring and through walls and behind TVs and I really don't want to fish USBs again that was awful haha...

@Sohail Tariq I PM'd you some info and an additional question per your request. I extracted the logs using the Powershell script.

Occasional Contributor

@Lukas123 any cable USB cable from well known brand should be fine, again, shorter is better

@DBR14 now I understand that your symptoms are different from what I saw, sorry for confusion. In my case it was a real pain - as we had ~20 rooms where we had to replace cables.

Senior Member

I have upgraded 18 MTR’s to manually following @Graham Walsh's guide

The update went through 100% on all our Crestron Flex devices. I did the upgrade for the MA support. We have migrated all our MTR accounts to TeamsOnly with Exchange OnPrem and licensed the account with MTR license. Last weekend/early this week when I tested all the MTR’s with Teams/Skype/PSTN I had only problem with one account. That MTR-account is logging on just fine and showing calendar/Teams/Skype/Dial Pad. But when I trying click “Join meeting” (Teams-meeting) the device will not respond or join the meeting, I can’t even start a “New meeting” and the “Dial Pad” don’t react at all. I can start “Presentation” and “More” to do all the settings stuff and Skype-meeting links works fine.


I have done some (a lot) of testing with different accounts and different MTR’s, but I can’t really conclude where the problem lays. I have tried reinstalling an MTR, tried resetting the app for OOBE, but nothing seems to help. Today 5 or 6 more rooms have the same symptoms with no reaction when I click “Join Meeting”, “New meeting” or the “Dial Pad”. Skype-meeting links always works and the calendar always shows up. So it seems to be an issue with the Teams part of the app or account...? All the sign-in logs in AAD is “Success”.


As for now we have 12 MTR’s running Teams/Skype/PSTN perfectly.


One more curiosity; If I log on with an account that I know works and verify that Teams/Skype/PSTN works I then log on with an “account that is bugged” that bugged-account works fine UNTILL I reboot the device…


Any tips anyone? @Sohail Tariq @GerryVS 



@Toris_no , Please submit a support ticket and to expedite the process, please PM me links of the logs from the impacted device (s) so I can have product engineering take a look and able to assist. Thanks! 

Frequent Visitor


Please find a proper place where the Meeting Options should be placed. It covers a portion of the shared screen. Thanks!

Established Member

@Remar10  If I'm correct there is an update on the list this month that will move the bar to the top of the screen

Senior Member

Good Morning - are there any issues with conference room phone numbers pushing down to MTRs? We've followed @Graham Walsh article here and we have 2 rooms working but 2 that don't. The 2 rooms that do not work were installed this week, and their numbers were applied in AD on Monday, how long does it typically take for them to replicate down to the MTRs? I can confirm that they're update in AD and in Outlook properties, just not showing on the MTRs touch panel. Thanks! 

@jschina I have one system that this worked on and one that it hasn't replicated since.  Not had a chance to investigate what is up with it.

Established Member

@Toris_no  I've escalated it towards Logitech but there definitly seem to be something wrong with the latest Teams client on the MTR devices if you ask me,  I tried a lot of troubleshooting but nothing seems to help so far. I've tried swithing to Skype (Default) back to Teams (Default). Performed some windows updates. Tried a proximity based join but that also failed. I will try to open a case with MS as well this afternoon because when I see your having similar issues on Creston devices I don't think it's related to the HW vendors. So far the device we have is useless :(

Established Member

@Toris_no  meantime I received feedback from Logitech that the the last update pushed by MS via the windows store was not complete in some cases and that this is causing the issue on many devices running

Logitech asked me to force an update via Powershell what I will try todo tomorrow to see if this resolves the issue.


Senior Member

@jschina  have you added country code to the phone number? I had the issue on all our 18 rooms, but I just added +47 for Norway and number was showing within a few hours on the MTR.


@GerryVS  I have spoken with other consultants that got the same issue on ThinkSmart Hub 500 devices. They also went through a lot of troubleshooting and MS support tickets. On some devices it just started working again SUDDENLY…

And also follow Graham Walsh guide for updating the app: there is something with the -Update switch thats not working when updating the app.


@GerryVS @Toris_no  we have published a troubleshooting article specifically around 4.4.41, and are working to release an automated troubleshooting tool as well as address the root issue(s) in a future app update.  Meanwhile please contact @Sohail Tariq so we can collect logs from any systems with issues with 4.4.41


Senior Member

This morning all our18 MTR's are working again, why...? I haven't done anything to the MTR's or the accounts. Could it be a problem with Teams Services and Meeting Room license?

@GerryVS  I did manual update to on all my rooms, I didn't do it with the Store App. What type of licenses do you use on your MTR accounts?


@Sohail Tariq @Ilya Bukshteyn

Established Member

@Ilya Bukshteyn I went through the entire procedure but without any outcome. I took logs and I'm resetting the device right now as they will need to able to use it monday again. 


@Sohail Tariq If your interested in the logs you can drop me a pm.

@Toris_no  The manual update also didn't help :(


Meantime I also found out that it's not only the "join" button who fails to work, but also the "new meeting" option. Looks like the functions behind the buttons are somehow failing as you see it when you touch the screen it get's the focus, if you keep pushing some extra info but the functionality behind the buttons doesn't work. I can perfectly go to settings and into the other options


@Toris_no We identified a service side issue where the New Meeting, Join and Dial pad buttons would occasionally not function on MTR.  This was fixed yesterday on the service, and should be resolved on all MTRs after the last nightly reboot.  

Senior Member

@Toris_no @Graham Walsh - Thank you!! Adding in our country code resolved the issue! 

Frequent Contributor

Any ETA on a fix?

Regular Visitor

I would like to chime in that we have had many of the same issues on our tenant with our Teams rooms. We had several room devices fail to upgrade properly. Several units have new meeting and join issues. This last week we struggled through "cannot fetch calendar" issues that affected all our room devices. Engaging Microsoft support through the O365 has been a thoroughly frustrating experience. The reps we work with have no training on these devices and have no power to fix these issues. I'm always waiting on technical leads for more information. Took two weeks to fix one issue which was mysteriously fixed with an account "background sync" of the affected accounts. The current Exchange online calendar issue was fixed mysteriously over the weekend without even a hint of issue listed on the 365 service health portal. 


We love our MTR units and using Teams rooms. But as of late, I can not recommend the product to other companies if I'm asked. It has been too unstable and the support has been horribly lacking. Our hope is that things will improve quickly before our company deployment completes and our users are soured on the MTR product and start begging for Zoom rooms.

I'm wondering if anyone has information or has been able to get one of the latest settings on the MTR to work. 


Its the "Leave meetings automatically if everyone else has left".  I have tried to test this by just leaving the room in the meeting by itself, but I cannot seem to get it to work the way I would expect it to and I haven't found documentation regarding the function.


I'm wondering if @Ilya Bukshteyn @Greg Baribault @Christian Schacht or anyone else might have the details on how this works and might be able to share those details as my testing is just showing that it doesn't work the way that I would expect (which could be flawed in my thinking) and I have a few customers that are looking for no-touch options and this was one I was hoping might satisfy that request.


Teams room leave.png

Regular Visitor

After I installed the on a Surface+Logitech Smartdock+Logitech Rally+Dual Screen, the automatic presentation of HDMI input worked correctly, rendering the HDMI input in both screen and routing the HDMI audio to the Rally System.

But that was just the first time! From the second time I connected the HDMI input, the video is correctly shown on both screen, but the audio is routed to nowhere. It's not active on any device (PC presenting the content, Surface, Rally System and any of the screen.

I tried all the possible audio settings, but the audio is not present anymore.

Before the automatic dual screen presentation the audio worked correctly.

Senior Member

Wonderful features introduced to make teaching learning inclusive and accessible!!...

Occasional Contributor

We have now joined the group of customers, who have had all their SRS/TRS installations destroyed by the update.

We use Surface Pro 4 in Logitech SmartDock as consoles.

Thanks to the Jabra "turtles" we are still able to gather people around a table for meetings.

Now waiting for a new build from Microsoft to load onto the consoles.


Any of you that successfully completed the remediate app below, referred to by Ilya?

Occasional Contributor


@Ilya Bukshteyn 

@Sohail Tariq 


Wondering if you can help.  I am working on implementing the proximity feature with a few customers but results have been hit and miss.  I cannot find any detail on how it works other then some references to bluetooth.


My questions are how is this working:


1) Does the joining device (android/ios phone or windows laptop) simply do a scan for the bluetooth beacon of the MTR units? 


2)  Is it limited to people who are in the same Teams tenant? 


3) Is the 'nearby' item and how far you can be just based on the strength of the bluetooth beacon?


4) Also one customer has sworn to me that his laptops have bluetooth disabled yet he can see this option, although i am pretty sure he is just looking at a room list.  But still asking i 'assume' bluetooth must be on the client device for it to detect the MTR or if they are on the same wireless network can it find it somehow.


Always appreciate the insight you guys provide.  Please advise.  Thanks.




1) yes
2) yes

3) depends on multiple variables, HW, antennae, etc.

4) correct, customer must be seeing a last used room list


@Henning_Beck we have now added an automated PowerShell script to the troubleshooting article which can be run remotely and corrects all of the known trouble conditions we have seen with 4.4.41. We have also released app version 4.4.63 which will upgrade without creating these trouble conditions.

Occasional Contributor

@Ilya Bukshteyn  is that the MTRemediate- from the you are referring to?

Our consoles are not able to do updates on their own any more, so I need to build a new image with Windows 10 and TRS 4.4.63, right?

The version list is not updated yet. Will we be able to run 4.4.63 on Windows 10 version 2004? 

Thanks for supporting us!


@Henning_Beck you can find Windows version support in this article:


We do NOT support Windows 2004 yet.  How did your devices get to this Windows version?


If your devices are on a supported Windows version you should not need to re-image, you can use the PowerShell app you linked to and our app version 4.4.63 to recover the MTRs and get them updating normally again.

Occasional Contributor

@Ilya Bukshteyn @Sohail Tariq in follow up to my question about bluetooth beaconing I had a customer frustrated by the distance their units were working at for proximity.  (Saying they had to be about 3 ft from unit)


I had been doing some testing which is why i asked those questions for proximity.


I have been testing for the last hour using a combination of android, ios and windows devices and i have 4 different MTR units.  The results have not been consistent.


On the mobile ios/android devices it usually worked and i had a list of nearby and suggested rooms.


On windows it almost never worked.  I could easily join using the suggested list of rooms but i was not getting the nice big purple ribbon showing the option to join.  I had to click on the Add a room option and then pick a room which i am assuming is the same as the 'suggested list' that you see on IOS and Android.


I am looking for some suggestions or who/where i should open a case.   I had a Lenovo, Logitech w/NUC, Crestron Flex and Logitech SmartDock all available and nearby.


Please advise and as always thanks!


A few weeks ago, we released an update to Microsoft Teams Rooms, version 4.4.41, that left a small number of devices in a state where the application did not automatically relaunch, and required a set of manual recovery steps.  While we always have quality and reliability of our devices and services at the very center of our work, in this case a combination of factors hindered our ability to detect, diagnose, and mitigate the issue quickly.  We understand how disruptive this can be to your business, and sincerely apologize.  We have worked with several customers who graciously provided device logs and information which allowed us to identify the root cause, thank you.


The issue: as the Teams Rooms application was being updated, the Windows Appx update process was running a part of our scripts before the app was fully upgraded, which resulted in a condition in which the app could not re-launch.  Working closely with Windows, we’ve identified and addressed the cause, and we have added checks in our startup process to detect and manage this condition.  While systems in this state will require a manual step to recover, we have created a script which can be run to recover a system, and put it back into a healthy state, and most importantly put in safeguards to prevent this issue from recurring.  The script is available here:


Once identified, handling specific issues like this is a matter of identifying the root cause, and putting the right fix in place.  What’s more challenging, but far more important is preventing this type of issue from happening again.  We’ve made changes, in both Windows and in the Teams Room update scripts and application to prevent this type of issue from recurring, and the telemetry signals necessary to make sure devices are updating correctly.  These changes are available in the 4.4.63 release which is now available to 100% of Store updating systems.  We are also modifying our release process

to better protect all of our customers from issues like this going forward. 


Thank you for your patience, and for working with us to resolve this issue.



Greg Baribault

Group Program Manager, Teams Shared Devices


@ToddMethven Bluetooth strength may vary from device to device depending on adapter class used, direction/ orientation of the device, field type and many other factors. (Learn more). However, regardless of adapter used in the device, 3 feet seems pretty low and points to issues with device driver or adapter itself. Here are a few links to troubleshoot for Windows 10 device: 

If your adapter has correct driver and doing small tweaks like changing the orientation of the device doesn't work, you may consider getting an external USB Bluetooth adapter/ extender. I am also curious if you have used Bluetooth on the device for other scenarios (e.g. playing music) and gotten similar range to help identify if the issue is hardware or proximity based scenario. Please PM me with results.  

Thanks for the great insight @Greg Baribault 

Out of interest, should users run the script on a working system?  Such as a system with or that's working fine?  I'm guessing not and it will get from the Windows Store when it's ready. I've just re-imaged a system and it got straight away from build, so no issues in this test.


@Graham Walsh Correct, If the device is running fine, it will upgrade to automatically. Users should only run the tool if the device is not automatically upgraded to

Occasional Visitor

Hi, we have been ordering the Microsoft Teams Room Systems with Logitech hardware from CDW. When we receive them they are often on older skype room system builds. When we started getting these devices early on they seemed to update on their own to the latest builds via Windows Updates. Lately I have had to create images and reimage the machines to get them to work. The old versions... I believe have all sorts of issues.


My question is, should this be standard practice at this point? Just to create the image every time. I feel like the devices should be able to upgrade on their own to the latest version... is there something we are missing here?

Frequent Contributor


We get ours from CDW as well. Logitech has some other company image all those NUCs if you hadn't noticed. They've botched a couple of them too...


I've always found running full Windows OS Updates on the machines has fixed this issue, after the OS is updated to 1909 - DO NOT do 2004...

Then my MTR's run fine and update within 24 hours.


I believe there is also a PowerShell available to force an update of the MTR's if they aren't doing it on their own.


All MTRs should update unless store updates have been disabled. We also work with OEMs to update their factory images over time also, but disti stock may not get updated. @Sohail Tariq for more

I put together an article here on OOBE when you receive it from the vendor

Occasional Contributor

@Ilya Bukshteyn  You wrote "We do NOT support Windows 2004 yet.  How did your devices get to this Windows version?" 
I understand that. All our Windows devices in the domain, including the consoles, automatically update to whatever is available from Windows Update, though. 

There are many not-working tips out there. How do we effectively avoid our TRS consoles being updated to the next windows versions?


@Henning_Beck  we do put in blocks for MTR to not update beyond the Windows version we support. However if you domain join your devices and have them be domain managed then these blocks can be over ridden with domain policies. In which case your admins should actually manage the devices, meaning create a group for MTRs with specific policies, and then manage (via SCCM or WSUS or similar) which Windows updates are approved for the MTR group.  So basically either the MTRs should be "unmanaged" and you leave the update policies to us, or else they should be actively managed by your admins.

Frequent Contributor

Can you record your meeting within the MTR GUI? I don't see a way, but maybe I've been missing something.


@DBR14 you can't start recording from the MTR console yet.  That's on our roadmap for H2 of this Cy. 

Occasional Contributor

@Ilya Bukshteyn Is the Telephone number for the MTR also on the Road map?  it would be good to have it on the home screen rather then needing to search for it? or worse...Putting a label on it so users will know the tele number of the device when they walk into the room. :sad:


@kerry6a1 not sure I understand the question; we do already support the MTR having a phone number and showing that on the display.  @Sohail Tariq ?


Senior Member

@kerry6a1 make sure your MTR account have your country code + telephone number in AD/AAD. 

Occasional Contributor

Thanks @Graham Walsh I did not, and now have.  @Ilya Bukshteyn  sorry.  I should have done a search before asking.

@kerry6a1 No worries, that is what the community is for, asking questions, there is lots of info out there, so can get lost easily. 

Occasional Contributor

@Sohail Tariq  or anyone very excited about the new builds ability to enroll into the Teams admin centre.  Is there by chance any way to force your system to get this new update.  I want to begin testing immediately!


@ToddMethven :) I love the excitement. We are at 20% store right now and will roll out 100% store next week. 

New Contributor

HI, do we have an update on 3 x 3 participants and are we going to get 7 x 7 as this is a must if we want to get the most out of MTR

Version history
Last update:
‎Jan 26 2021 12:09 PM
Updated by: