Introducing Microsoft Teams Rooms (Updated)
Published Jan 23 2019 08:09 AM 515K Views

[Update Note May 2019]
Adding an nearby Microsoft Teams Room is now available for your desktop and mobile clients May update (see more details bellow).


Two years ago we introduced the next generation of Skype Room Systems, a center of room control with one-touch join, to add the best audio and video to your meetings.  We started with one hardware partner and now work with six leading device manufacturers, to deliver the best quality experiences for both Skype for Business and Microsoft Teams meetings. To date, customers have conducted more than 130 million minutes of meetings through Skype Room Systems. In light of this momentum, and to mark our commitment to making Teams a complete meetings and calling solution, we are rebranding Skype Room Systems as Microsoft Teams Rooms.

 

This rebranding signifies the continued delivery of features being built to enhance Teams meetings experiences. Our goal is to extend Teams meetings into every space from small huddle rooms to large conference rooms.

We’ve recently announced and delivered several capabilities that enhance the Teams Meetings experience in meeting rooms:

  • Proximity detection (Update May Available NOW), makes it easy to discover and add nearby, available Microsoft Teams Rooms to any meeting.
  • Companion experiences with mobile, to join your devices in content-only mode.
  • Support for dual screen rooms.

And it’s important to note that Microsoft Teams Rooms still work with Skype for Business calls and meetings.

 

 

Meetings Simplified

Meetings are easy to schedule, simply use Microsoft Outlook or Microsoft Teams to invite your conference rooms to a meeting just as easily as inviting your colleagues.

 

Schedule Teams in OutlookSchedule Teams in Outlook

 

One touch-join

Instantly start your meeting from the center of the room control with one touch.

 

Microsoft Teams Rooms ConsoleMicrosoft Teams Rooms Console

Add nearby meeting room

Proximity based meeting join, for an available Microsoft Teams Room, the Microsoft Teams client on your PC and mobile has a proximity sensor that detects the room and you can add the room easily to the meeting from your pre-join screen on your client.

On your PC the pre-join screen of your meeting will highlight that an Teams Room is nearby. 

Add nearby room from your desktopAdd nearby room from your desktop
On your Teams mobile client you can add the room to your meeting and find nearby rooms quickly.

Add Conference Room from your MobileAdd Conference Room from your Mobile

Inside the meeting room, the front of the room display and console will show that you are trying to add the room, and simply accept the incoming invitation on the console to bring the room into the meeting.

 

Proximity join from Microsoft Teams RoomsProximity join from Microsoft Teams Rooms

 

Microsoft Teams will automatically join the meeting in content-only mode from your desktop, allowing the room to provide audio and video into the meeting without echo and feedback generated by the other clients in the room.  Also your mobile client will switch to content-only mode after adding the room.

If the Microsoft Teams Room is already in the meeting and you like join from your devices as well, Teams now detects this and recommends to join the meeting with audio off as well.

Pre-join screen when the room is already in the meetingPre-join screen when the room is already in the meeting

Learn more about how Microsoft has deployed Microsoft Teams and Microsoft Teams Rooms internally to more than 2,400 meeting rooms around the globe and how Microsoft is using the integrated meeting solution to reshape the collaborative environment into a simple, consistent, and reliable experience for thousands of employees.


Additionally in our phones business, we recently added our first native Teams Phones from Yealink, the T56A, T58A, and CP 960.  These desk and conference room phones all have a touch screen and existing customers can now instantly upgrade to Teams as they migrate their platform.    


Look for more exciting announcements from our partners at Integrated Systems Europe in February, and please visit aka.ms/teamsdevices to learn more about our portfolio of Teams certified devices.

 

Let us know what you think!

Try the new features on your Microsoft Teams Rooms and provide feedback via User Voice or vote for existing ideas to help us prioritize the requests. We read every piece of feedback that we receive to make sure that the Microsoft Teams Rooms experience meets your needs.

 

- Christian Schacht, senior product marketing manager Microsoft Teams Rooms

 

810 Comments
Super Contributor

@johnwaldron 

If I'm honest, I would love to hear what those updates really are? Shall we prepare ourselves to these somehow and what are the actual changes? At least I have not been able to found a single word about them. And personally, if these are a previews, it would be nice if the subject could clarify that. Not even on Microsoft's roadmap: Search "Web Client" 

@johnwaldron Yes, many of those updates are web service updates. However, front row is not yet rolled out, slated for January. Some more info here 

Microsoft

@Petri X , all features should have a Message center post that goes out 30 days in advance of hitting the GA. Please search for Team Rooms on Windows from Message Center in your Microsoft365/ Office365 admin center to keep track of what's coming. All features are also posted to Microsoft 365 roadmap site with title "Microsoft Teams: <Feature name> for Teams rooms on Windows". This should provide ample heads up for you to know what's coming. 

Starting in Q1 2022, we will enable Public Preview for both Web client and Store builds ahead of GA release. You can opt-in to Web client features "Public Preview" today as well using instructions posted at Public preview in Microsoft Teams - Microsoft Teams | Microsoft Docs but it will require an additional step to log in to room account from Web browser and enrolling in "Public Developer Preview" similar to Teams desktop client. In Q1 2022, we will make it easier to enroll devices into public preview using XML and Teams Admin Center and utilize Tech Community Microsoft Teams Public Preview - Microsoft Tech Community forum to make announcements for all upcoming features. Please stay tuned for more documentation/ tech community blog on how to enroll in public preview early next year. 

Senior Member

Hello Team,

 

I am in big trouble at 3 customers' as they just noticed that Edit Settings from Teams Admin Center in Teams Devices did not work as expected.

They launched weeks (months) ago the change from Skype for business and Teams (default) to Teams only. They clicked on Save and let the nightly reboot do the rest!

Trouble is, they did not notice that the configuration stayed stuck in QUEUE mode and would NEVER switch to successful. So any reboot would not apply the changes. And now, end of the year, I would need to run to all the rooms around the different sites to change locally the setting on all MTRs!

 

I cannot find any details of what would block the settings change in the customers' network. Guess what : each customer has a proxy! Otherwise this would not be fun! Proxy is configured in Load Hive Skype and all the URLs listed in https://docs.microsoft.com/en-us/microsoftteams/rooms/security#network-security are whitelisted and the MTRs work fine otherwise. They are all in 4.10.10 and 20H2. All brands are concerned.

We made the test to connect an MTR out of the customers' network and then TAC configurations success.

 

Restart can be launched from TAC and Logs can be collected.

 

If you have any details of network blocking point from TAC to MTR please share. I can provide logs of 1 MTR I collected.

 

Thanks all

Super Contributor

@Sohail Tariq 

About those updates.. when looking for the app version from TAC it says:

Teams App4.10.10.0
 
And when looking for the release notes: Teams Rooms Web client update (December 2021) it says:
"Split video layout across dual Front of Room displays when content isn't being shared"
 
Then how it is possible that on our rooms the videos are split between two screens when the content is not shared? I thought those web clients are still on preview phase? But have we still received those versions, and if yes, how to detect that?
 
At the same time one old problem seems to came back with this. I got the first reports that videos from others are cropped. But that I need to get better report. And that seems to be on other clients than Room System as well.
Microsoft

@Petri X , Teams web client updates will work with existing app store verion of the application. I will be posting a detailed blog post for everyone to understand MTR releases soon. But in nutshell, there are two release trains. Store app (which is the version mentioned in TAC) which is the main application which contains SfB, Teams, 3P client to join Cisco/Zoom meetings and device agent for TAC communication/ device mgmt. Everything except for Teams application is updated through Store app. Teams is a web application and uses same mechanism as Teams desktop for updates. Features within Teams are released using web client update, and have been for couple of years now. If a feature doesn't have any app level UI (e.g. app home page, settings etc.) it doesn't need store app to release at the same time and will work with existing store app. We are working on enabling Public Preview for MTR store app and web client features for customers to try out these features and provide feedback before they are rolled out to GA. Again, expect more concise documentation around this soon. 

For video crop issue, after you verify, please submit a support ticket. We now use the same gallery component as Teams desktop, so it should not be isolated to Teams rooms only, and we can take a look at this and get a fix for both Teams desktop and Teams rooms sooner since the impact of such change will be too broad.  Hope this helps!   

Senior Member

Is anyone else experiencing an issue in Teams Admin Center this week where MTRoW devices are showing as offline even though they are online and functioning properly?

 

Since Monday 1/10 and every day since I have anywhere from 20 to 35 showing as offline, but in other tools i.e. Microsoft Teams Rooms - Managed Services and Lenovo ThinkSmart Manager they are correctly showing as online.

 

Even from TAC I can effect changes to the ones showing offline and even restart them. Something like this could be a real problem if our org decides to not subscribe to premium tools and rely on TAC for monitoring and management.

Microsoft

Hello @johnwaldron, We are sorry to hear about the issues you are facing with Teams Admin Center.  We are not aware of any recent issue that would cause this behavior.  Please reach out to me directly so I can obtain the relevant information needed to investigate the issue you are facing.  Also, please reach out to Microsoft support for additional assistance. 

Super Contributor

@Sohail Tariq 

The blog would be highly appreciated :D

 

At first you said: 

"Store app (which is the version mentioned in TAC) which is the main application which contains SfB, Teams, 3P client "

And then continue:

"If a feature doesn't have any app level UI (e.g. app home page, settings etc.) it doesn't need store app to release at the same time"

 

Does the store app really contains Teams, as it sounds very much that there is isolated web client for Teams? And seems that the Room System app just controls the Teams Web App? Or, is it really Web App, as the desktop client on workstation is not web app. I though, the web app is updated directly in the cloud, while desktop client is more slower by downloading update and then doing the update. So I'm not sure if this is really so: "Teams is a web application and uses same mechanism as Teams desktop for updates."

 

But at the end that means, Teams client on the room systems does not follow the Room System version. Do we have possibilities to verify the version, and are there any reasons to follow its version?  Of course this makes our life more challenging, when we have been asked to take control for the client versions :D

 

About the cropping, that we found is not with the rooms, only desktop client versions. Somehow I remember when video is cropped, Teams client has been able to centralize the person even user moves a bit on the video. But this was not room system issue, so I need to continue that.

Microsoft

@Petri X, Please read more about Teams client updates here: Teams updates - Microsoft Teams | Microsoft Docs
Please note that Teams rooms application updates are not meant to be controlled. So, the store application updates itself when a new release is available and Teams web client updates independently of Teams room store application, following same cadence as described in the article above on Teams updates. 

Senior Member

@Sohail Tariq , @kspiess , @Graham Walsh - Need some advice / clarity on MTRoA update management from TAC. The manual firmware update process seems not working from TAC. I changed from 30days deferral and tried enforcing a manual FW update on a Poly X30 but it didn't pick. If I do it via Poly admin portal (Choose Polycom support site to download update from) and click 'Update All', it picks it up immediately.

Also, manual update of Teams app from TAC is also not happening for the Poly X30.

Super Contributor

Hi,

Has anybody faced issue where on the MRS the Skype account is able to sign-in, but app does not start. On the screen we have only:

DesktopAPIHelper.exe - System Error

Exception Processing Message 0xc0000005 - Unexpected parameters

[OK]

 

From the devices I found that there are over 200 processes for DesktopAPIHelper.exe.

 

Yes, I have case open as well, but if here is someone who already had such experiences.

 

 

Edit. Home made problem, the patches brake the devices so that service Win Device Admin Agent did not started at all on MRS. :flushed:

Senior Member

Finding an issue on all MTRoW in my fleet that are updated to 4.11.12.0.  The new Meet button does not work - when tapped, there is a brief loading screen and it promptly reverts back to the main screen.  Thus, no ad hoc meetings can be initiated from the MTR.

 

Meeting mode is Teams Only.

 

Anyone else seeing this?

 

Edit: It seems the issue here is special characters in the display name.  We have a ":' as a standard in all.  Thanks for your assistance in diagnosis, @Sohail Tariq 

Microsoft

@Teamsguy1790 , this is first I heard of this issue. Can you please try rebooting the device just in case it's missing Teams web client update? If this doesn't fix it, please file a support ticket with logs from MTR and pm me your support case number. 

@Raja Boopathy No idea I'm afraid. I'd open a ticket with Poly to assist with the case and understand what version TAC is meant to roll out to the x30 devices.

Senior Member

@Teamsguy1790 I'm experiencing the same issue on one of my test MTRs, a Lenovo ThinkSmart Hub, type 11H0

Senior Member

@Teamsguy1790 Is MS going to fix the special character issue? We have well over a thousand accounts with the display name starting as >Conf:

Senior Member

@johnwaldron I have been told so, yes.  But, very early rings so far, so at this point I am not expecting it anytime soon.  Will post more if I hear.

Senior Member

Regarding the the special character in Display Name issue, I have found there is strange behavior on our MTRoWs still running 4.10.10.0. The "New Meeting" button calls up the new "Call" page with the dial pad. The "Dial Pad" button also calls up the new "Call" page.

Calling app update.png

@johnwaldron Are you in Teams Only or mixed mode? Wonder if that makes a difference?

Senior Member

@Graham Walsh We are temporarily in Islands co-existence mode with a very small footprint of users still utilizing on-prem SfB for call center applications. When I use my personal credentials in the MTRoWs the new feature controls work as expected, but they do not when using credentials for our meetings spaces which have our standardized display names starting with identifiers >Conf:, >Train:, >Flex:, etc.

Senior Member

@johnwaldron @Graham Walsh I have the same dial pad issue with New Meeting, on those remaining on 4.10.10 (only a few left). 

-MTRs are all in Teams-only Mode 

-Coexistence mode is Islands

-Exchange on-prem with hybrid 

Senior Member

@Teamsguy1790 @Graham Walsh Update on the new "Meet" button issue. The issue has been corrected on our MTRs running 4.11.12. The new "meet" button now launches a meeting calling up the meeting page as expected. The issue persists on our MTRs running 4.10.10 where the "New Meeting" button calls up the new "Call" experience with the on screen dialer and does not launch a meeting.

Microsoft

@johnwaldron @Teamsguy1790 , Meet now issue where it fails to initiate a call if the room name has a special character in it is now fixed for both Teams desktop and Teams Rooms clients. The fix is deployed at 25% and will rollout to 100% Teams desktop and Teams rooms devices in next 24-48 hours.
The issue with 4.10.10 where the New Meeting button shows call experience is also fixed and being deployed in next 24-48 hours. 4.10.10 should show legacy "New meeting" experience. 

Senior Member

@Sohail Tariq Thanks for the update. That's excellent news!

Senior Member

@Sohail Tariq Amazing - thank you for the quick work on that.

Senior Member

@Graham Walsh @Sohail Tariq @kspiess  / All - Does anyone know which network ports to be allowed or any other network level changes predefined for using 3rd party guest join for Zoom and WebEx from MTR please?

I have tried searching for this from MS blogs and as well as from Zoom and WebEx but could not find anything specific to network config.

Super Contributor
Senior Member

@Petri X  - Thanks, I have checked them both before. These are the recommended network traffic for Zoom and WebEx in general. Wondering if there is anything specific to MTR guest join. There is nothing listed in Microsoft docs https://docs.microsoft.com/en-us/microsoftteams/rooms/third-party-join from network traffic perspective.

Microsoft

@Raja Boopathy , Direct guest join uses web apps from respective third parties (customized for room scenario) and all web apps use WebRTC, so nothing other than what works with standard.internet Ports 80/ 443 

@Raja Boopathy Here is the official docs Enable Teams Rooms devices to join third-party meetings - Microsoft Teams | Microsoft Docs As to joining a Zoom Web meeting, Zoom's docs are here

Regular Visitor

Adding on from this has anyone had issues with WebEx meetings? We have a multitude of devices, for example Lenovo Logi and Yealink whereby joining a WebEx meeting just shows a black screen and does not actually join the meeting.

We can attempt to join the meeting and get as far as the below screen, then when it attempts to join a black screen occurs. If I join from WebEx on my machine i cant see the MTR's; so it appears they are not actually joining.
@Sohail Tariq have you heard anything on this issue?

James_Hammond_0-1644941336808.png

 

Senior Member

Hi Team,

 

Wanted to express my disappointment with the way some OEM partners are behaving recently with OOBE issues. We happily Prestage our systems to ensure they are fully up-to-date  before deployment. However we are increasingly being asked to reimage MTRoW By the OEM. This appears to be the default response, We have seen this increase exponentially, are starting to question the stability of these products. We currently have a fleet of 5 newly deployed systems which require reimage due to the keyboard pop up not showing when in in the MTR App. Surly there must be a easy fix then having to reimage the Compute?? At our expense and the end user dismay? JTBC - The keyboard shows when entering windows settings but not while the app is running.! Any assistance would be appreciated

Senior Member

@Integ1978 That virtual keyboard issue keeps resurfacing every now and then. Seems like whack-a-mole. It pops up in an update, gets fixed, then pops up again later. I experienced it today on a MTRoW for the first time in a while.

Microsoft

@James_Hammond I am not aware of any customer reporting this issue with Cisco Webex meetings in Teams Rooms. I also followed up with Cisco and they have no seen this either. Could you please file a support case with us? Thanks

Senior Member

Hello - I have noticed that the recent MTR update to 4.11.17.0 seems to be causing issues with newly deployed units.

 

Specifically - I have a stock of Lenovo Hub Gen 2 MTRs with a factory build of 4.8.19.0 on Windows 10.0.18363.418.

 

My normal deployment process is to follow OOB through + sign in device, update MTR app to current, then initiate windows updates.

 

Now, after updating to 4.11.17.0, Windows will not update beyond 10.0.18363.418.

 

Anybody else experiencing similar symptoms?  Any insight is appreciated.

Senior Member

@Teamsguy1790 - I have not tried this approach before. Used to follow OOB, sign-in and keep the dock on network for 2-3 days for updates to apply automatically before deployment. If I am not wrong it updates the MTR app and eventually fetch the relevant Win10 build update. The build you have referred is 1909 where MTR app supported between 4.5.33.0>=4.9.12.0. Only 20H2 is supported for version >=4.10.10.0. Refer this lifecycle sheet for more details - https://docs.microsoft.com/en-us/microsoftteams/rooms/rooms-lifecycle-support

But for scenarios like this, I would say that installation of latest MTR version 4.11.17.0 shouldn't have been allowed for you. If the lifecycle sheet is right, you should have received a message for compatibility and it should have only applied 4.9.12.0 (since the device build is 1909). This is something for Microsoft to correct.

@NancyForero , @Sohail Tariq , @kspiess , @Graham Walsh  - FYR.

Your summary seems to be correct @Raja Boopathy but I’m sure one of my test devices is on an older Windows build still (as I re-imaged it) even though it is 4.11.x.x. Can’t check now as on vacation. I can’t seem to get it on to the latest supported Windows build. As it was working, I didn’t worry too much as no time to troubleshoot it.

Senior Member

@Raja Boopathy Thank you for your answer.  In the interest of feature parity, we like to have all updates done on the day of deployment.  But, since I've seen this, I've left them to their own devices to update - so far none have come naturally.

 

Currently, the only version available here is 4.11.17.0, which leads me to believe this is the production version.  (It would be nice if there were an archive of recently past versions for situations like these).

 

Now, I hope that I am not stuck with Winver 1909 on the units that I have brought up to date to 4.11.17.  

Senior Member

@Teamsguy1790 - In the lifecycle support docs, it is mentioned to manually update the MTR app to the latest version after setup and sign-in as (you did), so that devices that run the Microsoft Teams Rooms app automatically update to an appropriate Windows 10 release during the nightly maintenance reboot.

However, the doc also says that windows feature updates are delayed up to six months intentionally as validation period. To be fair, it's not clear. I will also try to reproduce the steps from my end. But better clarity needed from Microsoft on this.

1.JPG

2.JPG

Microsoft

@Raja Boopathy , Your steps look right and it should offer the correct Windows version. To help troubleshoot why Windows is not updated to latest supported version of Windows, can you please contact Microsoft Support and attach MTR logs as well as  get Windows logs and attach to the ticket.
Here's how to get Windows update logs:
From PowerShell, Get-WindowsUpdateLog and attach the file it generates (which by default should be "WindowsUpdate.log" on the user's desktop).
Please also attach these files to the ticket:

C:\Windows\appcompat\appraiser -> appcompat_appraiser.zip, C:\Windows\System32\appraiser -> system32_appraiser.zip.
Thanks! 
CC: @Ragini_Murthy 

Super Contributor

I got quite interesting call from users. They have had high important meeting where number of MTRs has been participated. Then one of these MTRs steps into "hold" mode, and looks like it was calling or receiving call from certain "+countryCode" -number. Obviously after the meeting, users did not had idea of the number, and why they should, as they are just users and the technical evidences is not their work.

 

It is quite interesting to noticed that after several hours, I'm quite alone. It seems that I have no evidence to say if this happening or not. From the CDR of that MTR account I cannot see any calls arriving to that, nor call tries.

 

Anybody knows the good list of the cases then the MTR could go to "on hold" -status?

 

I really wish to one day to understand clearly why we (as regular administrators) are not allowed to do a real troubleshooting with Teams/rooms. 

Regular Visitor

@Ilya Bukshteyn@Sohail Tariq do you know how we can sign in to an MTR admin settings and admin page with a device that is Azure AD Joined. The account that was used to join the device to Azure AD Join can sign in to the settings. But none of our other Admin accounts can. Is there a specific role that the users need to be in?

Many thanks in advance

Contributor

Click "Other user" and type ".\admin" for the user, then use the local Admin account password ("sfb" if it hasn't been changed).

Regular Visitor

Hi @RayGentry yes we can still get in with the local admin but we want to use accounts from AAD so the local account details are not given out. Therefore the support staff would log in with their AAD support accounts.

New Contributor

@jcjamif you used windows settings to join the device to AAD, only the enrolling user becomes local admin and the others are standard users.

 

This article discusses a few methods you can use to make std users local admins on aadj devices:https://www.mobile-mentor.com/insights/azure-ad-local-administrator-access-how-to-options?format=amp

 

hopefully this helps in getting additional users access to the mtr admin settings app on the device.

Super Contributor

When you are connecting your laptop with HDMI to MTR, the MTR informs on the meeting that:

"Couldn't share system audio.."

Is this caused by laptop or MTR? This seems to be not a common issue, but would like to be smarter when this is coming in next time?

 

Microsoft

@Petri X This could be faulty cable, HDMI hub or the laptop port connection being loose. It may be as simple as re-plugging HDMI connector/ dongle or a more complicated issue. If this happens often, please try HDMI ingest directly from MTR without anything in between to isolate issue. If you believe this message is shown in error, please report it to Microsoft support with logs from MTR. 

Super Contributor

@Sohail Tariq big thanks for your reply. Unfortunately I have not been able to be in the room while this issue has been so I do not have so much of deeper knowledge of this. These questions are not coming often, so I believe the solution could be as simple as you proposed: re-plugging the HDMI cable  :D
Have a great day !

Super Contributor

A real dummy question..

If we change the display name of the account/mailbox for the MTR, what would be the correct (minimal) action to get the device using the new name? Currently on the hub there is still the old name, has been there several days already. And no reboots helps.

Version history
Last update:
‎Jan 26 2021 01:28 PM
Updated by: