The application was not detected after installation completed successfully (0x87D1041C)

Copper Contributor

I' ve packaged Notepad++ with the IntuneWinAppUtil tool to deploy it with the Endpoint Manager, but i keep getting the following error message after installation. 


The application was not detected after installation completed successfully (0x87D1041C).


I tried different detection rules:


Registry key:

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Notepad++\"C:\Program Files\Notepad++\uninstall.exe"


and File>

C:\Program Files\Notepad++\uninstall.exe


I get the same error message with both options.

Does anyone have any tips to get rid of this error message?

11 Replies
best response confirmed by TechSkills (Copper Contributor)
Thank you very much @Harm_Veenstra! This detection rule worked for me.

@Harm_Veenstra I have the exact same issue, your solution works great for Win32 apps yet I'm getting this exact same error with a "Microsoft Store app (New) deployment for "Company Portal"
No option to set the path, not many options at all for a store app deployment, so I am wondering why the app is not detected and if anyone else has experienced this and may have a possible solution.

Did you switched from the legacy company portal (user based) the new company portal? Is this on an existing device or new enrolled ones

@mparker1760 Weird, I deployed it in my tenant like that without any issues a while back:






But if you have issues, perhaps it's better to post about this in a new topic instead of this already closed topic...





Indeed, it appears to be a detection rule problem. I've encountered this issue several times and successfully resolved it by addressing the detection rule. However, when using the Microsoft Store App (new) deployment method and encountering error code 0x87D1041C, it indicates that the application already exists on the device, leading to this specific error code. This is a known issue in this scenario.


If you want to read more about the error code, you can refer to the blog post:

@Rudy_Ooms_MVP Hi Rudy, this is deployed with the new company portal and it's only happening on devices that already have the app installed. Daily notification that it didn't install. I use detection rules on other apps yet there is no option for a detection rule on the (New) deployment method. I may try to just download the app and use the "Windows App (Win32)" deployment method and see if that works.

Ahhhh yep... the detection method is a bit off.. (the same as for the company portal itself) when moving from system to user context, even if the app is already installed... what happens when you try to remove that app on 1 device to see if the grs check-in the other day now could successfully install the app?

@Harm_Veenstra I thought I will tag on to this, as I am trying to install dell command updates and my version is 5.1.0 and when I try to use the version to detect greater than or equal to I get this error message. So, how can I get this to work successsfully? As, I have previous versions and I cannot be pointing to a folder as the previous version also has the same exe file. So, how can I address this?




Could you share the detection settings?
1 best response

Accepted Solutions
best response confirmed by TechSkills (Copper Contributor)