Sync cannot be initialized 0x80190194


I have one device which cannot be synced since 2 month.

I am getting the message: Sync cannot be initialized 0x80190194

Any idea about this?


Best regards,


17 Replies
Is this a device you have access to?

@Thijs Lecomte yes, sorry for the late response.

I also rejoined it already but its still not syncing.


Getting an evententry: MDM Session: OMA-DM client stopped with status: (Not found (404).).

@m_kroneDid anyone get a resolution for this? I'm having same issue but no joy so far


Getting the same evententry: MDM Session: OMA-DM client stopped with status: (Not found (404).).

@RyanWilson unfortunately i dont found any solution. It ended in reinstalling the device.



@m_kronethanks for the update, i will keep on investigating and i have a call open with MS so if i get a resolution i'll share incase it helps you in the future :)

best response confirmed by m_krone (Contributor)

@m_kroneI found a solution, hopefully this helps you




HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Enrollments\[some guid which has the enrolment information]


  • removed both reg paths above
  • ran dsregcmd /leave
  • reboot device
  • ran AAD connect to provision device back into Azure AD
  • device now Hybrid joined again and registration date is todays date and time / MDM set to none
  • dsregcmd /status shows information is being pulled down, waiting for MDM URLs to populate
  • Info button on settings / user accounts has now disappeared
  • Rebooted device again after 10 minutes
  • Upon reboot the MDM URLs now populated
  • Event logs show device enrolled
  • Info button now available and sync status is successful
  • Intune policies applying
This worked for me, thanks!

@Daniel Baird thanks, good to know it helped :)

@RyanWilson what is that for? 

I have an issue that i cant see my pictures and videos, the error says that this item cannot be displayed when I try to use the Onedrive app in my phone, but when I try to use the onedrive on my laptop I get an error saying that something went wrong, please I just want my data back.

@Marcus355 Hi

This error is regarding MDM enrollment into Intune, this error has nothing related to OneDrive sorry

If your data is missing then try using the recovery option in OneDrive on the web or raise a call with MS.




HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Enrollments\[some guid which has the enrolment information]


- There are a lot of entries under this that have enrollment information, I only deleted the one with the same GUID as the Tracking.... - is this correct or should I remove them all?


After going through this guide, now dsregcmd /status says that I am "AzureAdJoined : NO" and I have "WorkplaceJoined : YES" and "WamDefaultSet : NO"


Are these steps required to be done while hardwired into the corp network?



Please have a look at my blog which goes into further detail, if you still get stuck let me know






Thank you Sir, however I do not think this is working either because I am remote/vpn and/or this is an AutoPilot device.


It will not remove from AAD... I will delete it from AutoPilot and try this again. dsregcmd shows it is not in AAD but when I go to the web console the device is still there and managed.


If the device is autopilot then yes remove the hardware hash from your tenant and remove the device from AAD and intune. Then try this the blog again if you still get the problem.




Thank you, it now shows in AAD as Hybrid Azure AD joined however, local registry has not updated nor is the device listed in Intune yet.


Validated Registry that there is no other Enrollments listed as described in your post. Was not able to get your script to work but did a manual lookup in Registry for both values "SSPHyperLink" and then "" and neither returned results.


Only error in Event Viewer is now MDM Push: Failed to renew WNS Push Channel for MDM Push Sessions. Result: (The system cannot find the file specified.).


Have restarted the system multiple times and logged back into the VPN each time.


Thoughts? We do not have pre-login setup or AOVPN at this time.



You may need to remove the token settings to pull down new settings, follow this article i posted awhile back:

Check out the steps at the bottom regarding removing settings files.



It has been a sometime but I would like to drop this about the error. I have tested the same behavior in my labs as a part of a client deployment.

This is because, the MDM and MAM Scoping were not set properly or it is moving downwards.

If both MDM and MAM scope are set to All, - all the client computers that are not joined to azure or just domain joined will be given a MAM profile with the initial registration. This MAM profile must be removed after changing the scope.

the easy solution is that we go to the work school - remove the account and reconnect the account. the sync issue would be resolved.

Thanks, BR, DJ