Hybrid Azure AD Autopilot

Contributor

I am not able to 

 

  1. The device will send its hardware hash to the Windows Autopilot services.
  2. If the device is registered with Windows Autopilot and has an Autopilot profile assigned to it, the profile details will be provided to the device.  In the Hybrid Azure AD Join case, the profile would tell the device what Azure AD tenant the device is associated with and that the device needs to be joined to Active Directory, but it does not specify the Active Directory domain details. 
  3. The user will be prompted for their Azure Active Directory credentials (or if using white glove, the device will perform TPM attestation) to get an Azure AD token; that token will be used to enroll the device in Intune.  Intune will be notified as part of the enrollment process that it needs to get the device joined to Active Directory.

 

Until the first 3 steps everything is going fine. From Step 4 as it says,  it should get the domain join configuration profile. I do not see this happening even though I have created the Domain Join configuration profile and assigned it to the device group. The devices have been added to the group. 

 

4. Intune will look for a Domain Join device configuration profile assigned to the device (via the groups that device is part of).  Assuming it finds one, it will create a request for the Offline Domain Join connector (officially named the “Intune Connector for Active Directory”). 

 

What can be going wrong here?

 

If it doesn’t find one, steps #5 and #6 will never happen, and the device will time out waiting for an ODJ blob that will never come.

  1. The ODJ connector picks up the ODJ request from the Intune service (it polls Intune looking for requests).  If it finds a request, it will attempt to create an Active Directory object in the specified domain and OU using the naming prefix specified (all from that Domain Join profile).  If that succeeds, it will upload the resulting ODJ blob representing that computer account to the Intune service.
1 Reply
You're posting multiple times about the same thing, you also have this one https://techcommunity.microsoft.com/t5/microsoft-intune/starting-wait-for-odj-blob/m-p/3597753#M1158...