Citrix Workspace fails to install with code 0x80079C42

Copper Contributor

Trying to deploy a new version of Citrix Workspace, and one of my machines fails to install with the above error code (0x80079C42). I can't find anything on Microsoft or by Googling it. Anyone that can shed some light on what this error code is for?

10 Replies

Hi @emb3rz, are you still seeing this error?

The error 0x80079C42 refers to a Win32 app failure.
Is this app published via Intune Line-of-business (LOB), or wrapped and deployed via Intune Win32?

If Win32, we have a couple of troubleshooting docs that may help narrow down what's causing the issue: Troubleshoot Win32 app issues. Additionally, reviewing the DeviceManagement Enterprise Diagnostic Provider logs via: MDM Diagnostic Information log from Windows 10 PCs, may also help determine the cause of why the application is failing to install.

Hope this helps!
Intune Support Team

@emb3rz did you ever figure this out?  i'm having the same issue.  i think the citrix installer sees an existing version and doesn't want to upgrade it.  not 100% sure though.

You could use Supersedence with the newer version and do a uninstall of the previous Win32 app in the process?

@Harm_VeenstraThanks, but if I run the installer manually it can overwrite the existing installation so not sure why I would need to manually uninstall the older version.  Do you know what this error code means?

Not sure, it looks like it tells you that the user cancelled the installation? You do run it as system I think?
Correct I run it as system.
And on a system with the old version installed, when you run the install script of the new version manually as administrator.. It does install/update? No prompts?
Thanks very much! I ran the installer before not using the same script and it worked. But I found other issues with the installer file itself (was same version as one already installed). Started from scratch and now it works. That error code meant it was already installed but I was detecting a new version which is why it was failing. Thanks for responding so quickly!

@BigEHead I _think_ I had the same issue a while ago. It was caused by the .NET framework being 'corrupted'. It worked for all other apps that were on the device but Citrix Workspace somehow didn't want to play nice. 


I resolved that by reinstalling it as documented here.


DISCLAIMER: not sure it's exactly the same code, but hey, it's worh a shot :lol: