Android COPE join doesn´t work

Copper Contributor

Hello everyone, 

I have the problem with a customer that the COPE Join does not work. Any other Android method will work. When you install the apps, you won't see the Intune app listed and probably won't be installed. After installing the app, device enrollment starts through the Intune app and does not open at the customer's site. The other apps will be installed though! The customer is located in Austria and when I test it from Germany with the same user, it works! 

The customer has already tested it in the company network, via mobile communications or even in the home network, always the same behavior. He has also tested several Samsung and Google devices, again with no discernible difference. I've tried it with two devices, it works. I've also had several support tickets with Microsoft on it, with no success so far. Does anyone have an idea. At first glance it looks like a location problem, but that can't be.

Thanks a lot!

6 Replies
Hi,

Can you please explain you registration method. Do you use Knox Mobile Enrollment and/or Zero Touch Enrollment? Or do you use the QR registration method? You use the "Corporate-owned devices with work profile" enrollment profile right?

If it is indeed location based it might be some Location based Conditional Access rule, is that used with this customer?

I am not completely sure what you mean when you say "When you install the apps, you won't see the Intune app listed and probably won't be installed. "

@SebastiaanSmits i´m sorry, for sure! 

We use the QR-Code methode with android 13 and android 14 with Samsung Galaxy and Google Pixel devices as "Corporate-owned devices with work profile" (COPE)

By my customer in austria the intune app is not applicable! 

grandMA_0-1708426297956.png


I don't think it's CA's fault. There is no corresponding rule and I can't find anything in the log. We have now tried it in our tenant, same problem. This means that the cause does not appear to be in the tenant.

You are also deploying the Company Portal app, that's the Microsoft Untern Portal' app right? Can you please look at this: https://learn.microsoft.com/en-us/mem/intune/enrollment/android-corporate-owned-work-profile-enroll#...

"The Microsoft Intune app is automatically installed during enrollment. This app is required for enrollment and can't be uninstalled. If you deploy the Intune Company Portal app to a device and the user attempts to launch the app, they will be redirected to the Microsoft Intune app, and the Company Portal app icon will be hidden."

Just for my complete understanding everything works fine right on the device, everything is deployed and the device is correctly managed, there are only issues with the Intune or Company portal app, the will not launch, is that correct? And when you stated before "The customer is located in Austria and when I test it from Germany with the same user, it works! " that is not the case right it looks like the issue is across the board?

@SebastiaanSmits thank you.

We have the problem that my customer in Austria cannot complete the device registration because the Intune app does not install itself in the deployment process. After the app installation, the next step is the device registration and unfortunately this is only possible if the Intune app has been installed beforehand.

If I test it with the same user from Germany, it works. 

@grandMA 

 

I just tested this in our test tenant. I created a WPCOD (COPE) enrollment profile - first screen tapped 5 times to open QR reader, after some steps the Chrome browser opens to login.microsoftonline.com (depends on IDP ofcourse) - provided accounts, got a screen to install apps, the Intune portal apps is visible there and installs (do you see this screen at all?) And I am able to register the device, it opens the Intune app to do that and after enrollment I have a workin Intune Application (Don't think this has anything to do with it but I am based in the Netherlands)

 

Can you confirm you see the screen in the following screenshot during enrollment (see attached screenshot)

 

My device is a S21 on Android 13 - patch April 2023

Hi @SebastiaanSmits

thanks for your tests. I can confirm that we are able to see this screen, but intune doesn´t install, therefore my customer can´t start the next step to register the device. If i do this with the same user from germany, the intune app installs an everything is fine. My customer from austria try these with the same user an serveral devices, but intune doesn´t install und therefore the next steps can´t start.