Problem with Microsoft Forms

Brass Contributor

Hi there - what is the problem with Microsoft Forms?

all I am getting is:

This site can’t be reached refused to connect.





29 Replies
Same here
Same issue in multiple O365 tenants. No report message about it in Service health Center

@Eileen Kennedy 


Same here.  Not great when we've just put up the link for feedback.




Same here..Please provide us an update....

Back online, it's working now

Many thanks @luis-ribeiro 

Seems like a yearly occurrence from the conversation here - fingers crossed no more than that!

Hearing that this should now be resolved. May need to flush your cache.

Best, Chris
Yes thanks - it is now resolved.

I went to the site and all it does is show the loading animation.

Just tried to access it and all is show is the loading animation.

@Jack Schofield Iii  Same as previously noted: only the loading animation. Have tried clearing cache, etc.  

@Erik_Roll  did you tried to use the browser private mode/private tab?

@luis-ribeiroI did - tried Edge & Chrome, then Edge In Private, then cleared cache/cookies in Edge and tried again.  Based on some of the previous posts that it is 'resolved', I may just give it 15-30 minutes and repeat this cycle... 

I am hearing through social that it has to do with the roll out of Forms Pro but nothing has been confirmed as of yet. It is really difficult with Forms (like Stream) not being in the Service Health dash which is something which needs to happen sooner rather than later.

Best, Chris

Just came into work and started up my computer. Office 365 outlook works fine and so does most of the other survices. @Erik_Roll 

best response confirmed by Eileen Kennedy (Brass Contributor)
All - I have raised a uservoice to have Microsoft Forms added to the Service Health Dashboard you can vote for it here

Same with Stream

Hope that helps. This is absolutely 101 and we should have oversight on the issues.

Best, Chris

@Jack Schofield Iii @Erik_Roll  I am currently experiencing the exact same thing all i get is a loading splash screen. I have also cleared the cache and tried incognito and it is still not working.


@MCTFT  Really wish we could get a answer for this issue.The service statues say everything is up and running.