Error on Azure ATP installation wizard. Check access key.

New Contributor
I am trying to install the Azure ATP agent on of our DC. I have tried multiple times it keeps giving error 'Check access key'

I am sure the access key is correct. I have tried regenerating the access key .. still the same issue.

I tried the silent installation, i get the same error in the logs file 'Incorrect access key'

any thoughts?

6 Replies

@svinchu2619 Make sure you are using the access key with a package downloaded from the exact same workspace you have the access key from, as every workspace gets its own package with its own access key.

If it still goes wrong, I would try from another machine, maybe you have something that is messing with your clipboard? seen such things happen before...

Hello Eli,

Thanks for your prompt response. I just tried on two different machines.

I only have 1 worskspace and I have confirmed that correct package is used.

Not sure what wrong here? can it be backend issue?

I will try typing the key manually and test.


@svinchu2619 Not likely that this is a back end issue,  but if you fail to progress by manual typing, please open  a support case  so we can check specific problems you might have in your workspace.

Hello Eli,

This morning we tried typing the key manually. Did not help, still getting the same error.

We are actually downloading the agent on a machine ane then we copy it to the server. asthe DC does not have internet access.

Will this cause any issues?

Shashank Vinchu.

@svinchu2619 How do you expect the sensor to connect to azure back end?

When you say no internet access, you mean none at all,  or only via a proxy ?

Hello Eli,

It was the proxy.. For the first DC that we configured had traffic bypassed.

We bypased the proxy and tested for the error DC and it worked. However the error was confusing.

Thanks for your help on the matter.

Thanks and regards,
Shashank Vinchu.