unable to delete email in deleted item

Copper Contributor

I try unable to delete the email in deleted item 


It shows this error "Some items cannot be deleted. They were either moved or already deleted or access was denied"


I also try to migrate this mailbox to office365 


It shows this error : Mailbox dumpster size 30 GB (32,213,335,723 bytes) exceeds target quota 30 GB (32,212,254,720 bytes). --> Mailbox dumpster size 30 GB (32,213,335,723 bytes) exceeds


Anyone have solution for this issue?

10 Replies

As the message suggests, you've reached the RecoverableItems subtree quota and need to clean up a bit: https://docs.microsoft.com/bg-bg/exchange/security-and-compliance/recoverable-items-folder/clean-up-...


Alternatively, you can put the mailbox on hold, which will effectively extend the quota to 100GB.

@Vasil Michev 


I had try run clean up but the email still inside the deleted items


Search-Mailbox -Identity "peter" -SearchDumpsterOnly -TargetMailbox "backup" -TargetFolder "Deleted" -DeleteContent


The search has Succeeded.


 Started by: 
 Start Time:23/07/2020 5:25:42 PM
 Size:0 B (0 bytes)
 Operations performed:Messages were copied to the target mailbox and deleted from the source mailbox.
 Search Dumpster:True
 Mailboxes to search:(1) staff\peter

See attachments for additional logging information when full logging is enabled.

Get-MailboxFolderStatistics -Identity "peter" -FolderScope RecoverableItems | Format-Table Name,FolderAndSubfolderSize,ItemsInFolderAndSubfolders -Auto



@Vasil Michev 

If change -SearchDumpsterOnly to -SearchDumpster, will it solve my issue?



The SearchDumpster parameter specifies whether to search the Recoverable Items folder, which is the storage location in which items deleted from the Deleted Items folder or hard-deleted items are stored until they're purged from the mailbox database. By default, the Recoverable Items folder is always searched. To exclude the folder from the search, set the SearchDumpster switch to $false, for example,-SearchDumpster:$false

You have to disable Single Item recovery first and remove any holds placed on the mailbox. It's all detailed in the article above.

@Vasil Michev 


I had disable Single Item recovery and try empty the deleted items. it still has the same error and not allow to delete it. 


I try to go into light version of OWA. It allow to delete it as a subfolder under manage folders



Deleted is 138 bytes and Recoverable items is all  0 bytes









I still cannot migrate this mailbox to office365. it still shows the same error. 


Error: MigrationPermanentException: Mailbox dumpster size 30 GB ‎(32,213,335,723 bytes)‎ exceeds target quota 30 GB ‎(32,212,254,720 bytes)‎. Mailbox dumpster size 30 GB ‎(32,213,335,723 bytes)‎ exceeds target quota 30 GB ‎(32,212,254,720 bytes)‎.

Does the mailbox have an archive enabled and did you check the RecoverableItems subtree in the archive?

@Vasil Michev 


The Mailbox Archive is enabled. Deleted items and Recoverable items are empty. 





Interesting, so it seems the issue is with the quota, not the actual used size. I suppose you can try setting the quota to a lower value, preferably on the database level so that other mailboxes don't run into the same issue.

@Vasil Michev 

I had set the RecoverableItemQuota to 30GB and RecoverableWarningQuota to 20GB



Office365 Migration still have the same error on 





When i check mailbox statistics by database , it show 26553mb in deleted item.


So i try to move that mailbox to into another database ( another exchange Server), it show 0mb in deleted item.


now i will try to move it to office365. Hope it will work.