Free Busy - From Cloud to on-premise not working

%3CLINGO-SUB%20id%3D%22lingo-sub-353200%22%20slang%3D%22en-US%22%3EFree%20Busy%20-%20From%20Cloud%20to%20on-premise%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-353200%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20everyone%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ewe%20have%20set%20up%20an%20Exchange%20hybrid%20configuration.%3C%2FP%3E%3CP%3EEverything%20works%20fine.%20Except%20the%20Free%2FBusy%20from%20Cloud%20to%20on-premise.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20read%20some%20(also%20opposite)%20blog%20posts%20and%20decided%20to%20follow%20this%20one%3A%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fblogs.technet.microsoft.com%2Fexchange%2F2018%2F02%2F06%2Fdemystifying-hybrid-freebusy-what-are-the-moving-parts%2F%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fblogs.technet.microsoft.com%2Fexchange%2F2018%2F02%2F06%2Fdemystifying-hybrid-freebusy-what-are-the-moving-parts%2F%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe%20have%20executed%20the%20HCW%20therefore%20ended%20up%20with%26nbsp%3B%3C%2FP%3E%3CP%3EIntraOrganizationConnector%3C%2FP%3E%3CP%3EOrganizationRelationship%3C%2FP%3E%3CP%3Eand%20the%20Other%20one%20%3B)%3C%2Fimg%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20checked%20the%20availbility%20of%20the%20autodisover%20from%20external%20with%20the%20MS%20connectivity%20test.%3C%2FP%3E%3CP%3EI%20tested%20the%20Oauth%20from%20Exchange%20online%20(Test-OAuthConnectivity%20-Service%20EWS%20-TargetUri%20etc)%3C%2FP%3E%3CP%3EI%20checked%20all%20URLs%20in%20the%20connectors%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhat%20else%20can%20i%20do%20or%20check%3F%20The%26nbsp%3BTargetSharingEpr%20is%20empty.%20But%20according%20to%20the%20blog%20this%20is%20%22normal%22.%20Other%20MS%20sites%20states%20this%20must%20be%20filled%20(for%20OrganizationRelationship).%20Other%20blogs%20set%20the%26nbsp%3BIntraOrganizationConnector%20to%20%22Enabled%3Afalse%22%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECan%20someone%20advise%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20Stephan%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-353200%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3E2016%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EExchange%20Server%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EHybrid%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-353224%22%20slang%3D%22en-US%22%3ERe%3A%20Free%20Busy%20-%20From%20Cloud%20to%20on-premise%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-353224%22%20slang%3D%22en-US%22%3E%3CP%3EOk.%20The%20TargetSharingEpr%20was%20the%20one%20that%20was%20missing.%20%3B)%3C%2Fimg%3E%3C%2FP%3E%3CP%3ENow%20the%20cloud%20user%20gets%20a%20%22Security%20Popup%22%20after%20trying%20to%20open%20an%20onprem%20calender.%20We%20are%20using%20Office%20365%20ProPlus.%3C%2FP%3E%3CP%3EMaybe%20an%20issue%20with%20modern%20auth%3F%20Is%20there%20a%20way%20to%20solve%20this%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EBest%20regards%3C%2FP%3E%3CP%3EStephan%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Contributor

Hi everyone,

 

we have set up an Exchange hybrid configuration.

Everything works fine. Except the Free/Busy from Cloud to on-premise.

 

I read some (also opposite) blog posts and decided to follow this one:

https://blogs.technet.microsoft.com/exchange/2018/02/06/demystifying-hybrid-freebusy-what-are-the-mo...

 

We have executed the HCW therefore ended up with 

IntraOrganizationConnector

OrganizationRelationship

and the Other one ;)

 

I have checked the availbility of the autodisover from external with the MS connectivity test.

I tested the Oauth from Exchange online (Test-OAuthConnectivity -Service EWS -TargetUri etc)

I checked all URLs in the connectors

 

What else can i do or check? The TargetSharingEpr is empty. But according to the blog this is "normal". Other MS sites states this must be filled (for OrganizationRelationship). Other blogs set the IntraOrganizationConnector to "Enabled:false"

 

Can someone advise?

 

Thanks Stephan

 

1 Reply

Ok. The TargetSharingEpr was the one that was missing. ;)

Now the cloud user gets a "Security Popup" after trying to open an onprem calender. We are using Office 365 ProPlus.

Maybe an issue with modern auth? Is there a way to solve this?

 

Best regards

Stephan