Exchange 2016 Public Folder Migration (from 2010) error

Occasional Contributor

I started a public folder migration from our Ex2010 environment and ran into an error with a particular public folder. When I queried the people that owned that public folder they indicated that those folders could be deleted and not migrated. I'd already followed the instructions here:  https://www.petenetlive.com/KB/Article/0000789 

 

I'd gotten as far as the point where public folder mailboxes had been created and I was importing the data after the mailboxes were populated.

 

When I originally tried to import the data I got errors that there was a problem trying to populate the mailboxes. After I discovered the offending data and deleting those public folders I deleted the public folder mailboxes on the 2016 server, re-ran the scripts on the 2010 server, copied the scripts to the 2016 server but now I get an error that there is an existing migration taking place so it can't re-run the scripts.

I got into the 2010 public folders with an account still on the 2010 servers and realized I can just manually copy the data (there's not a lot). However when I tried to manually create public folders and their mailboxes via the EMC I get the following error:

"An existing Public Folder deployment has been detected. To migrate existing Public Folder data, create new Public Folder mailbox using -HoldForMigration switch."

 

I can't find a way to get rid of this 'deployment' so that I can proceed with this migration. How do I show this deployment and either get rid of it or make changes to it? EMC doesn't show anything in the way of public folders.

0 Replies