Dynamics 365 connection to exchange fails. Unable to send emails from Dynamics 365

%3CLINGO-SUB%20id%3D%22lingo-sub-1358969%22%20slang%3D%22en-US%22%3EDynamics%20365%20connection%20to%20exchange%20fails.%20Unable%20to%20send%20emails%20from%20Dynamics%20365%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1358969%22%20slang%3D%22en-US%22%3E%3CP%3EHello%20people%2C%3C%2FP%3E%3CP%3EI%20have%20integrated%20the%20Dynamics%20365%20with%20exchange%20on%20premises%202013%20and%20after%20entering%20the%20correct%20setting%20I%20was%20able%20to%20test%20the%20connectivity%20which%20passes.%20But%20when%20any%20users%20try%20to%20send%20emails%20via%20dynamics%20365%20they%20are%20getting%20the%20error%20below%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CEM%3E%3CSTRONG%3EError%20%3A%20Microsoft.Exchange.WebServices.Data.ServiceRequestException%3A%20The%20request%20failed.%20The%20underlying%20connection%20was%20closed%3A%20An%20unexpected%20error%20occurred%20on%20a%20receive.%20---%26gt%3B%20System.Net.WebException%3A%20The%20underlying%20connection%20was%20closed%3A%20An%20unexpected%20error%20occurred%20on%20a%20receive.%20---%26gt%3B%20System.IO.IOException%3A%20Unable%20to%20read%20data%20from%20the%20transport%20connection%3A%20An%20existing%20connection%20was%20forcibly%20closed%20by%20the%20remote%20host.%20---%26gt%3B%20System.Net.Sockets.SocketException%3A%20An%20existing%20connection%20was%20forcibly%20closed%20by%20the%20remote%20host%3C%2FSTRONG%3E%3C%2FEM%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3COL%3E%3CLI%3EI%20checked%20the%20TLS%201.0%2C%201.1%20and%201.2%20is%20enabled%20in%20all%20the%20exchange%20servers.%3C%2FLI%3E%3CLI%3E%3CSPAN%3EChecked%20the%20EWS%20authentication%20and%20SSL%20for%20all%20the%20servers%20and%20it%20looked%20fine.%3C%2FSPAN%3E%3C%2FLI%3E%3CLI%3E%3CSPAN%3EBrowsed%20the%20EWS%20URL%20and%20able%20to%20browse%3C%2FSPAN%3E%3C%2FLI%3E%3CLI%3EDynamics%20365%20IP's%20are%20also%20added%20in%20firewall%20allowed%20list%26nbsp%3B%3C%2FLI%3E%3C%2FOL%3E%3CDIV%3EFound%20the%20article%20below%20and%20followed%20the%20same%20which%20also%20did%20not%20help%26nbsp%3B%3C%2FDIV%3E%3CDIV%3E%3CSPAN%3E%3CA%20href%3D%22https%3A%2F%2Fsupport.microsoft.com%2Fen-in%2Fhelp%2F4533252%2Fweb-server-returned-securechannelfailure-exception-error-appears-in-dy%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fsupport.microsoft.com%2Fen-in%2Fhelp%2F4533252%2Fweb-server-returned-securechannelfailure-exception-error-appears-in-dy%3C%2FA%3E%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%3E%3CSPAN%3EAny%20assistance%26nbsp%3Bwill%20be%20appreciated%26nbsp%3B%3C%2FSPAN%3E%3C%2FDIV%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1358969%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3E2013%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3E2016%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EExchange%20Server%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOffice%20365%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Highlighted
Occasional Contributor

Hello people,

I have integrated the Dynamics 365 with exchange on premises 2013 and after entering the correct setting I was able to test the connectivity which passes. But when any users try to send emails via dynamics 365 they are getting the error below:

 

Error : Microsoft.Exchange.WebServices.Data.ServiceRequestException: The request failed. The underlying connection was closed: An unexpected error occurred on a receive. ---> System.Net.WebException: The underlying connection was closed: An unexpected error occurred on a receive. ---> System.IO.IOException: Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host. ---> System.Net.Sockets.SocketException: An existing connection was forcibly closed by the remote host

 

  1. I checked the TLS 1.0, 1.1 and 1.2 is enabled in all the exchange servers.
  2. Checked the EWS authentication and SSL for all the servers and it looked fine.
  3. Browsed the EWS URL and able to browse
  4. Dynamics 365 IP's are also added in firewall allowed list 
Found the article below and followed the same which also did not help 
Any assistance will be appreciated 
0 Replies