SOLVED

Power Pivot add-in lost - Office365 ProPlus

Occasional Contributor

Hi,

 

Yesterday I had some issues with the Power Pivot add-in - it wouldn't load the data model after connecting to external data sources through the query editor, which were loaded to the data model (connection only).

After searching solutions, I went to the registry and deleted two keys related to the addin. 

 

After it didn't work, I tried repairing the office installation (both simple and online) - still no workable solution.

After restart of the machine, I still don't have the add-in to enable in Excel.

 

I have office 365 Pro Plus, thus the add-in should be available.

 

I have the add-in folder (C:\Program Files\Microsoft Office\root\Office16\ADDINS\PowerPivot Excel Add-in) - bot how do I install it?

 

Office_Add-ins.jpgOffice_account.jpg

 

 

Please help :)

//Christoffer

7 Replies

Hi Christoffer,

 

Office 365 itself is not enough to have Power Pivot, it's available mainly for enterprise subscriptions. You may check is it available for your one or not here https://support.office.com/en-us/article/Where-is-Power-Pivot-aa64e217-4b6e-410b-8337-20b87e1c2a4b.

 

As for loading to data model you most probably use Power Query (aka Get&Transform), these are different tools. It loads data to data model which is available for any version (any recent) of Excel, you only don't have Power Pivot to work with data model directly.

 

Hi Sergei

 

Thanks - But I feel you haven't taken the time to read my post entirely :)

 

I have Office 365 Pro Plus - which is the first plan listed in your link.

 

I had Power Pivot yesterday, faced some issues, and removed it through the registry - After trying to fix the office installation, I can not get the power pivot back.

 

After loading data to the data model through the query editor, I can not get into the data model and add columns, make lookups, do calculations etc... 

I see, sorry,

 

And if you go to list of COM add-ins from the options do you see Power Pivot here?

AddIns.JPG

 

Hi again,

 

No;

Office_Add-ins_2.jpg

 

 

best response confirmed by Christoffer Risberg Müller (Occasional Contributor)
Solution

When strange if full repair didn't help. Latest option i know is full uninstallation of the Office by this fix https://support.office.com/en-us/article/Uninstall-Office-from-a-PC-9dd49b83-264a-477a-8fcc-2fdf5dbf... and install it again from scratch.

 

However, with that you will loss all your Office settings.

Used the easy fix program to uninstall office completely, and re-installed.

 

I now have the add-in, and can access the data model.

 

Thanks!

Okay, so far so good