Excel crashes on attempting to open VBA editor

New Contributor

Hey guys,

one of my workbooks crashes when I try to open VBA editor. Do  you know how to fix the problem or extract the macros from such workbook?

Thanks a lot

15 Replies



Bad macros may have caused this!

You have to numb these macros to be able to open the VBA editor.


Try this:

Go to Developer Tab >> Macro Security >> Macro Settings

And make sure that the macro setting is (Disable all macros with notification).

Then go to Trusted Documents and press Clear button.


After that, save and close the workbook, then open it again.

Try to open the VBA editor, and look what the problem is.


Hi thank you for reply! I think it must be something with macros but I have tried to disable macros and clear trusted documents but my spreadsheet crashes or freezes on saving.

Another try

  • Open a blank workbook
  • Press Shift+F12
  • Find that workbook
  • Click it one click
  • Click the down arrow next to Open button
  • Try each one of these options: Open and Repair, Open in Protected View, and Open Read-Only


Open and repair command



Useful Link:

Repair a corrupted workbook

After trying everything I have killed outlook.exe process and it suddenly worked LOL :D

many users repair, uninstall, reinstall office and some users even reinstall windows and the solution is quite simple right in front of your nose. all these problems happened due to the new Beta feature for Region setting using unicode UTF-8 for worldwide. correction of this stupid error which cost me a lot of time and effort is very simple.

control panel >> Region >> Administrative tab >> change system locale >> untick the box " Beta: Use Unicode UTF-8 for world wide language support" . that's it problem solved .





The solution said works.

Thanks for the solution

Amazing...It works, thanks a lot.
Thanks for the solution.


I still get the above described error, but my Region Settings does not have the offending Beta box.



@DATA00 Excellent answer! It worked, thanks! 

It did solved the problem for me, thanks
Thanks, it works.

hallelujah, you saved my day@DATA00 

@DATA00, on the surface this sounds like a great solution. Problem is — it's not a solution, it's a workaround. I thank you for the reply (it has obviously been helpful to many), but I would love some help getting deeper into the issue (which I too, am experiencing).


See, I reside in a country that utilized RTL text and so many of my macros only work to begin with thanks to said beta feature. That's how I got to turning it on to begin with

There must be another way around this. Any ideas where to begin?

The solution worked, thanks a lot.