OOS unable to load files on OWA or S4B

New Contributor



I am reverting here as we are still having this issue after spending several days trying to fix this.

When trying to open an Office file on OWA it is not possible to load it and an error is returned.

Note: SharePoint works flawlessly with these same OOS servers.

For instance, trying to open a PowerPoint:

"Sorry we couldn't open this presentation because we run into a problem. Please try again. Session ID: ***"


The error in the ULS logs it mentions a problem deserializing the metadata file:

"There was an error deserializing the object of type Microsoft.Office.OpenWebApplication.WopiCheckFileResponse. Encountered unexpected character '<'.]" 


We definitely do not have any such symbol in any of the file names or paths. We also checked that there is no escaping character - we thought it may somehow escapes the XML tag hence it finds "<" at the wrong place.


Poking through the browser's network trace we managed to find the URL OWA is asking to access and tried to open it on the OOS server: loading works here (but not on the PC where OWA is used).


Checking OOS Event logs we also found a mention about protocol binding issue. Something like ->

"There is no protocol handler for http. Available bindings: []"

We checked IIS binding configuration on the OOS and:

1. We definitely do not use http but https

2. https binding is properly configured


We have also tried updating the OOS servers (we found some error logs related to an installed package).

Reconfiguring OWA for each Exchange server and also global config to remove OOS, restart service, and add again OOS.

As the issue happened not long after renewing certificates, we also reviewed the certificates on each of the OOS and Exchange servers to make sure we have the newest certificate on each server and that the configuration matches this one -> everything is fine. 


Sidenote: SharePoint and OOS work S2S, so whatever issue is affecting OWA/S4B I believe it is something related to the access from an external service.


What else could we review/check/investigate to find some more hints or possibly a solution?


Thank in advance.


5 Replies
best response confirmed by Drakeii (New Contributor)

@Drakeii Hello!  I'm not sure you've posted in the correct area.  This is for Microsoft Edge Enterprise questions. 


Maybe these other Hubs might be able to help.  



@Kelly_Y Hi

Thank you for the answer. I will move this question to the correct area. 


I've lately noticed this statement a couple of times lately "This is for Microsoft Edge Enterprise questions."

Is this forum only for Enterprise Edge? I thought it was also the channel if Edge is being used for personal browsing.

@ms4132 Hi!  Microsoft Edge Insider - Microsoft Community Hub is the larger MS Edge Insider community.  This Enterprise - Microsoft Community Hub is the Enterprise Discussion Space.  



Thank you for clarifying. My default view shows all the Discussion spaces in the Microsoft Edge Insider - Microsoft Community Hub and I neglected to consider the separate of the Discussion Spaces.