Copper Contributor

Hi Everyone,

Yesterday (20/09/2023) edge started to frequently crash with a STATUS_ACCESS_VIOLATION error. Only when using Microsoft Dynamics 365 Business Central (other web apps work fine). Any help for fixing this is appreciated!


Edge Version: 117.0.2045.36 (Official build) (64-bit)

OS: Windows 10 Pro

Version: 22H2

OS Build: 19045.3448

Experience: Windows Feature Experience Pack 1000.19044.1000.0


Microsoft Dynamics 365

Cloud version

Application Version: 22.4.59114.59220

Platform Version: 22.0

36 Replies

@ianknight2023 we're having exact same issues (for 1 user currently). Latest version of Edge, and W22H2

best response confirmed by ianknight2023 (Copper Contributor)
The issue is already being worked on. I have gathered everything here:


Thanks for the update. I did spot this before I started this discussion. The fix mentioned did not work me.

Even not the updated browser shortcut? People reported that (only) this worked for them.
In my Business Central Admin Center this morning there was a message about this issue. It restated the fixes you mentioned and also had instructions to turn off the windows accessibility feature "Text cursor indicator" which I had on. With that off Edge now works fine for me.
Thank you for your assistance.

Here is the full message
Message Summary
Following a recent update of Chromium based web browsers (Such as Edge and Chrome) to Chromium v117+ that took place in September 2023, some users may see error pages displaying Error Code: STATUS_ACCESS_VIOLATION when using the Business Central web client, regardless of Business Central version.

What action do I need to take?
If you encounter this issue, there are two potential workaround options to resolve the problem:
Disable the Accessibility feature:
If you are working in Windows, verify that the "Text cursor indicator" setting is turned off.
In Edge, open edge://accessibility in a new tab.
In Chrome, open chrome://accessibility in a new tab.
Disable Text metrics, Screen reader support, and HTML. Or try to disable Web accessibility instead, which might turn off the other options. (Note that your company admin settings might prevent changing these settings or cause the old setting to be restored shortly thereafter.)
Alternatively, add --disable-renderer-accessibility to your browser shortcut and restart the browser.
Why is this action needed?
We have identified that the update to Chromium v117+ introduced an accessibility feature which interferes with Business Central web client functionality. We have confirmed the issue with both the Edge and Chrome teams who are actively working on fixes for their browsers.

Thanks for letting me know! :beaming_face_with_smiling_eyes:
Seems like Microsoft just copied my blog content into the BC Admin Center with very little changes.

My blog post also mentioned turning off the windows feature, so probably you've read my post at a very early stage?
Anyway, I'm glad that it works!

who even uses edge :skull:

@NatalieKarolak Hi there - any new updates on this? I see the last one was in Sep. I've tried all of the commonly reported solutions (rename executable, extensions, disable code integrity, etc.) to no avail. I still regularly get the error on Edge and I'm going to need to go to (shudder) Firefox soon.


Incredibly frustrating, considering how commonly this seems to be happening, based upon the reports across Reddit, here, etc.


Asus Z790 Maximus Hero

Windows 11

Intel i9-14900k




Thank you!

My blog posts really reflects the very last information that I have collected: There has never been any official announcement again, or I was unable to find it.
However, I neither know about any other user who is still unhappy after a browser update.
Are you really using the latest Edge version 120.0.2210.121?


I'm on Version 120.0.2210.121 (Official build) (64-bit)

And if you search on reddit, you'll see quite a bit of evidence that it's still an issue, even on current version. It's clearly not been fixed.

@Rumtintin24 I have almost the same setup as you (except the CPU):
ASUS ROG Maximus Z790 Hero
64 GB DDR-6400 (G.Skill with XMP II Profile)

The problems started after the 23H2 update.  I thought I had a hardware issue because there were other things failing as well.  I replaced the motherboard AND the GPU (was using an RTX-3090 previously) because I couldn't install Video Card drivers.  Everything else is running relatively smoothly (and was perfect prior to the update), but now I get browser tab crashes with STATUS_ACCESS_VIOLATION in both Edge and Chrome.  Interestingly, tabs crash in Firefox while watching video as well.  I've tested with my 4090, 3090, and a 2080 Ti I had lying around with no difference.  CPU, RAM, and storage drives all test good with no errors.  I'm baffled.

Thank you for that, it's incredibly frustrating. I did a full reset on Edge today - no luck. I have changed the executable name, I've disabled code integrity, CPU affinity, I've done the accessibility thing, none of it has worked. It happens with zero extensions enabled, also.

@Rumtintin24   Same here.  I've disabled everything, and I've reinstalled Windows (23H2 build straight from MSDN) now 8 times while troubleshooting.  I've tried ditching the XMP profile as well and made sure no overclocking was enabled and nada.  Edge, Chrome, and Firefox all fail.  I've also noticed Call of Duty failing with a "Direct X" error occasionally, but that's completely normal for CoD.  However, it could point to potentially being an NVidia driver or DirectX issue.

There's a possibility it could be CPU or thread related. I saw a couple posts of people saying they fixed it by replacing their CPU. I have a hard time believing the CPU I just installed a couple months ago is the issue, but I have been running a test. I just stream a tik tok live in a tab and wait for it to crash and it reliably does so (in chrome, firefox, and edge). So, I started it again, located the process for the tab, and set the affinity to only use CPU 0.... it's been running awhile now and no crash.
Interesting - in the past, when certain sites like Reddit had the issue a lot, I'd set affinity for that tab's process to like CPU0-4, then 5-10 if the issue occurred, and so on, but was never able to find the right choice.

Please let me know how that goes!
Definitely seems to be the issue. I located the browser tab in task manager and set affinity to only use CPU 0 and 1 and it worked fine. Worked my way through blocks of CPUs and narrowed it down to one... CPU 6. If CPU 6 is enabled, either by itself or with others, the access violation occurs. If I disable CPU 6 and enable one or all other cores, everything still works just fine.
That's great research! Now the question is - are you able to make that 'sticky?' Like - so that you don't have to turn off CPU 6 every time?
Yes* Problem is that Windows lists the CPUs under affinity configuration 0 through 29. By my bios lists performance cores 0 through 7 and E Cores 0 through 22 or whatever. I can turn off cores individually, but evidently P-Core 6 does not equate to CPU 6 in Windows so it's trial and error to figure out which one I'd have to disable.
1 best response

Accepted Solutions
best response confirmed by ianknight2023 (Copper Contributor)