[Search Engines] Favicons do not appear next to the built-in providers by-default

%3CLINGO-SUB%20id%3D%22lingo-sub-2364138%22%20slang%3D%22en-US%22%3E%5BSearch%20Engines%5D%20Favicons%20do%20not%20appear%20next%20to%20the%20built-in%20providers%20by-default%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2364138%22%20slang%3D%22en-US%22%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSTRONG%3EDescribe%20the%20problem%3A%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CEM%3EEdge%26nbsp%3B%3C%2FEM%3Eships%20with%20some%20built-in%20search-engines.%26nbsp%3B%20These%20vary%20by-country%2C%20but%20for%20UK%20users%20they%20are%20%22Bing%22%2C%20%22Yahoo!%22%2C%20%22Google%20US%22%20and%20%22DuckDuckGo%22.%26nbsp%3B%20None%20of%20the%20built-in%20engines%20will%20initially%20show%20any%20icons%20next%20to%20them%20--%20all%20just%20show%20a%20blank-page%20icon%2C%20making%20the%20feature%20look%20broken.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSTRONG%3ESuggest%20a%20solution%3A%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EEither%20one%20of%20the%20following%3A%3C%2FP%3E%3CUL%3E%3CLI%3E%3CEM%3EEdge%26nbsp%3B%3C%2FEM%3E%3CSPAN%3Eshould%20ship%20with%20the%20favicons%20for%20each%20built-in%20search-engine%20already%20cached%3C%2FSPAN%3E%3C%2FLI%3E%3CLI%3E%3CSPAN%3EOr%20the%20first%20time%20%3CEM%3EEdge%20%3C%2FEM%3Eis%20ran%2C%20where%20a%20valid%20Internet-connection%20is%20present%2C%20it%26nbsp%3Bshould%20immediately%20retrieve%20the%20favicon%20for%20each%20one%20silently%2C%20in%20the%20background%3C%2FSPAN%3E%3C%2FLI%3E%3C%2FUL%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSTRONG%3EAny%20workarounds%3F%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAfter%20the%20user%20has%20visited%20the%20website%20of%20one%20of%20the%20search-engines%20that%20comes%20built-in%2C%20the%20favicon%20will%20get%20cached.%26nbsp%3B%20If%20the%20user%20were%20to%20return%20to%20the%20%22Manage%20search%20engines%22%20screen%2C%20you%20will%20then%20see%20the%20icon%20next%20to%20each%20one%20you%20have%20visited.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHowever%2C%20given%20many%20users%20are%20unlikely%20to%20have%20visited%20all%20of%20the%20sites%26nbsp%3B%3CEM%3Ebefore%26nbsp%3B%3C%2FEM%3Ethey%20first%20access%20the%20%22Manage%20search%20engines%22%20screen%2C%20the%20result%20will%20be%20blank-page%20icons%20for%20most%2C%20if%20not%20all%2C%20of%20them.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSTRONG%3EBefore%20posting%20on%20this%20site%2C%20have%20you%20suggested%20this%20previously%20using%20the%20%22Send%20Feedback%22%20feature%20built-into%20Edge%3F%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%2C%20yes.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSTRONG%3EBrowser%20and%20OS%20versions%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EEdge%20Stable%20v90.0.818.62%20(Official%20build)%20(64-bit)%3C%2FP%3E%3CP%3EWindows%2010%20Home%20(64-bit)%20Version%2020H2%20(Build%2019042.985%3B%20May%202021)%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSTRONG%3EScreenshot%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSTRONG%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22MicrosoftEdge_DefaultSearchProvidersNoFavicons.png%22%20style%3D%22width%3A%20912px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F281486i0F81A1F17CEAAE2D%2Fimage-size%2Flarge%3Fv%3Dv2%26amp%3Bpx%3D999%22%20role%3D%22button%22%20title%3D%22MicrosoftEdge_DefaultSearchProvidersNoFavicons.png%22%20alt%3D%22MicrosoftEdge_DefaultSearchProvidersNoFavicons.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FSTRONG%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2364138%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3Eengine%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3Efavicon%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EIcon%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3Eprovider%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESearch%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2364150%22%20slang%3D%22en-US%22%3ERe%3A%20%5BSearch%20Engines%5D%20Favicons%20do%20not%20appear%20next%20to%20the%20built-in%20providers%20by-default%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2364150%22%20slang%3D%22en-US%22%3E(Also%2C%20as%20a%20minor%20addendum%3A%20it's%20odd%20how%20in%20the%20UK%2C%20Edge%20ships%20with%20the%20regionalised%20%22Yahoo!%20UK%20%26amp%3B%20Ireland%22%20provider...%20but%20for%20Google%2C%20instead%20defaults%20to%20the%20US%20site%20URL%2C%20not%20the%20UK%20one.%20Surely%20for%20UK%20users%2C%20Google%20UK%20should%20be%20the%20default%3F)%3C%2FLINGO-BODY%3E
Frequent Contributor

 

Describe the problem:

 

Edge ships with some built-in search-engines.  These vary by-country, but for UK users they are "Bing", "Yahoo!", "Google US" and "DuckDuckGo".  None of the built-in engines will initially show any icons next to them -- all just show a blank-page icon, making the feature look broken.

 

Suggest a solution:

 

Either one of the following:

  • Edge should ship with the favicons for each built-in search-engine already cached
  • Or the first time Edge is ran, where a valid Internet-connection is present, it should immediately retrieve the favicon for each one silently, in the background

 

Any workarounds?

 

After the user has visited the website of one of the search-engines that comes built-in, the favicon will get cached.  If the user were to return to the "Manage search engines" screen, you will then see the icon next to each one you have visited.

 

However, given many users are unlikely to have visited all of the sites before they first access the "Manage search engines" screen, the result will be blank-page icons for most, if not all, of them.

 

Before posting on this site, have you suggested this previously using the "Send Feedback" feature built-into Edge?

 

I have, yes.

 

Browser and OS versions

 

Edge Stable v90.0.818.62 (Official build) (64-bit)

Windows 10 Home (64-bit) Version 20H2 (Build 19042.985; May 2021)

 

Screenshot

 

MicrosoftEdge_DefaultSearchProvidersNoFavicons.png

1 Reply
(Also, as a minor addendum: it's odd how in the UK, Edge ships with the regionalised "Yahoo! UK & Ireland" provider... but for Google, instead defaults to the US site URL, not the UK one. Surely for UK users, Google UK should be the default?)