SOLVED

On version 20H2, the File Explorer on the taskbar often shows an active window with an Edge tab

%3CLINGO-SUB%20id%3D%22lingo-sub-1590769%22%20slang%3D%22en-US%22%3EOn%20version%2020H2%2C%20the%20File%20Explorer%20on%20the%20taskbar%20often%20shows%20an%20active%20window%20with%20an%20Edge%20tab%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1590769%22%20slang%3D%22en-US%22%3E%3CP%3EOn%20the%20Windows%20beta%20channel%20(version%2020H2%2C%20build%2019402.450)%2C%20the%20File%20Explorer%20on%20the%20taskbar%20often%20shows%20an%20active%20window%20with%20an%20Edge%20tab.%20Clicking%20the%20explorer%20icon%20or%20the%20thumbnail%20that%20shows%20the%20Edge%20tab%20switches%20to%20that%20tab%20in%20Edge.%20Closing%20the%20tab%20makes%20the%20thumbnail%20disappear%20from%20the%20File%20Explorer%20icon%20and%20replaces%20it%20with%20another%20Edge%20tab.%20This%20can%20be%20repeated%20until%20all%20tabs%20have%20been%20closed%2C%20but%20at%20some%20point%20later%20this%20behavior%20will%20start%20again.%20This%20is%20surely%20related%20to%20the%20new%20feature%20where%20Alt%20%2B%20Tab%20works%20for%20Edge%20tabs%2C%20but%20I%20have%20that%20disabled%20and%20it's%20a%20bug%20in%20any%20case.%20Switching%20desktops%20seems%20to%20trigger%20this%20behavior%20very%20often%2C%20though%20not%20always.%20I'm%20running%20Edge%20Beta%2085.0.564.30.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22adrianghc_0-1597513828875.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F212614iEAE7E4238993A20D%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20title%3D%22adrianghc_0-1597513828875.png%22%20alt%3D%22adrianghc_0-1597513828875.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22adrianghc_1-1597513834536.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F212615i578AA2DDFB043FBF%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20title%3D%22adrianghc_1-1597513834536.png%22%20alt%3D%22adrianghc_1-1597513834536.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22adrianghc_2-1597513836939.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F212616iE181BD6978AD037D%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20title%3D%22adrianghc_2-1597513836939.png%22%20alt%3D%22adrianghc_2-1597513836939.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1804376%22%20slang%3D%22en-US%22%3ERe%3A%20On%20version%2020H2%2C%20the%20File%20Explorer%20on%20the%20taskbar%20often%20shows%20an%20active%20window%20with%20an%20Edge%20tab%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1804376%22%20slang%3D%22en-US%22%3EIt%20seems%20to%20be%20fixed%20since%20build%2020231%3A%20%3CA%20href%3D%22https%3A%2F%2Fblogs.windows.com%2Fwindows-insider%2F2020%2F10%2F07%2Fannouncing-windows-10-insider-preview-build-20231%2F%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fblogs.windows.com%2Fwindows-insider%2F2020%2F10%2F07%2Fannouncing-windows-10-insider-preview-build-20231%2F%3C%2FA%3E%3CBR%20%2F%3E%3CBR%20%2F%3EHopefully%20it%20will%20soon%20make%20its%20way%20to%2020H2%20as%20well.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1828020%22%20slang%3D%22fr-FR%22%3ERe%3A%20On%20version%208%3A2%20p.m.%2C%20the%20File%20Explorer%20on%20the%20taskbar%20often%20shows%20an%20active%20window%20with%20an%20Edge%20tab%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1828020%22%20slang%3D%22fr-FR%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F418331%22%20target%3D%22_blank%22%3E%40adrianghc%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHello%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20a%20similar%20problem.%3C%2FP%3E%3CP%3E%3CBR%20%2F%3ENo%20I%20have%20exactly%20the%20same%20problem%20and%20I'm%20using%20Edge%20Chromium%2C%20virtual%20desktops%20and%20I'm%20in%2020H2%20(19042.572).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-right%22%20image-alt%3D%22Q1prllF%22%20style%3D%22width%3A%20776px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F229841i7F07A4AE0C312B93%2Fimage-size%2Flarge%3Fv%3Dv2%26amp%3Bpx%3D999%22%20role%3D%22button%22%20title%3D%22Q1prllF%22%20alt%3D%22Q1prllF%22%20%2F%3E%3C%2FSPAN%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-right%22%20image-alt%3D%22ScM1QvG%22%20style%3D%22width%3A%20644px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F229842iEBDD681AB3299ABC%2Fimage-size%2Flarge%3Fv%3Dv2%26amp%3Bpx%3D999%22%20role%3D%22button%22%20title%3D%22ScM1QvG%22%20alt%3D%22ScM1QvG%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1804353%22%20slang%3D%22en-US%22%3ERe%3A%20On%20version%2020H2%2C%20the%20File%20Explorer%20on%20the%20taskbar%20often%20shows%20an%20active%20window%20with%20an%20Edge%20tab%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1804353%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F418331%22%20target%3D%22_blank%22%3E%40adrianghc%3C%2FA%3E%26nbsp%3BI%20had%20the%20same%20issue%20on%20a%20preview%20build%20of%20Windows%20and%20became%20so%20frustrated%20with%20it%20and%20the%20fact%20that%20Microsoft%20was%20completely%20ignoring%20my%20reports%20of%20this%20problem%20that%20I%20reinstalled%20Windows%20and%20made%20sure%20I%20didn't%20use%20an%20Insider%20build%20for%20Windows%20OR%20a%20beta%20build%20of%20Edge.%20Things%20were%20great%2C%20until%20the%20October%20update%20yesterday.%20Now%20the%20problem%20has%20returned%2C%20with%20no%20acknowledgement%20of%20the%20problem%20or%20effort%20to%20fix.%20I've%20even%20tried%20turning%20off%20the%20Alt-Tab%20Edge%20feature%2C%20but%20the%20problem%20persists.%20The%20only%20solution%20I've%20found%20is%20to%20get%20rid%20of%20Edge%20and%20use%20a%20different%20browser.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Frequent Contributor

On the Windows beta channel (version 20H2, build 19402.450), the File Explorer on the taskbar often shows an active window with an Edge tab. Clicking the explorer icon or the thumbnail that shows the Edge tab switches to that tab in Edge. Closing the tab makes the thumbnail disappear from the File Explorer icon and replaces it with another Edge tab. This can be repeated until all tabs have been closed, but at some point later this behavior will start again. This is surely related to the new feature where Alt + Tab works for Edge tabs, but I have that disabled and it's a bug in any case. Switching desktops seems to trigger this behavior very often, though not always. I'm running Edge Beta 85.0.564.30.

 

adrianghc_0-1597513828875.png

adrianghc_1-1597513834536.png

adrianghc_2-1597513836939.png

 

50 Replies

@adrianghc I had the same issue on a preview build of Windows and became so frustrated with it and the fact that Microsoft was completely ignoring my reports of this problem that I reinstalled Windows and made sure I didn't use an Insider build for Windows OR a beta build of Edge. Things were great, until the October update yesterday. Now the problem has returned, with no acknowledgement of the problem or effort to fix. I've even tried turning off the Alt-Tab Edge feature, but the problem persists. The only solution I've found is to get rid of Edge and use a different browser.

@adrianghc I ran a search for Edge and File on the link you sent and didn't find the problem. Would you mind telling me where you saw that it was fixed?

Also, I was running that build before I reinstalled Windows I still had the issue. I actually had whatever the latest insider version was as of about 6 days ago. Are you running this build and the problem is gone for you? In my experience, the problem did not always show, but over the course of a couple of days I would encounter it.

"We fixed an issue that could result in your ALT + Tab order changing unexpectedly and leading you to switch to the wrong window."

I thought that refers to the issue at hand. But I'm not running that build, it just sounded to me like it would be that. Also, the bug was acknowledged here: https://github.com/microsoft/WinDev/issues/40

@adrianghc Ah, I don't think that's the same thing as our issue. It's not that the order changes, it's loading an Edge tab (often multiple tabs) as File Explorer icons, which isn't a problem with alt-tab, but a problem with how Windows 10 is displaying the Edge browser on the taskbar.

I'm stupid, sorry. I had forgotten what my own thread here was about. Yes, you're right, of course. However, I also reported the issue at hand in the Feedback Hub and got my feedback there added to a collection, so I guess they're at least aware of it: https://aka.ms/AAa29c9

@adrianghc Oh, that's good to know. I reported it a couple of times on the Hub and nothing ever happened with it. What I find really strange is why this isn't a massive problem affecting thousands of people, especially with the October update going out to everyone now. What is it about my system, even after doing a fresh install of Windows, and running no beta or dev versions of Win or Edge, that's causing this?

Do you happen to use virtual desktops? One thing I think I've noticed is that switching between desktops often serves as a trigger for this. Now you would need people who a) use Edge b) use Windows 10 20H2 or higher c) use virtual desktops d) care about this, which all things considered may not be such a big number.

@adrianghcYes, in fact I do use two virtual desktops. So that is the trigger, huh? Well I can see this issue being swept by the wayside while 20H2 was in a dev channel, but now that it is the main Windows 10 update going out to all users, it can't be considered an insignificant issue, no matter how few people might encounter it.

It may not be the only trigger, but in the months I've been seeing this bug I've very often seen a wrong thumbnail appear right in the moment where I switched between two desktops. I agree that it's not an insignificant issue but based on prior experience it's unfortunately exactly the sort of issue I could imagine existing for many months before someone finally decides it's worth putting effort to. Fingers crossed that's not the case this time.

@adrianghc 

Hello,

 

I have a similar problem.


No I have exactly the same problem and I'm using Edge Chromium, virtual desktops and I'm in 20H2 (19042.572).

 

Q1prllFScM1QvG

 

@adrianghc Yup you are absolutely spot on, I tried it on all the windows devices with Windows 10 20H2 and MS Edge and it happens all the time with virtual desktops. Its annoying as I can't not use virtual desktops as I need it for separating my work and personal windows!

Yeah, I experience this exact problem. It doesn't always happen though...

Yep same issue here, what's this weird tab that keeps showing up? This has been quite annoying to say the least. Restarting explorer doesn't fix it, but restarting edge makes the problem go away for a few minutes, but then it comes back again

 

nullptr_1-1611227572465.png


Also, edge tabs on Alt+Tab are disabled, in case that might with debugging

nullptr_0-1611227707472.png

 

I'll probably be switching to firefox in the meantime. Unfortunately votes seem to dictate the attention (or lack thereof) towards some workflow-breaking issues

 

     I encountered this after restarting as part of installing the February 2021 cumulative update for Windows 10 20H2 (v19042.804.)  (I recently also switched from using 2 virtual desktops to having 3 open to accommodate an additional task, but that was before the update and the bug wasn't manifesting then.  Odds are this's a Heisenbug, though…)  I have Edge set up to pick up where I left off when I start it up at the moment.  


     (Update: Closing and reopening the offending window appears to fix the issue.)

@Bryce Glover 

 

I just switched to Brave and haven't looked back. Ridiculous this bug hasn't been fixed in over half a year.

Same Problem here, with Windows Version 10.0.19043 Build 19043 and Edge Version 88.0.705.81
Having the same problem. Also, reported it many times in many boards. No response, no workaround suggestions, no fixes, no idea when it will finally be resolved. It's very annoying. I see only one possibility that this issue does not have a lot of attention from Microsoft. Apparently it is a problem of using Edge and most likely there won't be an issue with Chrome. I didn't switch back to Chrome only because I don't want to deal with moving my passwords and all other settings over but I'm really close to doing that.