No PlayReady visible with the Chromium Edge

Copper Contributor

Dear All,


I am trying to watch movies from, but it stutters with all browsers except IE v.11 and Edge v.44. The Edge Chromium also stutters.  When I check it with this website:, I get the same stuttering issue with DASH and HLS (options in the website). I can see only IE 11 and Edge 44 have Playready active in the above demo website. Chromium doesn't show Playready even after I activate it from edge://flags. It appears that only  Widevine flag works in Edge chromium. I can by the way watch MUBI movies on other PCs, with Google chrome etc.. I know that my PC is old, but Chromium doesn't show Playready activated. What do you suggest me to do?


I have:

Windows 10 Pro Version 2004. OS Build 19041.264 

Dell n5110 with Intel® HD Graphics 3000/Nvidia GT 525M (Intel is the main graphics card, doesnt matter if O select Nvidia, still I get stuttering).





6 Replies

I'm guessing you have "PlayReady Hardware DRM support: flase" in about://gpu page.
I don't know about PlayReady requirements but your hope is that's a missing requirement on the driver side, and thus with an driver update you'll be set. 

EDIT: I've now seen the screenshot you posted in the other thread and it appears you have Hardware DRM support , but you lack Direct Composition.
Too bad the latest Intel drivers for 3000 iGPU is from 2015...
Might be worth trying again with the Nvidia GPU and using the latest Nvidia drivers (from 2018) rather than Dell's OEM drivers. This way you might loose some custom vendor features, probably the ability to switch graphics too... 
Link to Nvidia GTX 525M latest available driver

As for selecting the nvidia gpu for edge in windows 10 you'd need to go to Settings -> System -> Display -> Graphics Settings (small writing, towards the bottom) -> then Browse for Edge (if you have shortcut on desktop you can select that). 
After you added Edge to that list you can select which GPU should be used for that process. Application restart is needed if it wasn't closed during the GPU preference selection.

Dear @Coddy , thanks for your detailed reply. I did the things you said but Intel is the main GPU, I can see playready under about:gpu, but in playready does not appear, playready appears only in the legacy Edge. (See the attached files)


I had the same problem with Firefox, Chrome, Opera, Brave, Vivaldi and Yandex. But what was interesting is Opera and Yandex worked fine with both movies and video (and showing no DRM in the bitmovin website), however, after some hours Widevine got activated and videos were stuttering as well as the bitmovin video.


My humble theory is:

  • It has nothing to do with direct composition. Because I maniplated Chrome by setting --disable-direct-composition=0 to shortcut and I had direct composition "true", but still the same issue. 
  • New Edge does not inherit the functionalities of the Legacy Edge (at least in my case/PC).
  • New Edge is not supporting Playready on my PC.
  • Widevine is blocking the video here : But when I disable the Widevine I can watch the video in that link without problem, but then I cannot watch the movies at all (not even stuttering). 



@mafein Here is an unofficial list of requirements needed for PlayReady/4k HD to run successfully. It may be possible to circumvent some of these, but this is what our team recommends:


  • Update the Microsoft Edge browser to the latest version.
  • PlayReady DRM for Windows 10 on edge://flags must not be disabled. See: edge://flags/#edge-playready-drm-win10.
  • The HEVC Video Extensions must be installed.
  • The "Use hardware acceleration when available" setting is enabled. See: edge://settings/system.
  • The following edge://gpu settings requirements must be met:
    • "Compositing" is "Hardware Accelerated".
    • "Direct composition" is "true".
    • "PlayReady Hardware DRM support" is "true".
  • A Windows 10 computer or tablet with the latest Windows updates installed.
  • A 60Hz 4K capable display (with HDCP 2.2 connection if external display).
    • NOTE: Every monitor connected to your computer must meet these requirements to successfully stream in Ultra HD.
  • Intel's 7th generation Core CPU (i3, i5, or i7 models in the 7xxx or 7Yxx series) or newer, or a NVIDIA GPU that meets these requirements .
  • A steady internet connection speed of 25 megabits per second or higher.
  • Streaming quality set to Auto or High. 


Fawkes (they/them)
Project & Community Manager - Microsoft Edge

Thanks for the response @Deleted, but that is a vicious cycle. Chromium Edge disables direct composition due to my GPU, but without this I cannot get Playready enables as per your response. My suggestion playready should be independent of direct composition, if not possible, direct composition should not be disabled due to GPU. Because I do have Playready with my legacy Edge version. My issue is problably that my GPU is incompatible with widevine. By the way I have no issues with watching Netflix movies. The only issue is movies and the DASH content here: . 

There is a workaround! You need to enable either playready drm or widevine drm by using Edge flags (see 2nd picture below). And for video accelerated decoding you need to enable "override software rendering list". To test if drm video streams work you can use the website . Netflix uses playready (for highest bitrate) while amazon prime uses widevine so you need to disable the other unused drm in flags. To get 4K Netflix you also need the HEVC video extensions from Microsoft: Nevertheless only the Netflix UWP App delivers the highest bitrate (you can see resolution bitrate with CTRL + Shift + Alt + Q ). For example I get over 5000 kBit/s at 1920x1080 pixels for movie Snowpiercer but only 2800 kBit/s at 1920x1080 in Edge.


Edge flags for NetflixEdge flags for NetflixEdge flags for Amazon Prime VideoEdge flags for Amazon Prime Video

edge://gpuedge://gpuPlayReady Hardware DRM supportPlayReady Hardware DRM support

There is a workaround I found today! Just disable either Widevine DRM or PlayReady DRM in edge://flags like in the images below. Both enabled (default flag is enabled by the way) does not work! And with override software rendering list set to enabled you even get hardware accelerated video decoding. On you can check which one is enabled and below in the images you can see it works flawlessly for both DRM key systems. When you also want to stream 4K Netflix you need the HEVC video extensions from here:  HEVC Video Extensions from Device Manufacturer
I get 1080p and over 4000 kBit/s bitrate for the movie snowpiercer in Netflix (view with CTRL + Alt + Shift + Q). Bitrate in Netflix UWP App is even higher and supports 5.1 Dolby sound.

PlayReady Hardware DRM supportPlayReady Hardware DRM supportedge://gpuedge://gpuEdge flags for NetflixEdge flags for NetflixWidevineWidevinewidevine.png