Home

New "Pdf reader is disabled" message

%3CLINGO-SUB%20id%3D%22lingo-sub-771729%22%20slang%3D%22en-US%22%3ENew%20%22Pdf%20reader%20is%20disabled%22%20message%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-771729%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EI'm%20working%20with%20new%20build%26nbsp%3B%3CSPAN%3E77.0.223.0%3C%2FSPAN%3E%3C%2FP%3E%0A%3CP%3ENow%2C%20when%20we%20enable%20the%20option%20%22Always%20open%20pdf%20files%20externally%22%20in%20sites%20permissions%2C%20there%20is%20this%20new%20message%26nbsp%3B%22Pdf%20reader%20is%20disabled%22.%20If%20we%20click%20on%20%22Download%20file%22%20file%20is%20downloaded%20and%20appears%20on%20bottom%20of%20the%20screen%20with%20a%20link%20%22open%20file%22.%20So%20far%20so%20good.%3C%2FP%3E%0A%3CP%3EThe%20problem%20is%20if%20we%20click%20on%20%22open%20file%22%2C%20the%26nbsp%3B%22Pdf%20reader%20is%20disabled%22%20message%20appears%20again%20and%20user%20has%20to%20browse%20manually%20in%20his%20folders%20to%20open%20the%20file%20(see%20picture%20bellow).%3C%2FP%3E%0A%3CP%3EI%20think%20this%20can%20be%20a%20little%20confusing%20for%20users.%20Is%20that%20possible%20that%20when%20we%20click%20on%20%22open%20file%22%20the%20file%20is%20opened%20automatically%20with%20default%20pdf%20reader%20in%20Windows%20%3F%20Or%20may%20be%20this%20is%20by%20design%20%3F%3C%2FP%3E%0A%3CP%3EAlso%20is%20that%20possible%20to%20let%20user%20choice%20to%20disable%20this%20message%20and%20let%20him%20download%20immediately%20the%20pdf%20(maybe%20add%20a%20%22don't%20show%20again%20checkbox)%20%3F%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F124313i15078E1719C9B356%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22reader.JPG%22%20title%3D%22reader.JPG%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EThank%20you%2C%3C%2FP%3E%0A%3CP%3EYohan%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-771814%22%20slang%3D%22en-US%22%3ERe%3A%20New%20%22Pdf%20reader%20is%20disabled%22%20message%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-771814%22%20slang%3D%22en-US%22%3E%3CP%3EThanks%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F381490%22%20target%3D%22_blank%22%3E%40yohan57%3C%2FA%3E%26nbsp%3B-%20It%20appears%20something%20is%20not%20right%20here%2C%20I%20am%20also%20seeing%20this%20behavior.%20I've%20submitted%20a%20bug%20with%20PDF%20settings%20and%20passed%20the%20feature(s)%20request%20mentioned.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1072543%22%20slang%3D%22en-US%22%3ERe%3A%20New%20%22Pdf%20reader%20is%20disabled%22%20message%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1072543%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F328980%22%20target%3D%22_blank%22%3E%40DarrenMH%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThis%20is%20still%20a%20problem%20in%20Microsoft%20Edge%20Dev%20Build%2080.0.361.5.%20The%20first%20thing%20where%20it%20goes%20wrong%20is%20that%20this%20message%20gets%20displayed%20when%20the%20%22Always%20open%20PDF%20files%20externally%22%20setting%20is%20set%20through%20GPO%2C%20meaning%20that%20users%20cannot%20change%20this%20setting%2C%20thus%20showing%20this%20message%20is%20redundant.%3C%2FP%3E%3CP%3ESecondly%2C%20after%20clicking%20the%20%22Download%20file%22%20button%20and%20selecting%20Open%20File%20from%20the%20download%20bar%2C%20still%20throws%20it%20into%20a%20loop%2C%20displaying%20the%20same%20%22PDF%20reader%20is%20disabled%22%20message%20again.%20The%20only%20way%20to%20properly%20open%20the%20PDF%20is%20to%20click%20the%203-dot%20menu%20and%20select%20%22Open%20with%20system%20viewer%22%20which%20is%20clear%20language%20for%20Administrators%2C%20but%20certainly%20not%20for%20the%20average%20user%2C%20or%20select%20%22Always%20open%20in%20Adobe%20Reader%22%2C%20which%20will%20prevent%20the%20%22PDF%20reader%20is%20disabled%22%20message%20to%20show%20in%20the%20future.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIn%20short%3A%3C%2FP%3E%3CP%3E-%20The%20%22PDF%20reader%20is%20disabled%22%20message%20should%20not%20show%20when%20this%20setting%20is%20set%20through%20GPO.%3C%2FP%3E%3CP%3E-%20Any%20open%20file%20link%20in%20the%20download%20bar%20should%20open%20it%20with%20Adobe%20Reader%2C%20not%20with%20Edge%20Browser.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F162346i8C2BF276E07D7250%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20alt%3D%22clipboard_image_0.png%22%20title%3D%22clipboard_image_0.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
yohan57
Microsoft

Hi,

 

I'm working with new build 77.0.223.0

Now, when we enable the option "Always open pdf files externally" in sites permissions, there is this new message "Pdf reader is disabled". If we click on "Download file" file is downloaded and appears on bottom of the screen with a link "open file". So far so good.

The problem is if we click on "open file", the "Pdf reader is disabled" message appears again and user has to browse manually in his folders to open the file (see picture bellow).

I think this can be a little confusing for users. Is that possible that when we click on "open file" the file is opened automatically with default pdf reader in Windows ? Or may be this is by design ?

Also is that possible to let user choice to disable this message and let him download immediately the pdf (maybe add a "don't show again checkbox) ?

 

reader.JPG

 

Thank you,

Yohan

 

2 Replies

Thanks @yohan57 - It appears something is not right here, I am also seeing this behavior. I've submitted a bug with PDF settings and passed the feature(s) request mentioned.

@DarrenMH 

This is still a problem in Microsoft Edge Dev Build 80.0.361.5. The first thing where it goes wrong is that this message gets displayed when the "Always open PDF files externally" setting is set through GPO, meaning that users cannot change this setting, thus showing this message is redundant.

Secondly, after clicking the "Download file" button and selecting Open File from the download bar, still throws it into a loop, displaying the same "PDF reader is disabled" message again. The only way to properly open the PDF is to click the 3-dot menu and select "Open with system viewer" which is clear language for Administrators, but certainly not for the average user, or select "Always open in Adobe Reader", which will prevent the "PDF reader is disabled" message to show in the future.

 

In short:

- The "PDF reader is disabled" message should not show when this setting is set through GPO.

- Any open file link in the download bar should open it with Adobe Reader, not with Edge Browser.

 

clipboard_image_0.png

Related Conversations
Display PDF in Tab
JTHOUMEL in Microsoft Teams on
7 Replies
Delete Messages Teams
cvillanueva in Microsoft Teams on
1 Replies
AIP and PDF
Rodolfo Umana in Azure Information Protection on
9 Replies